FORUMS: list search recent posts

Final Cut Pro Rendering Issue

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Heather Hodgins
Final Cut Pro Rendering Issue
on May 19, 2020 at 11:08:44 am

Hi,

I recently upgraded from a MacBook Air to the 2019 MacBook Pro 16" - 32GB RAM, upgraded the graphics card too, I was super excited to be able to edit my videos with ease and no lag, it was all going well until my harddrive accidentally disconnected from my laptop and I re-opened Final Cut and all my work from the day had disappeared, I checked the backups and there was no backups of the library since the night before (20 hours ago despite working on the project on and off all day)

Once I had re-edited the project to the point I had gotten to before I noticed it was playing back with dropped frames, I tried rendering and it renders successfully to 100% with no problem very quickly but this doesn't make a difference to the playback of the video. It was fine until the harddrive ejected and I had to re-start and I haven't made any dramatic changes, it's a very simple timeline with some speed ramping and minor colour correction, no transitions or heavy effects or keyframing.

I have also gone into the library contents and deleted all render files and re-rendered but again this hasn't worked

I'm baffled as it was working so well beforehand and it's such a simple project!

Please Help, thanks in advance!


Return to posts index

Joe Marler
Re: Final Cut Pro Rendering Issue
on May 19, 2020 at 1:19:27 pm

Make sure your hard drive is formatted HFS+ (Mac OS Extended Journaled). That is a transactional file system and sudden disconnects are less likely to cause problems than ExFAT.

Run Disk Utility Fist Aid on all drives, including the boot drive. Running it on the boot drive requires you first reboot in Recovery Mode, else the check will be advisory only, not fix anything. Also starting with Catalina the boot drive has two containers and you must run First Aid on each one separately.

Start MacOS in Recovery: https://support.apple.com/en-us/HT201314

After doing this, rebuild all Spotlight indexes on all drives: https://support.apple.com/en-us/HT201716

After that if the problem still happens, disable background rendering in FCPX preferences. Then delete all render files: Files>Delete Generated Library Files>Delete Render Files>All. Then select all clips on the timeline with CMD+A, and do a one-time render with CTRL+R.

After that completes, evaluate the performance. In general it should be very fast. If not there are a few cases where the render tracking system malfunctions, esp. if certain effects are used. It it's still slow and no render dots are showing above the timeline, state what effects are used on that clip.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]