FORUMS: list search recent posts

Render Keeps Freezing at one point

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Campbell
Render Keeps Freezing at one point
on Dec 20, 2018 at 10:03:11 am

Hello Everyone,

So I'm working on a project in FCPX and all of sudden after putting in some final edits, such as replacing the music and a few font changes, now it will always stop background rendering at ~1:33:08.

Things I tried already:
Deleting preferences (multiple times)
Copy/pasting the project in another project/event/library
Deleting and readding assets in case of a corrupt file
Deleting Generated Library Files

Any help anyone can supply would be wonderful! I needed this project sent out tonight and I haven't been able to because of it.

Thank you in advance!

Return to posts index

Gregor Queck
Re: Render Keeps Freezing at one point
on Dec 20, 2018 at 10:29:49 am
Last Edited By Gregor Queck on Dec 20, 2018 at 10:33:14 am

Duplicate project, delete all until the clip before the freeze-point, render.
That should tell you if the freezing has something to do with the fonts/effects/plugins.
If it still freezes delete the material/fonts/effects/plugins 'till it isn't cold anymore.
Hope this helps.

”Conversations don’t have to be easy to be worthwhile”
Jordan Peterson

Return to posts index

Joe Marler
Re: Render Keeps Freezing at one point
on Dec 20, 2018 at 3:18:24 pm

I saw this behavior once. The behavior was that either rendering or exporting would halt at a certain timeline point. There was no apparent error -- it just quit. Zooming deeply into the timeline showed a few anomalous black frames at the halt point. I vaguely recollect those could not be deleted or after deleting them the halt still happened at the same timecode. I made a copy of the project and it still happened, and likewise after removing all effects. Deleting and re-adding the clip from the Event Browser didn't work. I had to re-import the clip under a different filename, match timecodes for the edited range, then copy/paste effects from the original clip.

I suppose I could have tried exporting the project XML and loading that in a test library, but I didn't do that.

That was about a year ago. I don't know the cause, but I had previously experienced numerous FCPX crashes when adding multiple color corrections with the scopes up. It's conceivable one of those damaged the library. The MacOS Core Data APIs and underlying SQLite database probably don't have perfect transactional integrity. Unfortunately there is no library database integrity checker like in LightRoom or other client/server databases. I haven't seen the problem since then.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 All Rights Reserved