FORUMS: list search recent posts

Unable to Share (Export) a Project in FCPX

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
John Irvine
Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 1:21:39 pm

Hi there good people of the forum - I have completed a large 4k project in FCPX Ver. 10.4, but I'm unable to share it (export if you please!) in any way, either by writing a DVD or creating a master file, etc.

The project is 1hr 45 mins long and is fully rendered with optimised media. Each time the share fails and a box appears with the following message:

'The operation couldn't be completed. (com.apple.Compressor.CompressorKit.ErrorDomain error -1).'

By the way, thanks Apple for a pretty obscure error message, but hopefully someone out there understands it.

I have plenty of free hard drive space, so I don't think that's the problem. I don't have Compressor installed on my computer (a Mac Pro Quad Xeon 2.8 GHz) and am using FCPX's built in share options. Would I stand a better chance using the Compressor app, do you think?

Any ideas / suggestions gratefully received!

John Paul Irvine
Raemoir
Scotland


Return to posts index

Jeremy Garchow
Re: Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 1:58:13 pm

Did you try trashing your preferences?


Return to posts index

John Irvine
Re: Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 2:55:09 pm

Thanks, but no I haven't tried trashing my preferences - what exactly does that mean / do?

John Paul Irvine
Raemoir
Scotland


Return to posts index


John Irvine
Re: Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 3:01:00 pm

Well, I'm not one to hang about.... downloaded Preference Manager 4 and have now deleted my preferences.... so it's now time to retry sharing. I'll let you know how I get on.

John Paul Irvine
Raemoir
Scotland


Return to posts index

Jeremy Garchow
Re: Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 3:55:32 pm

That works.

Also, quit FCPX, then hold command-option and launch FCPX, then follow the dialog prompts.


Return to posts index

Joe Marler
Re: Unable to Share (Export) a Project in FCPX
on Oct 25, 2018 at 5:57:39 pm

If that doesn't fix it, boot into Safe Mode, run Disk Utility First Aid on all volumes, then try the export again: https://support.apple.com/en-us/HT201262

Also, what export options were you using?

Maybe there's a problem with your render files. Can you delete those file File>Delete Generated Library Files, and select "Render Files", "All", and try the export? You need not re-render the timeline before exporting. If by chance you have the Background Render preference enabled, try disabling that before deleting the render files. Sometimes the constant background rendering can cause a problem.

On an iMac, iMac Pro or MacBook Pro, the fastest export is H264 at 1080p (or even lower), done via File>Share>Master File>Settings, and select Format: Computer, Video codec: H264 Faster Encode, and Resolution 1080p (or even less for testing). For troubleshooting purposes you don't care what output resolution or codec, you just want it done quickly to try different steps.

Mac Pros don't have Quick Sync or AMD encode acceleration, so H264 encoding will be software only. On those machines I don't remember which is faster on a fully rendered timeline, H264 at 1080p or ProRes 422. I suppose you could try both.

If that doesn't work, use Range Mode via the R key, draw a small range on the timeline and export that. It will only export the drawn range. Try to narrow down where in the timeline or how much of the timeline is required to create the problem.

If that doesn't work, make a duplicate of the project, select the project in the Event Browser and use the command Edit>Remove Effects to remove all effects from the test project. Then delete the current render files and try to export it. This can help determine if it's an effect problem or a render or encode problem.

If it goes away when effects are removed, make another copy of the original project, and use the Range tool to select part of the timeline and then use Edit>Remove Effects to selectively remove effects from various timeline ranges until you find the problem.


Return to posts index


John Irvine
Re: Unable to Share (Export) a Project in FCPX
on Oct 26, 2018 at 8:54:58 am

Hi - thanks for your suggestions and here's an update to what could be a very lengthy process...

First, a little background to my footage. I filmed in 4k and V-Log gamma on my Panasonic GH5. The latter option I feel was a mistake - why didn't I just use Cine-D, for instance (being greedy?). I then applied a Color Finale LUT in FCPX to all my clips (about 40 of them). I also did some additional effecting of some clips. Then I rendered everything.

Last night I removed all effects from my clips on the timeline and then tried burning a DVD file to my hard drive - hooray, it worked! Ah, but not quite: although it completed the process and said 'Sharing successful', the resultant video only plays for 40 minutes out of about 100. So it's useless.

However, I now know that at least part of the problem lies with the effects on the clips. Can I burn the effects to the clips? I guess I would have to take each clip one at a time and export it as a new clip with effects burned in? Wow, that's a big job and I'd lose all my edits!

So, it seems that FCPX is not fit for purpose. You create a big project and then it can't handle it. How very unprofessional, I'd say. Does anyone have any experience of Apple's Compressor software? Is that a more professional platform for exporting and DVD creation?

I look forward to any helpful responses (can you tell I'm somewhat disappointed with FCP?).

John Paul Irvine
Forres
Scotland


Return to posts index

Marco Feil
Re: Unable to Share (Export) a Project in FCPX
on Oct 26, 2018 at 11:23:26 am

I've had similar issues a few times, most of the time it's a bugged or old plugin or some kind of file permissions issue with render files or optimized media.

Are FCPX and ColorFinale or any other plugins updated to the latest version?

If you're using ColorFinale only for applying LUTs you could just use the built in Camera-LUT function in FCPX instead (in the info inspector, metadata-view general).

You could export an XML of your timeline, create a new library and import the XML into that.

You could try deleting the cache files manually. It's either a ***.fcpcache file in the cache storage location you specified, or the "Render Files" and "Analysis Files" Folders inside the fcpbundle if you have set the location to "In Library".

I would not burn directly to DVD disk or image but render a ProRes master and encode that via Compressor or reimport it to FCPX, then do DVD export.


Return to posts index

Jeremy Garchow
Re: Unable to Share (Export) a Project in FCPX
on Oct 26, 2018 at 11:33:49 am

Sounds like you may have a bum plugin or old version?

Instead of color finale, use FCPX’s built in camera LUT system, as Marco mentions. FCPX also has some decent built in color correction capabilities as well.

Also, if you have a 100 minute DVD, you have to make sure that FCPX encodes the file small enough to fit on whatever style DVD you have (single layer, dual layer, etc). FCPX provides very rudimentary options for this. What settings do you use when creating the DVD? Have you checked to see if the file will fit on a standard DVD?


Return to posts index


Joe Marler
Re: Unable to Share (Export) a Project in FCPX
on Oct 26, 2018 at 12:07:09 pm

[John Irvine] "Last night I removed all effects from my clips on the timeline and then tried burning a DVD file to my hard drive - hooray, it worked! Ah, but not quite: although it completed the process and said 'Sharing successful', the resultant video only plays for 40 minutes out of about 100. So it's useless..."

When troubleshooting an render or encode problem, I suggest not burning a DVD. This introduces additional complexity and time. Focus on getting the export to a disk file working, then (and only then) try burning the DVD. Use whatever the fastest export parameters are for your specific hardware. On an iMac it's Master File>Computer>H.264 Fast Encode, and the lowest available resolution, 854x480. Even on a Mac Pro (which doesn't have Quick Sync) this might be faster than ProRes output. Once the problem is resolved you can use your preferred export type.

I have seen cases where corruption in a timeline will halt exporting and the resultant video is truncated. I resolved it by making a copy of the project, then successively deleting part of the timeline to narrow down the problem area. This is obviously easier if the behavior is consistent, IOW it tends to halt at the same place each time.

Close examination of that timeline region showed some anomalous black frames. I deleted the clip from the timeline *and* Event Browser, re-imported it, added it back to the timeline, then the problem was solved. This is a rare case and I've only seen it once.

[John Irvine] "...at least part of the problem lies with the effects on the clips. Can I burn the effects to the clips? I guess I would have to take each clip one at a time and export it as a new clip with effects burned in? Wow, that's a big job and I'd lose all my edits!.."

You can render clips with the effects and re-import them, then you can frame-match the head/tail timecode from the timeline clip to the new clip in the Browser, then draw a range on it and do a 3-point edit to overwrite the old clip. I have done this hundreds of times and it's not that bad once you get the procedure, but it should not generally be necessary. It is not clear your problems are due to all the effects, so exporting and replacing all those clips is probably not required.

Your initial goal should be examine whether exporting from a test copy of your timeline with no effects to a disk file will halt or truncate the output file. If that happens the whole issue about burning in effects is a non-issue -- it's happening with zero effects.

[John Irvine] ".... it seems that FCPX is not fit for purpose. You create a big project and then it can't handle it. How very unprofessional, I'd say. Does anyone have any experience of Apple's Compressor software? Is that a more professional platform for exporting and DVD creation?"

FCPX can handle gigantic projects -- I have edited a documentary where the library contained 8,500 4k clips, 220 hours, and 20 terabytes. I've tested complex two-hour timelines and both performance and reliability was generally good, at least on my iMac Pro. I sometimes had crashes on my 2017 iMac 27 when doing heavy FCPX color correction but never lost any data or edits. It's possible that machine had a hardware issue since the call stack would always crash in a GPU function.

When I edited with Premiere I would sometimes have crashes or unexplained render halts also. I've never used any NLE software on either Windows or Mac which did not occasionally crash when under high stress.

I suggest deleting all your render files, and also proxy or optimized media if possible. A render or corruption problem can become embedded in those generated files. You can delete only the render/proxy/optimized media from the timeline, not the entire library. Select the project thumbnail in the Browser, then File>Delete Generated Project Files. Once the problem is solved if you need the proxy or optimized files for subsequent editing performance, you can rebuild those.

After deleting all render files and rebooting both macOS and FCPX, you need to first validate whether you can export a test timeline to a *file* (not a DVD) with no effects applied. If that still halts it's not the effects. If it halts at a certain point such as +40 min into the timeline, zoom way in and inspect that region closely. Make sure there are no visible black frames. Make sure playback works on that region with no skipping, lagging or other anomalies.

If that works and doesn't show visible problems, draw a range box around the problem region, say 10 min long, then try to export that one problem region.

If that works but exporting the full timeline to a file still halts at the same place, import a new copy of the clip, copy the timeline clip attributes with CMD+C, then match the timecode from the timeline clip to the new copy in the Event Browser and do a 3-point replace edit. You then add the original clip attributes to the new clip via Edit>Paste Attributes and select which ones you want added. The avoids having to manually add them by hand. You can also do a connect edit (Q key) on top of the old clip, then use the V key to disable the original clip to verify the sync. If OK use the P key (Position Mode), and drag down the new connected clip to overwrite the original clip. Then re-try the export.

Note there is a difference between the export truncating the output file randomly vs the same approximate location each time. If it's the same approximate location that could imply corruption in a generated file for that one clip. If it's in a random location each time that might be a system problem.


Return to posts index

John Irvine
Re: Unable to Share (Export) a Project in FCPX
on Oct 27, 2018 at 10:05:56 am

Wow, thank you so much for all your help gentlemen! I'll be looking into it over the next few weeks and will let you know how I get on.

Regarding Compressor - is it worth having? I would need to upgrade my OSX to the latest version (not a bad idea) and spend £50, but is it a more reliable platform for exporting and does it do DVD authoring?

Many thanks, John.

John Paul Irvine
Forres
Scotland


Return to posts index

Joe Marler
Re: Unable to Share (Export) a Project in FCPX
on Oct 27, 2018 at 5:55:47 pm

[John Irvine] "Regarding Compressor - is it worth having? I would need to upgrade my OSX to the latest version (not a bad idea) and spend £50, but is it a more reliable platform for exporting and does it do DVD authoring?"

Compressor gives very flexible export options. It's very inexpensive. It can be used for time lapse generation: it can import a still image sequence and transcode to a 4k or native-resolution ProRes file that FCPX can then edit efficiently. Procedure linked below in MacBreak Studio #353.

If you are not already on High Sierra 10.13.6 and FCPX 10.4.3, those would be good first steps in troubleshooting your "unable to share" problem. You can spend lots of time debugging some odd behavior only to have it fixed by running the latest app and OS versions. However I would not at this point suggest Mojave until FCPX is updated.

Re export to DVD, I haven't burned a DVD in three years so I'm not familiar with the current software. This Larry Jordan article says Compressor can do it, but the best Apple authoring app was DVD Studio Pro which is long unavailable and compatibility with the latest (much less future) macOS unknown: https://larryjordan.com/articles/optimize-compressor-4-3-to-burn-dvds/







Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2020 CreativeCOW.net All Rights Reserved
[TOP]