FORUMS: list search recent posts

Motion Template Losing Track of Text?!

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Doug Metz
Motion Template Losing Track of Text?!
on Feb 7, 2018 at 2:02:27 am

Greets, peeps!

I built a very simple Title template in Motion - small rectangle slides in from the side with text overlay and then slides back out again. It works perfectly inside Motion, and it works perfectly in FCPX, too.

Until I quit / relaunch Final Cut. Then, every instance of the title loses track of the text that is supposed to move with the small rectangle, and is then out of position and can't be made to behave properly. New instances of the template dropped into the timeline work perfectly, until I quit and relaunch the app.

There was one other oddity - while it was working I did an export, and the exported file exhibited the incorrect behavior.

Help?

2013 Cylinder / 10.12.6 / Motion 5.4 / FCPX 10.4
Timeline is 1080p24

Doug Metz

Anode


Return to posts index

Doug Metz
Re: Motion Template Losing Track of Text?!
on Feb 7, 2018 at 2:36:47 am

Found the answer... in the context of FCPX plugin design, 'Align To' behaviors do not always work correctly when applied to text. Put the text in it's own Group, and apply 'Align To' to the group containing the text. All is well.

What a stupid bug.

Thank you Fox!

Doug Metz

Anode


Return to posts index

Bret Williams
Re: Motion Template Losing Track of Text?!
on Feb 9, 2018 at 1:05:48 pm

I’ve done a lot of align to work and found a number of oddities, especially performance wise, but never this one you speak of. Perhaps I got lucky.

But it really sounded more like you were putting gfx in the timeline based on a motion template and then editing the template in Motion, and then adding more instances of the template to the timeline. This would potentially exhibit this behavior. All the ones in the timeline are cached in in memory and unaffected by the changes to the master template UNTIL export as exporting refers back to the original and doesn’t rely on the cache, OR until you relaunch the app and the timeline versions are re-cached.

Many get confused and think that once they’re in the timeline, that those instances are locked and changes to the template won’t affect them but they’re completely affected. Just not until you reboot FCP. But new instances are affected immediately by any changes made to the template in motion and only require a refresh of the browser by clicking to a different category and back. Once I figured out the rules I quit getting gfx that were messed up on relaunch the next day, etc.

_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index


Doug Metz
Re: Motion Template Losing Track of Text?!
on Feb 9, 2018 at 2:30:31 pm

[Bret Williams] "But it really sounded more like you were putting gfx in the timeline based on a motion template and then editing the template in Motion, and then adding more instances of the template to the timeline. This would potentially exhibit this behavior. All the ones in the timeline are cached in in memory and unaffected by the changes to the master template UNTIL export as exporting refers back to the original and doesn’t rely on the cache, OR until you relaunch the app and the timeline versions are re-cached."

Well that's the rub - I didn't edit the template between instances. It appeared to be working correctly in Motion and in Final Cut. Even the preview scrub did the right thing. So I did all instances of that template in one pass, and it behaved / played back as intended. It was only on export that things went sideways (exported files were bad, timeline still looked perfect). Then I relaunched FCPX and saw the same problem in the timeline.

Originally, I had the rectangle and text in the same group, with 'align to' applied to the text (targeting the rectangle) and 'move in / move out' applied to the rectangle. After I put the text in it's own group and applied the 'align to' behavior to the group, it stopped losing it's mind.

It was a post by Fox Mahoney on the Apple forums that gave me the key to unlock the puzzle.

Doug Metz

Anode


Return to posts index

Bret Williams
Re: Motion Template Losing Track of Text?!
on Feb 9, 2018 at 2:39:52 pm

I don’t doubt it. Align to was pretty wack before 10.4. I tried to use it in a plugin (still unreleased) to do what you’re saying but I’m sure they were in different groups. But the problem I had was the performance. If you mixed align to with some link behaviors it would bring FCPX to its knees and possibly beachball forever. Totally fixed in 10.4. I just released Power Guides, a plugin to add rulers and guides, grid, film zones, safe zones, center crops etc and I used align to to align the XY nunber readouts to a rectangle that was aligned to Guides that are controlled by on screen controls and its error free and performs great. https://bretfx.com/power-guides so all seems fixed except for this new group issue. Good to know!

_______________________________________________________________________
http://BretFX.com FCPX Plugins & Templates for Editors & Motion Graphics Artists
Hang Tag http://bretfx.com/product/hang-tag
Overshoot Text http://bretfx.com/product/overshoot-text/
Outliner http://bretfx.com/product/outliner/
Clock Maker http://bretfx.com/product/bretfx-clock-maker/


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]