FORUMS: list search recent posts

FCPX constantly freezing Client review tomorrow

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Larry Watts
FCPX constantly freezing Client review tomorrow
on Oct 30, 2017 at 10:04:53 pm

Is there a way to figure out why I'm getting the spinning sphere and FCPX not responding messages?

Just now I opened a project and it froze immediately.

Do libraries cause freezing?

Or projects?

I've never tried to read a report being sent to apple.

I'm in a bind.

Any help appreciated!

Larry



Return to posts index

Jeff Kirkland
Re: FCPX constantly freezing Client review tomorrow
on Oct 30, 2017 at 11:00:21 pm

The bad news it could be any number of things from a bad library to corrupt preferences to a slow hard drive.

Which version of FCPX? Are other libraries working ok? Have you tried opening a backup of the library? Any GPU intensive plugins applied?

In my experience, a beach ball right on load is either a hard drive issue, a plugin issue, or a cache issue - but there are literally a hundred reasons it could be happening so I've got more questions than answers, sorry.

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index

Anton Antokhin
Re: FCPX constantly freezing Client review tomorrow
on Oct 31, 2017 at 3:04:13 am

My troubleshooting routine:

-restart app, restart machine
-trash FCPX prefs
-try new project/library, copy old media there (is there a specific file or plugin that's causing this?)
-try a fresh user account
-last resort is a fresh install


Return to posts index


Joe Marler
Re: FCPX constantly freezing Client review tomorrow
on Oct 31, 2017 at 11:02:36 am

As Jeff said, it could be hardware, system layer or software. A common problem is running out of disk space which then destabilizes the OS or the app. Check you have plenty of free disk space on all drives.

Before you start FCPX, verify you are getting expected performance on each drive by running Black Magic speed test: https://itunes.apple.com/us/app/blackmagic-disk-speed-test/id425264550?mt=1...

General FCPX troubleshooting recommendations from Apple: https://support.apple.com/en-us/HT203477

My own suggestions (inc'l some of the above):

(1) Locate and make a manual backup of the current library. Reason: even though FCPX automatically makes backup copies of the library every few minutes, this is an additional safety step before proceeding further. Note: this assumes you're using only external media. Duplicating the library may not be practical if you are using a managed library with all media inside -- it is likely too large to duplicate.

(2) When located, right-click that library in Finder and select "duplicate"; wait a few seconds. That makes a duplicate copy with a numeric suffix. This doesn't fix anything it's just a contingency backup.

(3) If FCPX won't start normally, reset FCPX preferences. This discards a few user-configurable preferences that can easily be set again. FCPX is known to become erratic if this file is damaged. Procedure: while FCPX is not running, press OPT+CMD and click on FCPX in the dock at bottom. It will ask do you want to reset preferences. You say yes.

(4) After a minute it should start up looking like a new installation with "Welcome to FCPX". If it won't start even, then it's a deeper problem. If it does start the problem was data-specific, probably inside the library or due to a damaged preference file.

(5) Set your preferences back to preferred values in the menu Final Cut Pro>Preferences, esp turn off background rendering while you are troubleshooting.

(6) Resetting preferences deletes the last known location of the library, so you can load that from Finder by double-clicking on it. It should load into FCPX. If it does load OK the problem was corruption in the preference file. If it does not load normally the problem was in the library.

(7) If it does not load properly or FCPX hangs, you'll need to force down FCPX by doing OPT+CMD+ESC. IF that doesn't work you can gracefully force down macOS by holding down CTRL+OPT+CMD+Eject key (at upper right).

(8) If FCPX won't launch with your main library, you must launch it without that. While holding the OPT key, click on FCPX in the dock. This makes it starts without loading any specific library, and gives you the option of what to load. Click "new" to create a new test library and make sure the program will at least start with a blank library.

(9) If it starts with a blank library the next step is try the previous auto-backup version of the main library. To do this:

(a) With FCPX up, pick menu File>Open Library>From Backup, then pick "Other"
(b) A list of library backups will be shown. Pick the most recent one.
(c) If that loads OK, examine your most recent work and see what is there.
(d) If it does not load OK or FCPX hangs, repeat the above procedure and pick the next most recent library.

(10) If none of those work, some users have reported deleting the "flexolibrary" file inside the library bundle has fixed some problems. Always have a backup copy of the library, although if it's very large due to managed media this could be difficult.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]