FORUMS: list search recent posts

Render Optical Flow

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Thanos Papadopoulos
Render Optical Flow
on Oct 16, 2017 at 6:47:23 pm

Is it only me having problems when I need to render clips with speed segments and optical flow (video quality)?
This thing happens often with different clips and on different macs. These clips cannot be rendered! I have to export it and reimport it to see these clips. Is it a bag?

Fix it in Pre.


Return to posts index

Noah Kadner
Re: Render Optical Flow
on Oct 16, 2017 at 8:09:08 pm

Anything's possible with the right combination of source media and system specs but as a general workflow- working fine here.

Noah

FCPWORKS - FCPX Workflow
FCP Exchange - FCPX Workshops
XinTwo - FCPX Training


Return to posts index

Jeff Kirkland
Re: Render Optical Flow
on Oct 16, 2017 at 8:59:43 pm

It's just you. Optical flow is working as expected on the three macs in my office.

----
Jeff Kirkland | Video Producer & Cinematographer
Hobart, Tasmania | Twitter: @jeffkirkland


Return to posts index


Thanos Papadopoulos
Re: Render Optical Flow
on Oct 16, 2017 at 9:18:18 pm

Optical flow with 2 or 3 speed segments renders normally?

Fix it in Pre.


Return to posts index

Noah Kadner
Re: Render Optical Flow
on Oct 16, 2017 at 9:22:48 pm

No issues here. However if you can make it happen consistently-

http://www.fcpworks.com/submitting-better-fcpx-feedback-to-apple/

Noah

FCPWORKS - FCPX Workflow
FCP Exchange - FCPX Workshops
XinTwo - FCPX Training


Return to posts index

Joe Marler
Re: Render Optical Flow
on Oct 17, 2017 at 12:28:43 am

[Thanos Papadopoulos] "This thing happens often with different clips and on different macs. These clips cannot be rendered! I have to export it and reimport it to see these clips"

I have seen this behavior periodically, and I've seen others report it. I think it's a bug. However you don't need to export and re-import it. The optical flow is usually being calculated correctly upon export, but it doesn't always render visually properly in the timeline.

I've seen reports that deleting generated library files might make the problem temporarily go away. Also if you are using optical flow on a speed ramped clip that can cause it. In that case try blading the clip and only apply optical flow on the bladed section.


Return to posts index


Thanos Papadopoulos
Re: Render Optical Flow
on Oct 17, 2017 at 4:13:44 am

Thanks Joe.

Fix it in Pre.


Return to posts index

Jeremy Garchow
Re: Render Optical Flow
on Oct 17, 2017 at 6:41:36 pm

I also think Optical flow cause weirdness if the clip and timelknenframe rate mismatch (30p clip in 24p timeline, or similar).

Not sure if it applies to you, but other than that, I find optical flow to work really well most of the time, depending on what I’m trying to slow down.


Return to posts index

Thanos Papadopoulos
Re: Render Optical Flow
on Oct 17, 2017 at 8:22:07 pm

I use optical flow really often and helps me a lot too. I don't think that is a frame rate issue but I'll check this out next time and I'll update this thread.
I am a freelancer editor so I use different editing suits and I'll confirm if it's a hardware or software problem.

Fix it in Pre.


Return to posts index


Doug Metz
Re: Render Optical Flow
on Oct 17, 2017 at 10:31:14 pm

I also use it regularly, and can corroborate Joe's findings. Had this problem last week on a 30p animation (matching timeline frame rate). Timeline showed unrendered optical flow sections but was able to output successfully.

Doug Metz

Anode


Return to posts index

Nikos Papadopoulos
Re: Render Optical Flow
on Oct 30, 2017 at 12:51:34 pm

Usually this happens if the system has NVIDIA instead of AMD. If you're on a Mac Pro (pre 2013) and have installed a custom NVIDIA card, know that this is usually the cause. If you're on a laptop with NVIDIA, again its a bug. After working on the latest MBPro 2017, all these issues disappeared for me.

Passion and knowledge put to work
nick314.com


Return to posts index

Thanos Papadopoulos
Re: Render Optical Flow
on Oct 30, 2017 at 12:59:54 pm

Thanks I'll check it. Although I have seen this to 2 mac pro (one 2013 and one older) and one Imac 2014. But I'll check the graphic cards.

Fix it in Pre.


Return to posts index

Joe Marler
Re: Render Optical Flow
on Oct 30, 2017 at 9:16:34 pm

[Nikos Papadopoulos] "Usually this happens if the system has NVIDIA instead of AMD"

I have four Macs with AMD GPUs and I periodically see this problem on all of them. As soon as 10.4 is released I'll test that.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]