FORUMS: list search recent posts

FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sam Lee
FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 17, 2017 at 2:17:15 pm

I'd not upgrade to 10.3.3 unless the basic file i/o bug is fixed.
The bug is carried over to the latest Compressor 4.3.2 as well.
Everything was working fine until the update was made couple days ago.
All of the sudden exporting to a simple 1080p Pro Res 422 will result in error.
In 10.3.3, you'll get a disturbing yellow triangle warning notice all of the sudden.
It doesn't matter if the original media in the sequence is mp4, AVC-I 100, Pro Res 422...

Reverting back to 10.3.2 via disk image backup.
Lesson learned: ALWAYS MAKE A FULL OSX DISK IMG backup before any update.


Return to posts index

Jeremy Garchow
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 17, 2017 at 6:50:57 pm

If you toggle the codec in the "Settings" window of the export, it goes away and you can export.

Seems like a little bug.


Return to posts index

Sam Lee
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 17, 2017 at 7:30:46 pm

It's minor if you don't have any 3rd party plugins. I have Subtitles 4.0 and it wouldn't export. Totally stopped. That's major. Happened on 5 different Macs (El Capitan-Sierra) with different media content and hardware configs. It cannot be my media or the hardware setup. Reverting back to 10.3.2. Luckily the project code hasn't changed so anything saved 10.3 will work.


Return to posts index


Jeremy Garchow
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 17, 2017 at 7:42:17 pm

[Sam Lee] "It's minor if you don't have any 3rd party plugins. I have Subtitles 4.0 and it wouldn't export. Totally stopped. That's major. Happened on 5 different Macs (El Capitan-Sierra) with different media content and hardware configs. It cannot be my media or the hardware setup. Reverting back to 10.3.2. Luckily the project code hasn't changed so anything saved 10.3 will work.
"


Did you contact the plug in maker?

I have 3rd party plugins. If I toggle the codec from "source" to anything else and back to "source" the little warning goes away. This doesn't happen when you toggle?

Have you tried anything else like a preference trash?


Return to posts index

Sam Lee
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 18, 2017 at 5:30:17 am

This particular plug in warning didn't go away but it abruptly stopped after several minutes. The only way to workaround this is to restore back 10.3. Use older version of Subtitles 3.01 and recreate it from scratch. Then it would export all OK without any warning whatsoever. However, the transcoding time is couple of hours slower than the latest 10.3.3.

I didn't trash any prefs. I contacted the plug-in developer and they're just beginning to be aware of this bug and working on it. I don't have weeks or months to wait for the fix. Restoring the disk image back 5 months ago works for me (minus the new features enhancements with 10.3.3).

I noticed (after 4th restore from the disk image) that the latest security upgrade patch has a factor in messing the export as well. Couldn't figure out what it was until on the 4th attempt I didn't upgrade anything (10.11.6 El Capitan) and all OK. For 10.12.4 Sierra OS, it behaved a bit differently. The latest security didn't affect it much. That annoying yellow triangle warning would go away after I click on a different setting. And fortunately it remained that way until I relaunch FCP 10.3.3 or restart the Mac.

The bottom line here is that this bug is related to OSX as well. El Capitan & Sierra behaved differently. Only time will resolve this bug.


Return to posts index

Doug Metz
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 18, 2017 at 9:33:34 pm

[Jeremy Garchow] "I have 3rd party plugins. If I toggle the codec from "source" to anything else and back to "source" the little warning goes away. "

This works for me as well. I've been doing a little digging and found that changing the default codec in preferences, restarting FCPX, and changing it back to ProRes 422, I still see the warning triangle but can now ignore it - exports a perfectly compliant file without having to toggle the codec on every export.

Console shows that FCPX kicks the same error on every try:
Apr 18 16:20:33 DMpro Final Cut Pro[532]: assertion failed: 16E195: libxpc.dylib + 74307 [ABC45890-DA23-3A4A-B50B-1384BD4CBBDF]: 0x89

Doug Metz

Anode


Return to posts index


Jeremy Garchow
Re: FCP 10.3.3 major export bug: Error 10008 - Video rendering error (ProMSRenderTool:renderVideoFrame
on Apr 19, 2017 at 12:10:27 am

Good tips.

Thanks, Doug!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]