FORUMS: list search recent posts

FCP X Failing to de-interlace footage

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Pippa Young
FCP X Failing to de-interlace footage
on Feb 1, 2017 at 3:43:56 pm

Hi All,

I'm sorry to add another question to the much written about progressive/interlace problems but I feel like I'm going in circles and can't find where the fault lies so I'd really appreciate some help.

I have been using the same camera (Canon XF100) and Mac Pro (OS Sierra 10.12.3) to edit and the footage always comes out looking great.
After updating to the new FCPX (v 10.3.2) the next video I exported had those horrible interlaced lines on them which I'd never seen before. FCP was telling me that footage I'm sure is progressive is interlaced and coming out horribly. I tried using the de-interlace button on the footage, changing the timeline to progressive, keeping it as interlaced, exporting as both. Nothing works! What is really strange is that in the original file the footage looks fine, and in the FCP window it appears fine but when exported it looks so much worse, here is a screenshot of original media & exported media:




Here is a screenshot of this clip's file info.

Please help, these interlacing lines are causing lines in my forehead!!


Return to posts index

Brett Sherman
Re: FCP X Failing to de-interlace footage
on Feb 2, 2017 at 12:58:33 pm

Try unchecking the "Deinterlace" button. And use the "Field Dominance Overide" above it and try different options to see if one of them works better.

--------------------------
Brett Sherman
One Man Band (If it's video related I'll do it!)
I work for an institution that probably does not want to be associated with my babblings here.


Return to posts index

Joe Marler
Re: FCP X Failing to de-interlace footage
on Feb 2, 2017 at 5:39:26 pm

[Pippa Young] "using the same camera (Canon XF100)...After updating to the new FCPX (v 10.3.2) the next video I exported had those horrible interlaced lines on them which I'd never seen before. ...that footage I'm sure is progressive is interlaced and coming out horribly. I tried using the de-interlace button on the footage, changing the timeline to progressive, keeping it as interlaced, exporting as both. Nothing works! What is really strange is that in the original file the footage looks fine, and in the FCP window it appears fine but when exported it looks so much worse..."

This is a tricky area. The XF100 can shoot either interlaced or progressive footage. Is there any possibility it was switched to interlaced for any of this footage, or has been interlaced all along? You can't trust visual playback behavior because various playback tools act differently. E.g, VLC defaults to "don't deinterlace", whereas it appears QT Player 10 automatically deinterlaces -- at least some of the time, likely based on header fields in the video file.

Even if you select 1080p/25, your XF100 may be using "Progressive Segmented Frame" (PSF) encoding, whereby 25p content is encoded as 50i. Editing and playback software may not always interpret this correctly: https://en.wikipedia.org/wiki/Progressive_segmented_frame

It's often good to inspect original vs exported video file characteristics with a tool like Invisor: https://itunes.apple.com/us/app/invisor-media-file-inspector/id442947586?mt... or MediaInfo: https://itunes.apple.com/us/app/mediainfo/id510620098?mt=12 I prefer Invisor since it can display several file headers side-by-side in a spreadsheet-like format.

I did some brief tests with some older 1080i AVCHD content from a Canon HF-G10 and I see similar behavior to what you report -- on both 10.2.3 *and* 10.3.2. In both cases dropping a 1080i/29.97 clip into an "automatic settings" project creates 1080i/29.97 settings. It looks OK within FCPX but has obvious interlacing comb artifacts (as seen by QT Player) if exported -- no matter what deinterlace and field dominance settings are used. With VLC you can manually invoke deinterlacing and make it look better. In this case QT Player does not automatically deinterlace.

I tried all combinations of FCPX deinterlace and Field Dominance settings on both FCPX 10.2.3 and 10.3.2, and none of them prevented interlaced-looking output -- when viewed in QT Player or VLC without turning on deinterlacing.

If I drop the 1080i clip into a 1080p project, then export with the default settings (deinterlacing off), it looks OK. Likewise if I re-wrap the 1080i AVCHD content with EditReady before importing it, the exported file looks OK in QT Player.

Importing the same 1080i clip into Premiere CC 2017, letting it automatically create a sequence then and exporting it to H264 looks OK.

There are two key metadata fields in the video file header, Scan Type and Scan Type - Store Method (thereafter shortened to "Store Method").

Examining the video file headers with Invisor shows my original 1080i file is Scan Type = Interlaced, Store Method = "Separated fields", and Scan Order = Top Field First. Note these fields are advisory -- they should (but don't always) indicate the physical encoding. Playback and editing apps can (but don't always) read these fields and take proper action.

The file exported from Premiere is marked Scan Type = Interlaced, Store Method = Separated Fields, whereas the files exported from a 1080i project in FCPX 10.2.3 or 10.3.2 are marked Scan Type = MBAFF (Macro Block Adaptive Field Frame), and Store Method = Interleaved Fields. MBAFF is a special feature of AVC encoding which mixes progressive and interlaced content in a single frame. I don't know if the data is really encoded that way or if FCPX simply marks that in the file header.

With the 1080i file imported to a FCPX progressive project, the output file is marked Scan Type = Progressive, Store Method is blank. The actual content is probably deinterlaced during render/export.

My first guess would be FCPX is erroneously marking the metadata field Scan Type as MBAFF, Store Method as "Interleaved Fields", and isn't physically deinterlacing the footage when you click the deinterlace check box. Hence the output files are still interlaced but the playback software reads these fields and is fooled into not deinterlacing for display purposes. When I upload a test clip to Youtube or Vimeo it looks OK so they must somehow be deinterlacing it regardless of the file header. It superficially looks like an FCPX bug, but it could be a "standards issue" regarding how software should interpret those fields, maybe in the case of Progressive Segmented Frame content.

My recommendations: Verify whether your original camera files are interlaced using a tool like Invisor. I am guessing they are. If so you can try putting those into a manually-created 1080p project, export them and see how they look.

I will study this a bit more and give Apple a call. Fortunately my group hasn't shot any interlaced content in several years but we have a lot of archival interlaced content.


Return to posts index


Pippa Young
Re: FCP X Failing to de-interlace footage
on Feb 8, 2017 at 6:16:47 pm

Hello Joe,

Many many thanks for such an in depth and constructive reply! It’s very kind of you to take the time to look into this issue and share your two cents.

It’s easy to overcomplicate interlaced/progressive problems but your post makes things clearer.

On your recommendation I purchased Invisor , a good tool for file inspection. As I suspected the files that refused to be deinterlaceds were interlaced in the first place so at least FCP recognised them correctly.
I used Handbrake fairly successfully to de-interlace my export but the quality loss is more definite than when FCP does work de-interlacing clips. How strange that it should fail to do so with some clips and work on others! It
My output is web upload so VLC/Quicktime de-interlacing is not helpful here unfortunately. I also realised today that YouTube de-interlaces which is very handy!

You recommended putting the definitely interlaced clips into a manually-created 1080p project in FCP but I tried this before and still got ugly lines. I think I will use an external programme- Handbrake, EditReady to defeat the interlace problem. Would you deinterlace with EditReady for the highest quality output?
MBAFF is a confusing concept, no wonder FCPX gets in a muddle!


I might buy EditReady rather than continue trying to get FCP to sort out these issues.
I hope you don’t mind if I ask another question, about EditReady, I did some reading and I wondered… Many editors re-wrap all their footage with this programme before importing into FCP or Adobe. I know it makes file naming more efficient and can sort out messy AVCHD files but does it also make for a quicker render from Compressor? Compressor seems to struggle with my hour long videos and often gives me 5 hour render times, I was wondering if a re-wrap of the footage first through EditReady would speed up these render times?

Many many thanks for your time and help, greatly appreciate it!

Pippa


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]