FORUMS: list search recent posts

Black frame around transition

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Paul
Black frame around transition
on Oct 18, 2016 at 3:55:55 pm

So I am using the Clothesline transition and I have got a BLACK frame (complete black background) behind my picture while it fades in. Of course this is undesired.

In detail: I have a compound clip- inside this nest I have got a JPG which I have scaled down and a text above it as a connected clip. I fade both in (inside the compound) using the Clothesline transition. The compound clip is a connected to the main story line. The main story line is just a background I am using throughout the entire movie (I wish a background wasn’t my primary story line but since it’s the background it has to be the „first“ track.)Before I nested everything I just applied the transition towards the connected clip but it would move out the background from the primary story line and move it back in again instead of applying the transition JUST to the connected clip.

Thing is: I have done EXACTLY the same thing before (in the same time line) and there I do not get the black frame so I guess it’s a bug. No idea what to do about it.


Return to posts index

Noah Kadner
Re: Black frame around transition
on Oct 18, 2016 at 7:12:28 pm

Hard to tell without a screenshot but I would suggest the transition on the Compound not the contents. I would guess the JPEG doesn't cover the frame entirely and you're seeing bleedthrough.

Noah

FCPWORKS - FCPX Workflow
FCP Exchange - FCPX Workshops
XinTwo - FCPX Training


Return to posts index

Michael Paul
Re: Black frame around transition
on Oct 19, 2016 at 8:53:39 am



This transition works for one clip just fine (though I had problems with it for the first time where the image would glitch / parts of it would dublicate and already move in where they weren't supposed to move in. Really weird and would always happen. I've simply masked out the "glitches" but later I noticed the mask wasn't needed anymore and FCPX could display it just fine). I dublicated that compound clip and replace the JPG with another JPG and DRAGGED the Clothesline transition onto the head/beginning of the bottom clip/JPG in the primary story line. I think THIS is where the problem lies. This causes the black frame around my transition. I think this is what's going on: FCPX wants to transition from A to B. It doesn't want to create a transition out of nothing like a fade in or animate in. So it fades from nothing AKA black to my JPG. The thing is: It works fine for the original compound clip BUT I can not recreate this. If I DELETE the transition from the original compound clip and drag it onto it's head again I will get the same problem. So I think dragging it onto the head is the problem. Maybe I have to drag it differently and I am so stupid that it lies somewhere where FCPX wants to transition from something that lies BEFORE it. I am not sure. Maybe you know how to apply a transition just to the beginning of a clip so that it doesn't look what lies before it.

I hope what I have written makes sense and isn't too cryptic. THANKS A MILLION! You guys rock.


Return to posts index


Michael Paul
Re: Black frame around transition
on Oct 19, 2016 at 9:09:30 am

I thought I could be super clever by opening the transition inside of Motion. So I’ve opened the transition as a copy inside of Motion but there isn’t much I can do / Motion let’s me do. I just want that FADE IN. I do not need the fade out of something because there is nothing. So here are some ideas I’ve had:

1) Disable Transition A and just display B. I couldn’t delete Transition A (and maybe just save it as motion template and not transition) so I clicked on „hide“ but this didn’t work when I’ve used it in FCPX.

2) I like the motion of Transition B (the drop zone) swinging in from the side so I thought I could simply select transition B and copy it into a new motion project (or generator) and just use it like that. Unfortunately Motion doesn’t let me copy the transition B layer around.

I’ve noticed there is one layer called „color solid“ and I think this is the black frame but I also can not get rid of it.


Return to posts index

Michael Paul
Re: Black frame around transition
on Oct 19, 2016 at 9:39:37 am

I just realized that I get this black frame with pretty much ANY transition. I apply a Lens Flare to a connected clip and at some point I get a black frame during the transition. This renders pretty much any transition useless.


Return to posts index

Michael Paul
Re: Black frame around transition
on Oct 19, 2016 at 3:44:46 pm

10709_test.zip

Here I have recreated the problem. It works just fine on the first clip but on the second clip I get the black frame. I am pretty sure that I am doing something wrong and I just don't know how to tell FCPX "Just apply this transition to the clip and not to anything BEFORE it" or something like that. Please take a look at the file. I hope I did the file uploading right. Thank you guys.


Return to posts index


Jeremy Garchow
Re: Black frame around transition
on Oct 19, 2016 at 5:53:47 pm

Open up your "Untitled Project Clip 2" Compound clip and put the still frame above the text, like this:




Should solve the problem.


Return to posts index

Michael Paul
Re: Black frame around transition
on Oct 20, 2016 at 9:26:07 am

WOW! Amazing! This actually did the trick. WOW I am seriously impressed. This place is seriously the best with the greatest people. You guys really rock.

Do you have any idea why it works when I do it like that also I am still curious why it works on the first one. I think I have also found a solution: I need to drag and drop the transition onto the clip so that it creates the transition automatically at the end and at the beginning of the clip and then I delete the end. For some reason FCPX only adds a transition towards the end OR the beginning if I drag it onto my clip. I've already tried to drop it at any position of the clip but I always only get a fade in or fade out but not both at the same time. No idea what is causing THIS now.


Return to posts index

Jeremy Garchow
Re: Black frame around transition
on Oct 20, 2016 at 3:51:30 pm

[Michael Paul] "You guys really rock."

Couldn't have done it without you posting the file, so thanks for that!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]