FORUMS: list search recent posts

Strange transition behavior - please advise.

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Tangier Clarke
Strange transition behavior - please advise.
on Jul 21, 2016 at 8:21:40 pm

I have a graphic I am laying on top of my video - think a mobile phone notification. The transitions I've used in FCP X don't seem to work right. It has to slide on screen than slide off.

Using the slide transition, the graphics slides on just fine at the head of the clip where one the graphic is affected. However using the transition to slide out at the end of the clip affects the base video on the storyline rather than just sliding off the image.


Return to posts index

Bret Williams
Re: Strange transition behavior - please advise.
on Jul 21, 2016 at 8:41:58 pm

The slide transition has a couple preferences. Push will also grab everything under it. Slide does not. Make sure you didn't just choose the push choice or the push transition. (or vice versa on everything I said)

You can also right click, open in motion, and turn off the background layer tracks. But you'll have to clutter up your transitions with a copy. A copy that will have to be installed on anyone else's computer that needs to open the project.


Return to posts index

Tangier Clarke
Re: Strange transition behavior - please advise.
on Jul 21, 2016 at 9:11:25 pm

At least I am not crazy. This has been a bug (at least I think it's a bug) that is really problematic - forcing me to have to build things in Motion rather than just use a transition.

Same goes for the built in shape mask filter and then making compound clip of things with masks on them - gets all messed up.


Return to posts index


Bret Williams
Re: Strange transition behavior - please advise.
on Jul 21, 2016 at 9:33:05 pm

So did my suggestion work? Works for me. It isn't really a bug. If you open the transitions up in Motion you'll see how it works. It's actually great when you want to push off a 20 layer stack with one transition and no compounds.

That said, there is a workaround. Instead of putting the transition at the start, slice the start of the clip and make the left of the slice 100% transparent. Add the transition on the slice. Now, since you're providing an A source (that's transparent) it uses that instead if grabbing the background.


Return to posts index

Tangier Clarke
Re: Strange transition behavior - please advise.
on Jul 21, 2016 at 9:30:40 pm

Another case of simple human error and I just need to slow down. I see what you're talking about now. I was only paying attention to the direction and not the "type" option.

Arghh


Return to posts index

Bret Williams
Re: Strange transition behavior - please advise.
on Jul 21, 2016 at 9:55:39 pm

Oh its a definite complaint many have. Other transitions don't leave that option. So you have to do the workaround or change in Motion.


Return to posts index


Noah Kadner
Re: Strange transition behavior - please advise.
on Jul 22, 2016 at 12:48:18 am

Also nesting the clip into a Compound Clip can override this behavior on a lot of transitions. But completely agree: it should be a preference.

Noah

FCPWORKS - FCPX Workflow
FCP Exchange - FCPX Workshops
XinTwo - FCPX Training


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]