FORUMS: list search recent posts

Compound clips played in event load previous version of project for some reason

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ned Thorne
Compound clips played in event load previous version of project for some reason
on Dec 16, 2015 at 8:38:23 pm

I'm using FCPX 10.2.1 on a late-2014 iMac with OS X 10.10.4.

I'm cutting a feature, and so have my audio and video clips synced into compound clips for each take, and placed into events by scene number. That it, each scene event contains the original audio and video clips as well as the synced compound clips. Additionally, in each scene event, I have various cuts (projects) of that scene.

My issue is this: say I review Cut 1 of a particular scene and decide I want to make changes. I duplicate the scene in the event, and open the new Cut 2 project. Then I want to put in a shot. I highlight a synced compound clip in the event, intending to select my range and edit it into the project sequence, like you do. However, when I play my selected clip in the event, FCPX stops in its tracks and loads the PREVIOUS sequence I had open (Cut 1) and starts it playing. I have to then stop it playing, re-open Cut 2, and only then can I go play a clip in the event and edit as normal; that is, FCPX does not open the previous sequence a second time.

What seems to be happening is that FCPX knows what clip I'm trying to play but for some reason associates it with the previous sequence (because some portion of it has already been cut into that previous version I guess), and so opens THAT sequence when I go to play that clip. This is utterly baffling behavior, but appears to be how FCPX is designed to work.

Can anyone a) explain exactly what FCPX is playing at with this ass-backwards methodology and b) how to make it NOT do it anymore? It's a very irritating quirk.


Return to posts index

Jeff Kirkland
Re: Compound clips played in event load previous version of project for some reason
on Dec 16, 2015 at 9:16:40 pm

I think FCPX is playing at being broken. I use compound clips the way you are (if I'm falling what you're doing properly) and I've never had an issue. Have you tried the basics like resetting the preferences, copying things to a new library, or reinstalling FCPX?

I know that's the equivalent of a tech support guy telling you to turn the computer off and on again but, from my experience at least, what you're describing isn't normal so you've got to start with the simple fixes and work on up from there.

Jeff Kirkland | Video Producer | Southern Creative Media | Melbourne Australia
http://www.southerncreative.com.au | G+: http://gplus.to/jeffkirkland | Twitter: @jeffkirkland


Return to posts index

Ned Thorne
Re: Compound clips played in event load previous version of project for some reason
on Dec 16, 2015 at 9:27:58 pm

Thanks for your response, Jeff. I experienced this issue in a previous library (and, if I recall correctly, in both 10.1 and 10.2), so perhaps it's some preference that's set funny. FCPX preferences are laughably pared down, as I'm sure you know. It seems to be a legit FCPX operation, but one I just don't understand. Perhaps the developers assumed that those using the program would never have reason to duplicate sequences, and so this automatic opening behavior is supposed to be a convenience? The going wisdom among film editors seems to me to be that FCPX has lots of nice features, but is ultimately a program designed for amateurs working on much smaller scale projects than entire features, and that Apple is only gradually catching up.

At any rate, I guess I can try trashing my preferences and see if that clears things up. As I said, it's not insurmountable, just irritating.


Return to posts index


Jeremy Garchow
Re: Compound clips played in event load previous version of project for some reason
on Dec 17, 2015 at 3:28:52 am

Is it possible to take a screen capture or show screen grabs of what's happening?

Compound clips react differently if the are in a Project that's a Snapshot versus a Duplicate.

https://support.apple.com/kb/PH12630?locale=en_US

Alternatively, If you select a Project in the Browser and hit the space bar, it automatically opens and plays. So, are you sure you are selecting a compound clip and not a Project?


Return to posts index

Bret Williams
Re: Compound clips played in event load previous version of project for some reason
on Dec 17, 2015 at 6:20:03 am

How are you duplicating your project? Are you perhaps duplicating as a snapshot? It's hard to follow what you were describing, but if you don't understand snapshots I can see how it's perfectly designed behavior could be confusing. When you create a snapshot, you are creating an infallible moment in time. All compound clips within will become self contained so that one can't change a compound and screw up the snapshot. IOW they lose all affiliation with compounds in the event. If you want to reveal the compound in the event, you'd have to match frame it from the snapshot and magically it appears in the event. You'll find it also at that point increments the name of the compound with a number.

So generally, when you make a duplicate for emergency backup purposes / versioning, you would use a snapshot - and continue editing the original, NOT the snapshot.

If you don't like this methodology, you can just create a regular duplicate where all compounds wil point to the same media. Editing that compound will change all duplicates. This would be the desired behavior if you were making a derivative work like another episode where perhaps the show intro is a compound and you'd want to change it across all episodes at once. But if there are other compounds within the project that you might edit that you wouldn't want the change to ripple through (like maybe a credit roll that changes every week) then you'd have to remember to make that compound link to a new master before you edit it.

Ripple Training just pointed out another aspect- If you use the hot keys shift cmd D to make a quick snapshot. But if you don't click back into your sequence before you hit spacebar, it'll open the snapshot in the timeline window. Perhaps your issue is somehow related to this procedure. Sometimes you can click and play things in the event but for some reason the focus doesn't change and weird things happen. I've actually had video playing in the event viewer and the regular viewer at the same time before.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]