FORUMS: list search recent posts

Improving performance, minimizing beach ball on clip select

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
jim bachalo
Improving performance, minimizing beach ball on clip select
on Jul 2, 2014 at 12:35:36 am

I am running FCPX 10.1 on a 2 yr old iMac. For the most part, seems fairly responsive, even with 4k footage, but the one annoying performance bottleneck is the 'beach ball' I see for 3-5 seconds every single time I select a clip.
I have caching enabled of course.
Is there anything I am missing to improve performance, other than a brand new Mac pro?

You should follow me on Twitter here. My latest work


Return to posts index

Jeff Kirkland
Re: Improving performance, minimizing beach ball on clip select
on Jul 2, 2014 at 9:29:13 am
Last Edited By Jeff Kirkland on Jul 2, 2014 at 9:32:16 am

I think we'd want to know what CPU, GPU and amount of RAM you have. Plus what sort of RAID is the footage on and how is it connected? Some third party effects can also cause a bit of beach-ball pause so it'd probably be worth mentioning those as well. And too many nested compound clips might also lead to some beach-balling.

Of course, if none of the above apply, then yes, you may need a beefier Mac.

I'll add that I don't have any beach-balls on selecting clips with my low-end 2010 iMac, 2012 iMac, or even very often on my 2006 Mac Pro so the issue should be solvable.

Jeff Kirkland | Video Producer | Southern Creative Media | Melbourne Australia
http://www.southerncreative.com.au | G+: http://gplus.to/jeffkirkland | Twitter: @jeffkirkland


Return to posts index

jim bachalo
Re: Improving performance, minimizing beach ball on clip select
on Jul 2, 2014 at 6:29:30 pm

2.7 GHz i5
AMD Radeon HD 6770M
16GB RAM

6TB USB 3.0 RAID 1 external drive

You should follow me on Twitter here. My latest work


Return to posts index


Tom Brooks
Re: Improving performance, minimizing beach ball on clip select
on Jul 5, 2014 at 1:05:51 pm

Do you have an external A/V output device? I find that a mismatch between project settings and output settings can cause all sorts of troubles, including instantaneous kernel panics.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]