FORUMS: list search recent posts

Library not showing up

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Steve Connor
Library not showing up
on Apr 9, 2014 at 7:29:22 am

When I open FCPX I load a library and get the progress box open up to say it's loading it but it never shows up in the libraries pane. Have done the usual trash prefs etc with no improvement. Any ideas?

I'm getting concerned as this is my main library!

Steve Connor

Class Bully


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 12:39:33 pm

I can now get it to load if it's the only library open, but it's lost all the projects, there's also a second library affected as well, have tried everything including backups but there's still a problem.

Not a happy FCPX user at the moment

Steve Connor

Class Bully


Return to posts index

Jeremy Garchow
Re: Library not showing up
on Apr 9, 2014 at 3:44:40 pm

Where are they located? Boot drive or external? have you checked permissions?


Return to posts index


Loren Risker
Re: Library not showing up
on Apr 9, 2014 at 6:13:28 pm

Try copying the library to back it up, then right click it and show package contents. Does it look like your libraries are in there?

-------------
OutOfFocus.TV - Original series, music videos, mini-docs.


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 6:18:29 pm

Thanks, It's an external SATS RAID I've tried both of those and it doesn't work. The library now shows up but there are projects missing from some of the events in it.

It's a strange one.

Steve Connor

Class Bully


Return to posts index

Charlie Austin
Re: Library not showing up
on Apr 9, 2014 at 6:21:22 pm

[Steve Connor] "The library now shows up but there are projects missing from some of the events in it. "

So the actual project Folders are missing from the Library when you open the package in the finder? That is weird. Do you use that Library Manager app or anything like it?

-------------------------------------------------------------

~ My FCPX Babbling blog ~
~"It is a poor craftsman who blames his tools."~
~"The function you just attempted is not yet implemented"~


Return to posts index


Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 7:19:17 pm

[Charlie Austin] "So the actual project Folders are missing from the Library when you open the package in the finder? That is weird. Do you use that Library Manager app or anything like it?
"


No I don't, also the events and projects that are missing actually show up in the package contents, they just don't show up in FCPX!

Steve Connor

Class Bully


Return to posts index

Jeremy Garchow
Re: Library not showing up
on Apr 9, 2014 at 7:20:26 pm

[Steve Connor] "No I don't, also the events and projects that are missing actually show up in the package contents, they just don't show up in FCPX!"

Did you at any time move those Projects from another Library via the Finder?


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 7:21:14 pm

Absolutely not!

Steve Connor

Class Bully


Return to posts index


Jeremy Garchow
Re: Library not showing up
on Apr 9, 2014 at 7:23:01 pm

Did you see this?

http://forums.creativecow.net/thread/344/29439


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 7:43:26 pm

[Jeremy Garchow] "Did you see this?

http://forums.creativecow.net/thread/344/2943"


That IS a good catch, but it doesn't help my problem sadly!

Steve Connor

Class Bully


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 7:52:32 pm

Also every time I open one of the corrupted projects I get the "restoring window layout" issue when I try to re-open FCPX

Steve Connor

Class Bully


Return to posts index


Charlie Austin
Re: Library not showing up
on Apr 9, 2014 at 7:58:28 pm

[Steve Connor] "Also every time I open one of the corrupted projects I get the "restoring window layout" issue when I try to re-open FCPX
"


You probably did this, but go to your user Library > Application support > Final Cut Pro and trash the "Layouts" folder (after making a copy, I'm crazy like that)...

-------------------------------------------------------------

~ My FCPX Babbling blog ~
~"It is a poor craftsman who blames his tools."~
~"The function you just attempted is not yet implemented"~


Return to posts index

Charlie Austin
Re: Library not showing up
on Apr 9, 2014 at 7:25:39 pm
Last Edited By Charlie Austin on Apr 9, 2014 at 7:26:51 pm

[Steve Connor] "No I don't, also the events and projects that are missing actually show up in the package contents, they just don't show up in FCPX!"

So, somehow or other, it sounds like the Library database (CurrentVersion.flexolibrary) got hosed... I know it's not much help, but if you can somehow contact apple support I've heard they have been able to fix things like that. Though it could jet be a Rumor...

You said even the backups exhibit this? Are these the FCP auto backups or physical backups you have?

-------------------------------------------------------------

~ My FCPX Babbling blog ~
~"It is a poor craftsman who blames his tools."~
~"The function you just attempted is not yet implemented"~


Return to posts index

Steve Connor
Re: Library not showing up
on Apr 9, 2014 at 7:42:52 pm

[Charlie Austin] "You said even the backups exhibit this? Are these the FCP auto backups or physical backups you have?
"


Auto, I didn't have physical on these two libraries! I'll contact support tomorrow, I'm hopeful there's a fix as everything is still in place.

Steve Connor

Class Bully


Return to posts index


Charlie Austin
Re: Library not showing up
on Apr 9, 2014 at 7:54:20 pm

[Steve Connor] "Auto, I didn't have physical on these two libraries! I'll contact support tomorrow, I'm hopeful there's a fix as everything is still in place."

Bummer, Hopefully someone there can help. Like you said, the data appears to be there so...

Also, FWIW, If you don't have it, Backups for Final Cut Pro has saved my ass a couple times. Keep us posted...

-------------------------------------------------------------

~ My FCPX Babbling blog ~
~"It is a poor craftsman who blames his tools."~
~"The function you just attempted is not yet implemented"~


Return to posts index

Jon Cairns
Re: Library not showing up
on Apr 10, 2014 at 2:06:06 pm

If you open this library in a different User account do you see the same issue?

I had some odd Library behavior (on quite and relaunch open libraries were closed, closed libraries were open, etc.). Same libraries on same drive behaved fine under a new User.

It's not the same issue you are seeing but worth a try?

Jon



Return to posts index

Steve Connor
Re: Library not showing up
on Apr 10, 2014 at 8:06:48 pm

That's a good thought, thanks I'll try it

Steve Connor

Class Bully


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]