FORUMS: list search recent posts

Timeline index doesn't function

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Oliver Peters
Timeline index doesn't function
on Jan 3, 2014 at 8:28:38 pm

I have one machine where the Timeline Index does not function. You open it and it is empty. You then cannot close it. When you quite X and restart it, the Timeline Index starts closed. Everything else in X and all other applications function normally.

If I try a different "test user" log in, the Timeline Index works correctly. On this machine this was the case with 10.8.5 and 10.0.9 and is still the case after the upgrade (10.9.1 and 10.1). Trashing prefs and deleting the app and re-installing doesn't fix it.

I realize it could be a corrupt home user, but I'm trying to see if anything else could cause this. It's now the second Mac Pro that I've seen this exact symptom on. Has anyone else run into this?

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Oliver Peters
Re: Timeline index doesn't function
on Jan 3, 2014 at 10:17:50 pm

PS: Turning skimming and snapping on/off are also not functioning.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Jeremy Garchow
Re: Timeline index doesn't function
on Jan 4, 2014 at 2:09:18 am

This sounds like an OS problem, no?

Are these MacPros at the same facility?

Using the same OS install, maybe?


Return to posts index


Oliver Peters
Re: Timeline index doesn't function
on Jan 4, 2014 at 3:05:41 am

Right now the lead I'm following is to delete certain .lock files. These are hidden system files in the user library that get created when pref files are written. Apparently they are supposed to be temporary, but can gunk up the works. When you change to a new user setting or you do a clean OS install (and don't migrate), then these won't exist.

On my own machine, where I did a clean Mavericks install, I don't find any. On the old hard drive with 10.8.5/10.0.9 I find a bunch. Apparently the way these are created (and automatically deleted) has been changed in the OS. Therefore, if you've updated across several OS versions, you've got this sort of stuff built up.

At the moment, this is partially theoretical based on various forums threads I've checked and some additional input. I'll get back to the other machine on Monday and will be able to test if these are present and if deleting them fixes the issue. I'll post the results then.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Bret Williams
Re: Timeline index doesn't function
on Jan 4, 2014 at 6:43:43 am

Let us know. That's exactly the issue I was having after mavericks update. The 10.1 update didn't fix it either. Only a new user. Snapping and skimming were stuck. I don't use the index much so don't know about that. I'll log into that account and see.


Return to posts index

Bret Williams
Re: Timeline index doesn't function
on Jan 4, 2014 at 5:37:34 pm

Checked that user acct just now. Ditto. Can open the index, but can't close it. Also, audio scrubbing is stuck too.


Return to posts index


Jeremy Garchow
Re: Timeline index doesn't function
on Jan 4, 2014 at 5:40:36 pm

So is it as easy as simply trashing all the files in Library > Preferences to get everything back up and running?

There seems to be no more pref lock files in Mavs.

I am browsing on a brand new Mavs machine, though.


Return to posts index

Bret Williams
Re: Timeline index doesn't function
on Jan 4, 2014 at 5:43:23 pm

No. Just like Oliver said, the only fix so far has been to create a new user. I trashed every preference I could find and used preference manager and it didn't do any good. This was a couple months ago after mavericks came out. I've been using a new user ever since. But I still have the old user on the system and just logged into it instead and yup, same problems, even after the 10.1 update.


Return to posts index

Jeremy Garchow
Re: Timeline index doesn't function
on Jan 4, 2014 at 5:45:50 pm

But is that one a Mavs machine that has been upgraded from Mountain Lion or was it a clean install?

If you go to your user > Library > Preferences files, do you see plist.lockfiles?

Jeremy


Return to posts index


Bret Williams
Re: Timeline index doesn't function
on Jan 4, 2014 at 5:52:53 pm

It's an upgrade from a Mountain Lion and I have zero lock files. It's a late 2012 iMac.


Return to posts index

Oliver Peters
Re: Timeline index doesn't function
on Jan 4, 2014 at 6:12:41 pm

I will know better on Monday, but in reviewing the old hard drive from my machine (I did a clean install to a new drive), I see .lock files in the ByHost folder within User / Preferences. These are revealed if you search in the finder window, but add criteria to include system files and visibility. They are normally hidden. These are 0 KB Unix Executable files. I found none of these on the current (Mavericks only) hard drive.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Simon Ubsdell
Re: Timeline index doesn't function
on Jan 5, 2014 at 2:54:07 pm

Yes, I had the exact same issues transitioning to Mavericks (not a clean install) - no Timeline Index, no skimming.

I also had two very specific Motion 5 bugs, namely the inability to reset the 2D grid and F7 not functioning for the HUD.

A new user cleared it all up - but it's annoying.

Would be great to hear of a different kind of fix.

Simon Ubsdell
http://www.tokyo-uk.com


Return to posts index


Michael Garber
Re: Timeline index doesn't function
on Jan 5, 2014 at 8:13:48 pm

I had an unrelated but similar user issue with QuickTime X where it would not allow me to upload to Youtube. Creating a new user allowed me to enter the info. The only reason I bring this up is because it was similar in that it started after the update to Mavericks and was fixed by creating a new user.

However, I found that I didn't have to create a new user if I trashed files from this folder, rather than the preferences folder: /Users/username/Library/Containers/com.apple.QuickTimePlayerX

This might not lead you directly where you need, but perhaps it's a start. I couldn't find any proapps related files in that folder.

Michael Garber
5th Wall - a post production company
Blog: GARBERSHOP
My Moviola Webinar on Cutting News in FCP X


Return to posts index

Michael Garber
Re: Timeline index doesn't function
on Jan 5, 2014 at 8:16:18 pm
Last Edited By Michael Garber on Jan 5, 2014 at 8:16:55 pm

This might help you find the right file to trash. To fix the QT issue, I went into Activity Monitor, pulled up the app and inspected the ports and processes. Had to do a little copying and pasting of the info into textedit, but found the offending folder that way.

Michael Garber
5th Wall - a post production company
Blog: GARBERSHOP
My Moviola Webinar on Cutting News in FCP X


Return to posts index


Oliver Peters
Re: Timeline index doesn't function
on Jan 6, 2014 at 2:08:39 pm

So I fixed it. Obviously changing users or doing a clean install from the ground up eliminates the reason for the problem, but it is indeed caused by the .lock files. I guess their use, need or location seems to have changed with Mavericks, and if you've done an upgrade install, there are previous vestige files left on your system. This is what causes the issue with FCP X.

To fix - go to to user Library (option+Go to reveal) and delete the contents of the user Library/Preferences/ByHost folder. If you don't see any .lock files in there, they may be invisible. If so, you can search for .lock files by adding two fields to the Finder window search. Add System Files=include and Visibility=invisible or visible. In my case they were visible on this particular machine. I trashed the contents of this folder and FCP X behavior was correctly restored.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index


Simon Ubsdell
Re: Timeline index doesn't function
on Jan 6, 2014 at 2:18:51 pm

A huge thanks for this.

This solved the problem for me just perfectly.

And that includes the odd anomalies I was having with Motion as well.

Simon Ubsdell
http://www.tokyo-uk.com


Return to posts index

Jeremy Garchow
Re: Timeline index doesn't function
on Jan 6, 2014 at 5:15:00 pm

Thanks, Oliver.

Great sleuthing.


Return to posts index

Oliver Peters
Re: Timeline index doesn't function
on Jan 6, 2014 at 5:18:53 pm

[Jeremy Garchow] "Great sleuthing."

Thanks. Although in all honesty, a friend pointed me in this direction and it worked out, so I didn't come up with it completely on my own. Grateful that it proved to be a reasonably painless fix.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Patrice Freymond
Re: Timeline index doesn't function
on Jan 20, 2014 at 5:38:53 pm

Hi Oliver,

thank you for this, I had the same problem today and by creating a new user got rid of it.

But out of curiosity, how do you add a search criteria for Visibility ? I couldn't find it in the list ?

thanks in advance,

Patrice


Return to posts index

Oliver Peters
Re: Timeline index doesn't function
on Jan 20, 2014 at 5:54:12 pm

[Patrice Freymond] "But out of curiosity, how do you add a search criteria for Visibility ?"

When you start to type something into the folder search field it allows you to add criteria. I believe you have to set type first and then add a second field for attributes.



- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

Jeremy Garchow
Re: Timeline index doesn't function
on Jan 20, 2014 at 5:57:47 pm

The cool thing is that you can save those search criteria for later!


Return to posts index

Patrice Freymond
Re: Timeline index doesn't function
on Jan 20, 2014 at 6:25:02 pm

Great !

thank you for the info.

Patrice Freymond

Editor  Certified Trainer FCP7/X
Post Consultant

Always learning...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]