FORUMS: list search recent posts

Timecode won't show up in Viewer window of single-cam clips

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Dennis Widmyer
Timecode won't show up in Viewer window of single-cam clips
on Dec 7, 2013 at 10:04:26 pm
Last Edited By Dennis Widmyer on Dec 7, 2013 at 10:16:17 pm

Having an issue where I'm literally going to have to rebuild my entire film (within 5 reels) and replace all the multi-cam shots with just the angles themselves. Now since FCX doesn't have a way to flatten multi-cam clips (which boggles my mind), the way I'll have to do this is going to be nightmarish. Shift F won't help me, b/c that will just point to the synced-up multicam clip in my Event folder. Instead, I'll need to go to the single camera (for the angle I need in the timeline) and then, using the timecode, mark my Ins and Outs and reinsert it into the timeline as a single camera clip.

This is probably going to take me all weekend, and we're supposed to be doing our conform on Resolve right now. But Resolve won't show any of the multi-cam clips, and after spending half the day researching this, it seems like this is the one thing it can't get past.

So before I start doing this, I need to know how to view the Timecode on single camera clips. I know that it shows it in the main Display counter (center screen). But when I then try to find the timecode within the timeline sequence on the multicam clip, it shows its own timecode for that clips actual place on the project.

So in short, I need a way to look at the timecode of the actual portion of the inserted multicam clip in my project, so I can then correspond it with the single camera version of that shot from the Events folder.

Any help would be greatly appreciated. Losing my mind over here.


Return to posts index

Bret Williams
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 8, 2013 at 6:17:12 am

Cmd+opt+s

Let's you skim (and see TC) individual clips in the timeline.


Return to posts index

Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 8, 2013 at 5:54:56 pm

Yeah, I spent all night emailing with Larry Jordan about this. Doesn't work for me with my multicam clips. That option shows me the duration of where I am in that individual clip (not the source timecode). Only way I see the actual timecode is if I go to the solo-cam version of that shot, within my events folder, and skin there. Larry was great, and spent many emails with me trying to figure this out. In the end, we both gave up.

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index


Bret Williams
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 8, 2013 at 11:55:11 pm

This is where I question whether LJ actually has any real working experience with the product. The concept it gave you was the only option. I couldn't remember if it showed the TC of the clip or the TC of the multicam clip. Sounds like the latter. For those that have actually used multicam for a year or so, this is a known downside of the software. You can't match frame back to the actual clip. You can't even open the multicam and have the play head snap to the same place that that the sequence was. So you have to match frame, mark an out, check the duration, use that to find the in point, etc. A mess.


Return to posts index

Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 9, 2013 at 12:13:34 am

Agreed, there's so many ways they could make this easier in subsequent updates:

1. Allow a way to flatten the multicam clips. (similar to breaking apart a compound clip)

2. Allow a similar tool (like Shift F) that matches the frames to the original clip, but let's you determine WHICH angle (not just default to the synchronized multicam clip)

3. Or at least let you see the source time code of the multicam clip in the main display. Right now, it only shows me the source timecode of the single angle versions of the clip.

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index

Bret Williams
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 9, 2013 at 12:52:44 am

Yep. All should be implemented in the next release if hope.


Return to posts index


Jeremy Garchow
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 9, 2013 at 9:35:39 pm

You can open the Angle Viewer, change the "Settings" to show the "Timecode" overlay and "Clip Name", and at least you will be able to see the tc easily and do a search for the clip in the Browser using the clip name.

It still doesn't solve the stupid match frame situation.

Also, as Bret mentioned, clip skimming (command-option-s) shows me clip tc in the timecode display when skimming a clip in the timeline (this is different from skimming the timeline). It doesn't for you?

Jeremy


Return to posts index

Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 10, 2013 at 5:52:38 pm

Yeah, it absolutely doesn't work for me, and it's really starting to screw me up. Ive got my co-director in NYC right now (I'm in LA) and he's working with a colorist at Deluxe. And last night, he was texting me to fill in some gaps where shots that had speed ramping applied were missing. He needed the source timecode for these shots, and here's how I had to figure out how to give it to him:

1. Find the multiclip on the timeline.
2. Turn on skimming. (command-option-s)
3. Skim over the clip (mouse over the actual clip). Again, for me, this doesn't show source timecode. It shows where you are in duration of that entire raw shot, with the shot beginning at 0. (my multicam clips are ignoring the source timecode)
4. So if I skim over the first frame of the multicam clip, and the counter shows me 01:12:04, I know I'm a little more than a minute into that actual shot/take.
5. Get the clip's shot / take number. Example: 26B_1.
6. Find it in the event browser (the solo version of it). So I'm not using Shift +F, because that would find me 26_1_Synchronized_Clip (the multi version)
7. Go to the raw shot and skim through till I get to 01:14:04 into the clip. Then make my In there.

Trouble is, I'm not too good with figuring out how to precisely put an In into a clip at a specific time. I think I know how to do it from the timeline, but not from the event browser. So then I run into the headache of, looking at the source timecode on the solo clip (in the event browser) and doing math in my head so I can figure out that, if the source clip starts at 14:05:03:01, I have to add 01:14:04 to that number to figure out my In.

But then there's yet ANOTHER added headache. In some clips, sound begins before the picture, so I have about 9 seconds of black before the clapper appears. So I then have to subtract 9 seconds from my math solution.

In short, it sucks, and trying to pull him the timecode for just one 6 frame clip he needed for the colorist, took about 20 mins.

I've followed all the steps; have all the settings turned on correctly; even had a long email back and forth with Larry Jordan about this: For some reason skimming isn't showing me the source timecode of multicam clips. Could this be an issue with how they were imported?

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index

Jeremy Garchow
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 10, 2013 at 6:16:09 pm

[Dennis Widmyer] "3. Skim over the clip (mouse over the actual clip). Again, for me, this doesn't show source timecode. It shows where you are in duration of that entire raw shot, with the shot beginning at 0. (my multicam clips are ignoring the source timecode)"

Then this is your problem. When making the mulitcam clips, there's a "starting timecode" field. If there's tc, it usually starts with the clip that has the earliest tc and uses that as the tc for the clip. Do all of your clips have tc?

The timecode overlay does not show tc (you have to open the Angle viewer)?

[Dennis Widmyer] "6. Find it in the event browser (the solo version of it). So I'm not using Shift +F, because that would find me 26_1_Synchronized_Clip (the multi version)"

Oh, wait a minute. Yes, if you are using Synchronized clips, then yes the tc is ignored and all clips start from 00:00…

Jeremy


Return to posts index


Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 10, 2013 at 6:19:23 pm

Jeremy,

Yes, this is only a problem with unsynchronized multicam clips. When I go to the unsynchronized version of the clip, I can see the source code.

All of my multicam clips start at 00:00. And opening a multicam clip in Angle Editor doesn't solve the issue either.

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index

Jeremy Garchow
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 10, 2013 at 6:30:12 pm

Yes, Synchronized clips do not borrow original timecode, and it sucks.


Return to posts index

Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 13, 2013 at 5:29:50 pm

Are you certain of this, Jeremy? Larry Jordan wrote a whole article about how they do:

Yes, that will definitely be in the next release. The Mac App Store will be closed for a one week Christmas break so it may not appear until after that, depending on their review times.

FYI I was wondering why this bug hasn't been reported before this. Is there another way to make multicam clips that would avoid this? Here's the method my assistant editor used:

He would first grab each camera angle clip and sync it with the audio. So now he has 5 clips in the bin:

26B_1_A (camera angle 1)
26B_1_B (camera angle 2)
26B_1 (audio)
26B_1_A_Synchronized Clip (sync sound version of angle 1)
26B_1_B_Synchronized Clip (sync sound version of angle 2)

Then, with those bottom two Synchronized Picture/Sound clips, he'd highlight each one and choose 'New Multicam Clip.' This creates a merged, synced version of the two camera angles.

The problem is, because they were synchronized first, they no longer show the source timecode.

So the issue might stem from the way my particular multicam clips were created from the get-go.

Is there a better process you can recommend for doing this? Because whatever process Larry Jordan is using, is preserving the source timecode after the clips have been multicammed, whereas mine is not.

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index


Jeremy Garchow
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 13, 2013 at 7:48:20 pm

[Dennis Widmyer] "Are you certain of this, Jeremy? Larry Jordan wrote a whole article about how they do:"

Synchronized clips do not carry over original timecode. I'm sure of it. All synchronized clips start at zero. Synchronized clips should be used when your source has to tc. If tc is important to you, use multiclips. you cannot, however add multiclips to multiclips.

[Dennis Widmyer] "FYI I was wondering why this bug hasn't been reported before this. Is there another way to make multicam clips that would avoid this?"

One way is to not use synchronized clips. You can sync audio only angles to multicam clips right in the angle editor. It's very easy.

Or, if you must use synchronized clips, you have the option when creating a multicam clip to choose a starting timecode. Typically, it will choose the lowest one. Since you have a synched clip with zero tc, it chose zero as the start time. Next time, add the tc that you'd like. Your synchronized clips will still have a tc of zero, in the multiclip, but at least the multiclip will have orig tc.

Jeremy


Return to posts index

Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 13, 2013 at 8:26:00 pm

So you're saying the best workflow for us would've been to first create the multicam clips (which comprise about 85% of our entire film project). Then, take all of those clips and, one by one, open them in the Angles Editor and line up the clapper with the audio clip?

If that's what you're saying needs to be done to avoid Synchronized Clip, I get it, but honestly, it sounds like a huge headache for any feature project with as many multicam clips as ours, when FCX provides a tool to sync audio with the click of a button.

Pretty annoying that you can't tell Synchronized Clips to retain the source timecode. That would solve all of this. Yet another item to put on the future updates list.

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index

Jeremy Garchow
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 13, 2013 at 8:49:07 pm

[Dennis Widmyer] "So you're saying the best workflow for us would've been to first create the multicam clips (which comprise about 85% of our entire film project). Then, take all of those clips and, one by one, open them in the Angles Editor and line up the clapper with the audio clip? "

No.

Use the audio as it's own angle and sync it in the multiclip when you sync everything else. this way, you sync the audio and video all together. There's no need to sync one audio to one video and then video to video.

Here is a similar problem. It has pictures that may help visualize what I mean:

http://forums.creativecow.net/thread/335/62522

[Dennis Widmyer] "If that's what you're saying needs to be done to avoid Synchronized Clip, I get it, but honestly, it sounds like a huge headache for any feature project with as many multicam clips as ours, when FCX provides a tool to sync audio with the click of a button. "

Mutliclips have the same sync function, and more. You can even add the audio later, and choose "sync to monitor angle". There is no reason to use Synchronized clips in a multicam edit as you have much more functionality in multiclips. That's what I am saying.

[Dennis Widmyer] "Pretty annoying that you can't tell Synchronized Clips to retain the source timecode. That would solve all of this. Yet another item to put on the future updates list."

Yes. It is an inconvenience. Synchronized clips are for clips that don't have tc. If your clips DO have tc, simply use a multiclip. You will be much happier. You still have to be careful about the start time of the multiclips, though. If all of your clips have tc, including audio, then FCPX can take care of it.

Jeremy


Return to posts index


Dennis Widmyer
Re: Timecode won't show up in Viewer window of single-cam clips
on Dec 13, 2013 at 9:24:02 pm

That all makes sense. Wish we would've done it that way. Too late now. But great to know going forward.

Thanks!

--
Dennis Widmyer
http://www.parallacticpictures.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]