FORUMS: list search recent posts

Compressor Glitches

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Justin Mrkva
Compressor Glitches
on Nov 1, 2013 at 3:40:16 am

So after upgrading to OS X Mavericks, I tried to run a batch job in Compressor. Now, the user interface in Compressor 4 has always given me problems (every so often, the Untitled project window would refuse to show up despite resetting the window layout multiple times, rebooting, etc., making it impossible for me to add destinations and settings).

What's happening now is this. If I drag multiple video files to the window, only one item shows up. I can add settings and destinations but just to one item. If I try to add a second item, well, this happens:



I keep getting this glitch when adding more than one movie to a Compressor document. It shows just the first one and the second partial item no matter how many additional items I add - the number of jobs at the bottom left updates to show 3 or more, but the interface never updates and I can't even scroll down to see the third one (resizing makes the second item stretch to properly fit the width, but nothing else changes - there are still only two items shown). I've tried every fix I can think of, including installing Compressor on a second Mac with a completely fresh install of Mavericks. No dice - it behaves exactly the same way.

FOLLOWUP: I found a few video files that work, and on the ones that don't, I'm getting this error:

10/31/13 11:43:44.357 PM Compressor[15855]: Inconsistent set of values to create NSBitmapImageRep
10/31/13 11:43:44.744 PM Compressor[15855]: Cannot lock focus on image , because it is size zero.

So it looks like either that's the bug, or maybe the video files are partly corrupted. They play in QuickTime, and FCPX likes them just fine, so I'm not sure what exactly is going on.

When I recompress them in QuickTime to something lower res (like 720p) Compressor then gives the error "Error trying to open source media file." So it's looking a lot like the video files are corrupted. Which as I said is strange because FCPX doesn't have a problem with them.


Return to posts index

Jeremy Garchow
Re: Compressor Glitches
on Nov 1, 2013 at 4:10:53 am

I the this had to do with mp4s. Compressor, for whatever reason, seems to have a tough time with them, especially in a batch.

Try "Add file" instead of drag and drop.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]