FORUMS: list search recent posts

FCPX acting up. Seriously.

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Florian Gintenreiter
FCPX acting up. Seriously.
on Jun 24, 2013 at 6:48:16 pm

Hi, Guys!

I closed FCPX on wednesday after finishing an edit with no problems and opened it again today and I had problems all over. I've been using FCPX professionally for a year now, know it quite well and have had no problems that come close to what happened today. I'm not a rookie with computers in general and Macs in partiular either, but I have no idea what I can do to fix my problem anymore.

I'm running 10.8.4 with FCPX 10.0.8 on a 2010 MacPro and have a couple of plugins installed (Magic Bullet Looks, DFX, Neat Video, FilmConvert) The only thing that changed on the machine since wednesday was a FXFactory update 4.0.7. I did not change anything else on the machine since wednesday. All the project's EVENTS are online with no yellow triangles and nothing missing. A couple of projects include compound clips.

The problem is as follows: In one project I can only see the main storyline (which is one clip pro Res422 clip) but NO connected clips whatsoever, no generators, no graphics nothing. I deleted all render files to force FCPX to rerender the timeline (which goes for all the projects I have on my machine), but nothing happens — it renders and the orange bar on top of the timeline desappears, but still just the video on the primary storyline is visible. I another project I see all the videos, but the color effects, I put on do nothing whatsoever. Regardless if they're swichted on or off.
Basically ALL projects that are on my machine
If I make a new project and drag generators in it they are just black, no matter if they are stock generators or self made ones. If I open them in Motion they all look fine.

Here is what I tried to bugfix this with no effects:

- repair permissions on all drives
- uninstall FXFactory
- removed all events and projects from FCPX, opened a new one and tried the generators there. Does't work.
- delete FCPX permissions /with permissions manager)
- uninstalled and reinstalled FCPX
- switched off A/V output to Blackmagic Card

The last thing I tried was to copy all the projects, events and custom motion templates to my 2012 MacBookPro running 10.8.4 with FCPX 10.0.8 and ALL the same plugins that are installed on my main machine.

Guess what: EVERYTING OK THERE. No problems, everything works.

Can anyone enlighten me what the hell is wrong with my MacPro?

cheers

Florian

________________________________________
Director of Photography, Director, Editor
Vienna, Austria


Return to posts index

Bill Davis
Re: FCPX acting up. Seriously.
on Jun 24, 2013 at 6:56:25 pm

This will all be speculation, but I'd grab one of the diagnostic tools and run a check of your RAM.

The one time many years ago I had a problem that screwed up things in ways so weird that it made no sense to me whatsoever, it turned out to be related to a single RAM chip on one of the 4 sockets in my machine. The tech who figured it out mumbled something like "could be just unlucky and a cosmic ray hit a gate and flipped it forever..." Don't know enough about semiconductors to know if that's reality based or fiction, but that's where my brain goes when the problem is systemic and infects things in ways that are just too weird to explain any other way.

You can also go into terminal mode and watch what happens when the software tries to run stuff.

Sometimes the code is doing fine, but the video card or something else in I/O is getting screwed up and tossing garbage on the screen.

Best I can do from afar.

Good luck.

Know someone who teaches video editing in elementary school, high school or college? Tell them to check out http://www.StartEditingNow.com - video editing curriculum complete with licensed practice content.


Return to posts index

Dave Gage
Re: FCPX acting up. Seriously.
on Jun 24, 2013 at 8:03:17 pm

[Florian Gintenreiter] "- repair permissions on all drives
- uninstall FXFactory
- removed all events and projects from FCPX, opened a new one and tried the generators there. Does't work.
- delete FCPX permissions /with permissions manager)
- uninstalled and reinstalled FCPX
- switched off A/V output to Blackmagic Card"


What Bill said and also have you tried running Disk Warrior on the drive with your Events and Projects. I had some weird problems about a year ago with my external RAID "FCP X only" drive and Disk Warrior made it all better after repairing the directory structure. For years I avoided buying Disk Warrior because of the $100 price tag, but it's made all my computers run better and even boot up faster. One of the best purchases I've made in the last few years.

Dave


Return to posts index


T. Payton
Re: FCPX acting up. Seriously.
on Jun 25, 2013 at 4:19:09 am

Sounds like a hardware problem with one of the following: RAM, Logic Board, GPU, other PCI card. To rule those out I would install your OS on a new partition, boot from it and see if the problems persist.

With everything that could go wrong it is amazing that computers work at all. To boggle your mind, take a look at this while your OS is installing on that partition:







With that said I'm guessing it is your RAM or GPU.

------
T. Payton
OneCreative, Albuquerque


Return to posts index

Florian Gintenreiter
Re: FCPX acting up. Seriously.
on Jun 25, 2013 at 8:05:43 am

Thanks for your thoughts. Because of your inputs, I made a new user on my machine and voilá — FCPX behaves as it should, so a hardware centric problem can be ruled out.
What can be wrong with a user that it causes FCPX to act up? Is there a list of files that FCPX stores/uses in the user?

________________________________________
Director of Photography, Director, Editor
Vienna, Austria


Return to posts index

Andy Neil
Re: FCPX acting up. Seriously.
on Jun 25, 2013 at 2:58:27 pm

[Florian Gintenreiter] "What can be wrong with a user that it causes FCPX to act up? Is there a list of files that FCPX stores/uses in the user?"

I don't know that FCPX stores anything with the user, but there could be files that are being shared that are corrupt or have permissions errors.

I used DiskWarrior to rebuild the directory of my system disk one time when FCPX was acting up on me and it fixed the problems (which happened to be corrupt headers in QT codec files). I'd give that a shot.

Andy

http://www.timesavertutorials.com


Return to posts index


Craig Alan
Re: FCPX acting up. Seriously.
on Jun 25, 2013 at 5:55:41 pm

I had the same thing happen on a FCP 7 computer with media stored on an external drive. A project was a mess. Created a new user account and copied project file and relinked to media and all was solved.

So user accounts can get corrupted or develop permission problems. Good question about what to look for in User folder. I second Disk Warrior being able to sort things out that disk utility cannot.

I always keep the original ram chips that came with my mac and buy third party ram to max out as much as I can afford. This way I can swap them out to original ram chips to quickly determine if ram is the culprit when I get weird behavior - though in my experience bad ram has always involved kernal panics. I have never had bad ram be the cause of one app acting weird.

One more thought: make sure your system drive is not getting too full.

Mac Pro, macbook pro, Imacs (i7); Camcorders: Panasonic AG-HPX170/AG-HPX250P, Canon HV30/40, Sony Z7U, VX2000, PD170; FCP 6 certified; write professionally for a variety of media; teach video production in L.A.


Return to posts index

Florian Gintenreiter
Re: FCPX acting up. Seriously.
on Jun 27, 2013 at 9:49:13 am

After three days of trying to solve the problem — I even reinstalled OSX — I gave up and moved to a new user on the same machine and everything works perfectly there.

Although in different forums I got lots of promising tipps, nothing worked.

It's a pity I could not find out what went wrong there and I hope it does not happen again.

Florian

________________________________________
Director of Photography, Director, Editor
Vienna, Austria


Return to posts index

Sascha Engel
Re: FCPX acting up. Seriously.
on Apr 28, 2014 at 5:06:05 pm

I am having a similar situation...also with new user account it work, but I do not want that actually. Somebody found a way to fix this differently?
I guess some file is corrupted...if I could know which I could replace it with Time Machine.


Thanx,

Sascha Engel
TIME BANDITZ Productions
http://www.youtube.com/taikang


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]