FORUMS: list search recent posts

Keyframing issue when making moves on jpgs

COW Forums : Apple Final Cut Pro X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Dan Herz
Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 7:34:31 pm

I am a long time FCP 7 editor...recently forced to switch over to FCP X for work. I am running OS X 10.8.2
and running FCP X 10.0.7

I am going out of my f*&$king mind trying to figure out how to move pics the way I want in FCP X. I have watched tutorials, read editing websites, talked to other editors...I can not figure this out. here's the issue:

I am attempting to do a series of moves on some jpgs...on the timeline, I select my clip, I open up the Video animation and in the inspector, I go to the Transform option and select "add keyframe"(I'll call this keyframe A)...then I put the cursor in the clip where I want the next keyframe to go...then I select the "transform" option in the lower left hand corner of the player window and move my jpg to the desired position (I'll call this keyframe B). I want the jpg to remain in the same position for a second or so...so I move the cursor 1 second forward and add another keyframe in the "transform" option in the inspector (I'll call this keyframe C). Now - I move my cursor a second or 2 ahead on the timeline and move the jpg again to the desired position and add another keyframe (i'll call this keyframe D). So...the end result should be that the jpeg moves from the starting point, keyframe A to keyframe B...remains in the same position through keyframe C...and then moves to keyframe D.

The problem I am having is that, for some unexplained reason, the jpg does not stay in position between keyframes B & C...it "floats" or "drifts" between these 2 keyframes even though the keyframes are identical for both positions. When I look at the inspector, the keyframe positions in the "transform" option are identical for both keyframes...but I can see when I go frame by frame along the timeline that the positioning actually moves ie. - the numeric values of the keyframes change between keyframes B & C but end up identical positioning on the keyframes themselves.

Here's some additional info - the jpg will stay static in the desired position between keyframes B & C until I add the next keyframe D. Once I add keyframe D, the image floats or moves between keyframes B & C.

I have tried everything I can think of to fix this, but I can not figure it out...and I am starting to go a little crazy. Any help anyone can provide would be greatly appreciated.

Thanks,

Dan

Dan Herz
danherzproductions.com


Return to posts index

Loren Risker
Re: Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 7:51:57 pm

I believe this is a bug that's been around since 10.0.0. It's maddening. If you use the arrow to reset the transform properties, then make all of your adjustments in the inspector pane will it work as intended? I haven't had this issue in awhile so can't remember how to recreate it.

Also, is this a project and event created in 10.0.7 or was it upgraded from a previous version?

-------------
OutOfFocus.TV - Original series, music videos, and entertainment for your couch.


Return to posts index

Dan Herz
Re: Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 8:10:20 pm

Thanks for your response, Loren,
First of all, this is a project & event created in FCP X 10.0.7

I'm not sure I understand when you say "If you use the arrow to reset the transform properties, then make all of your adjustments in the inspector pane will it work as intended".
Can you clarify exactly what you mean by using the arrow to reset the transform properties? If you could walk, step by step, through the process, I would really appreciate it...I know it can be tedious, but I really need to figure this out...and fast!
Thanks

Dan Herz
danherzproductions.com


Return to posts index


Loren Risker
Re: Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 8:23:24 pm

Select a jpg that's giving you problems, and go to the inspector pane (command-4)

Make sure you'r eon the video tab of the inspector tab, and scroll down to find the transform property.

To the left of the word Transform there is a blue button, to the right there is an arrow which resets it to the default. Reset it.

Pick the property you want to adjust, still in the inspector pane. Drop your keyframes there, and make your moves there. See if that clears itup.

-------------
OutOfFocus.TV - Original series, music videos, and entertainment for your couch.


Return to posts index

Dan Herz
Re: Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 8:35:03 pm

Same problem...I also am noticing that when I move the jpg to the new position, the actual keyframe movement follows the path of HOW I moved it...including the movements if I over adjust it before finding the final desired position.

Dan Herz
danherzproductions.com


Return to posts index

Nick Toth
Re: Keyframing issue when making moves on jpgs
on Mar 20, 2013 at 8:34:02 pm

Default keyframe behavior is "smooth". Make sure the playhead is on one of the hold keyframes using the transform controls in the viewer or inspector. In the viewer right click or control click on the keyframe and a menu will pop up. Change the interpolation to linear. Navigate to the next hold keyframe and do the same thing.

anickt


Return to posts index


Charlie Austin
Re: Keyframing issue when making moves on jpgs
on Mar 21, 2013 at 12:12:15 am

[Dan Herz] "Any help anyone can provide would be greatly appreciated."

see this... http://forums.creativecow.net/readpost/335/49872

-------------------------------------------------------------


~"It is a poor craftsman who blames his tools."~
~"The function you just attempted is not yet implemented"~


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]