FORUMS: list search recent posts

Compressor 4.1 consistently crashing

COW Forums : Apple Final Cut Pro X Debates

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Rich Hawksworth
Compressor 4.1 consistently crashing
on Feb 20, 2014 at 2:00:11 pm

I know this is a widespread problem, but I haven't been able to find a solution that solves it for me. Compressor is consistently crashing immediately upon startup. The load screen comes up for a few seconds, but that's it. Next thing I see is the Problem Report. There's a bunch of binary, but this seems to point to an issue:

Dyld Error Message:
Symbol not found: _StreamBasicDescriptionSetCanonical
Referenced from: /Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
Expected in: /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

I've updated QT codecs. My QT components are older (probably a vestige of FCS), but I don't know if they need to be updated or, if so, where to find them. I've uninstalled Compressor several times from the App Store.

Thanks in advance. Any help would be appreciated - specs below...

Mac Pro (early 2008)
2 x 3 GHz Quad-Core Intel Xeon
10 GB 800 MHz DDR2 FB-DIMM
OS x 10.9.1
Compressor 4.1.1


Return to posts index

Jeremy Garchow
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 2:15:48 pm

Do you have Compressor 3 and 4 on your machine?

If so, did you follow best practices?: http://support.apple.com/kb/ht4722

If not, try compressor repair from Digital Rebellion.


Return to posts index

Rich Hawksworth
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 2:40:33 pm

Thanks for the link. I screwed that up. I previously had FCS on this computer, but removed it AFTER installing FCPX in late 2012--can't remember which program I used to uninstall. There must be a stray file(s) that are in conflict? What would you suggest at this point--keeping in mind that I can install FCS on a separate computer and don't need to keep a legacy version on this MP. In other words, what's the best way to make way for a clean install of the pro apps?


Return to posts index


Jeremy Garchow
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 2:53:13 pm

Digital rebellion also makes an FCS remover.

It's easy and quick.

I have FCS and fcpx installed on nearly all my machines, they work fine together if you follow the instructions.


Return to posts index

Rich Hawksworth
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:00:49 pm

Still not working, but after reading Apple's upgrade recommendations, I think I complied with them at the time.

I tried Compressor Repair and also FCS remover--though I wasn't exactly sure which components to remove from FCS. I still have DVD Studio Pro, Soundtrack Pro, and QMaster installed from FCS. From what I read, Compressor 4.1 has QMaster baked-in and doesn't associate with separate program as in prior versions.


Return to posts index

Jeremy Garchow
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:07:04 pm

I would wipe it all and start over.

Has Compressor ever opened or is this a new phenomenon?


Return to posts index


Rich Hawksworth
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:14:55 pm

Compressor 4.1 has never opened. I used FCPX/Compressor to cut 4 x 30 minute shows last summer.

When you say, wipe it all, do you mean all the pro apps or reinstall OS as well?


Return to posts index

Russ Haskell
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:25:46 pm

Try this with C4.1 closed: In your Home Library > Applications Support>Compressor. Open the folder and if you have important custom settings, preserve them in a separate folder on your Desktop. Then drag the Compressor folder to the trash. Relaunch the app.

Russ


Return to posts index

Jeremy Garchow
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:26:45 pm

ProApps.

Before you do that, it would be good to trash Compressor prefs.

And follow these instructions: http://support.apple.com/kb/TS3894

Jeremy


Return to posts index


Martin Jaeger
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 7:43:55 pm

Had this issue. Moving Apple Qmaster folder out of Library>application support>Apple Qmaster, solved the problem for me... Doing this causes FCP 7 to crash however.



Return to posts index

Rich Hawksworth
Re: Compressor 4.1 consistently crashing
on Feb 20, 2014 at 6:24:23 pm

Alright. I've made some progress. Compressor is looking for QT Components in the ~/library/ directory but they exist only in the /system/library/. I copied the entire folder over and Compressor launches without issue.

Not sure the root of the issue, but at least I've taken a step forward.

Thanks for the help Jeremy.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]