FORUMS: list search recent posts

Can't play clips in Event Browser FCP X

COW Forums : Apple Final Cut Pro X Debates

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Brian Shaw
Can't play clips in Event Browser FCP X
on Apr 2, 2013 at 5:53:19 pm

Hi there,
FCP X will not let me play/preview clips in the Event Browser. JKL & Spacebar do not work, also hitting the play button does not work. I have trashed my prefs. I am up to date with 10.0.8, but this was happening before hand also. So frustrating!! Luckily the project I'm working on did not require audio this time. Cheers1


Return to posts index

Kara Stephens
Re: Can't play clips in Event Browser FCP X
on Apr 21, 2013 at 11:28:34 pm

The same thing happened to me. I was working on a project, and suddenly the spacebar and the j-k-l keys stopped working. I trashed the preferences but that didn't fix the problem. Any ideas?


Return to posts index

Brian Shaw
Re: Can't play clips in Event Browser FCP X
on Apr 22, 2013 at 10:52:31 am

Hi there, I figured it out. I repaired my disk permissions. Now it's working.

Brian Shaw
Managing Director
Digi House Media
http://www.digihousemedia.tv


Return to posts index


Kara Stephens
Re: Can't play clips in Event Browser FCP X
on Apr 22, 2013 at 3:55:53 pm

I solved it in a different way. I downloaded a program called Preference Manager. It deleted more stuff than I did when I trashed my preferences. Then I re-started FCPX and it worked great. Glad you solved your problem


Return to posts index

Ruairi Watson
Re: Can't play clips in Event Browser FCP X
on Jun 21, 2013 at 11:14:49 am

I am having this same issue. I have repaired my disk permissions and trashed my presets in preference manager and it still is not working. Can anyone think of anything else that might be causing it?


Return to posts index

Marshall Lee
Re: Can't play clips in Event Browser FCP X
on Sep 18, 2013 at 7:33:02 pm

Same issue. Even after repairing disk perm and and using Preference Manager. FCPX was working great just yesterday. So baffled.


Return to posts index


George Scott
Re: Can't play clips in Event Browser FCP X
on Jun 13, 2014 at 3:45:27 pm

The solution seems to be to REVERT TO ORIGINAL LAYOUT. Type that in "Help" in FCPX and it will take you there. Worked for me after trying everything else short of re-installing FCPX.

I use FCPX 10.1.1 on OS 10.9.3


Return to posts index

Jason Jenkins
Re: Can't play clips in Event Browser FCP X
on Feb 17, 2016 at 5:03:21 pm

[George Scott] "The solution seems to be to REVERT TO ORIGINAL LAYOUT."

Thank you! This just saved my sanity. "Revert To Original Layout" is in the "Window" menu.

Jason Jenkins
Flowmotion Media
Video production... with style!

Check out my Mormon.org profile.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]