FORUMS: list search recent posts

Missing media and black video -- FCX's file management errors

COW Forums : Apple Final Cut Pro X Debates

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mari Jenkins
Missing media and black video -- FCX's file management errors
on Feb 7, 2013 at 5:55:18 pm

Two separate but related problems:

UNLINKED FILES LISTED AS UNLINKED: I noticed that FCX was giving me a lot of exclamation points saying clips were missing or unlinked. When I find the files in the folder I'm supposed to be looking for them in, it gives me errors that it won't import said files because they're not exactly the same files. It looks to me like FCX had some errors in its process of copying everything into the events folder, and then won't let me re-link to the original clips because they're not the weird clips FCX made and somehow lost in certain cases.

To be clear, nothing was moved in the Final Cut Events folder, so please don't try to blame this weird issue on me (people have already started doing that in previous posts).

UNLINKED FILES APPEARING AS BLACK: Secondly, I find a whole sequence which is almost all black video. "Reveal in Event Browser" does nothing to show me missing clips, just sits there without an error message like FCX does in so many cases. There are many clips in the Original Media Folder of the event the clips should be in, but they don't show up in the event within FCX. When I try to Relink Project Files, it says "38 files found, but 38 files are not compatible"

I'm lost. Any inquiries I've made so far are like "Oh, you must have moved something, idiot. It can't be FCX's fault!!"


Return to posts index

Bill Davis
Re: Missing media and black video -- FCX's file management errors
on Feb 7, 2013 at 6:50:31 pm

I'm a bit at a loss of what to suggest.

FCP-X's entire media management is built around a pretty complex relational database that stores and IDs things based on machine code locations that are obscure and cryptic to anyone but someone that understands the deepest recesses of how computers work.

In some fashion, you're clips have become disconnected from those fundamental links.

It is this foundational reality that's the base of why so many of us keep talking about why it's a really bad Idea to move things OTHER than by using the internal FCP-X "move" command - which keeps the links intact.

This is also affected by whether you choose to import digital assets INTO X's event library - or you work with Reference assets.

No matter which you choose to do - the database MUST be able to identify and locate it's assets or it simply can't function properly.

I'm not saying your using or doing anything wrong. Just that this is a fundamental truth about using FCP-X that trips up a whole lot of people trying to use it. (including me in the first six months I was trying to learn it!)

Take that for what it's worth.

Hopefully someone else can help you diagnose what's gone wrong.

Good luck

Know someone who teaches video editing in elementary school, high school or college? Tell them to check out http://www.StartEditingNow.com - video editing curriculum complete with licensed practice content.


Return to posts index

Steve Connor
Re: Missing media and black video -- FCX's file management errors
on Feb 7, 2013 at 6:51:58 pm

Have you opened any of the clips in another programme?

Steve Connor
'It's just my opinion, with an occasional fact thrown in for good measure"


Return to posts index


Mari Jenkins
Re: Missing media and black video -- FCX's file management errors
on Feb 7, 2013 at 7:48:49 pm

I can actually see clips of the same name in the Event Browser, and play them. I can also play those clips outside of FCX.

WHen I select the clip in the Project and ask it to find it in Event Browser, nothing happens though. I'm guessing its looking for media it can't find and rather than being designed to tell me what's happening, it just doesn't do anything at all. Another design win for Apple.

To speculate, these problems happened after I updated the software and it told me I needed to upgrade the projects / events to work with the software. The program does crash fairly regularly for me as well, so it could have been undergoing some sort of process and cut off halfway though.

I've found a painful working solution by using a backup to copy over the project / event files over the newer versions (yes, I made a backup of the newer versions first). It worked but cost me days of labor, and who knows when it will happen again?


Return to posts index

John Davidson
Re: Missing media and black video -- FCX's file management errors
on Feb 7, 2013 at 10:18:31 pm

I think that the update to 10.0.7 actually 'fixed' this relinking problem. You can still have it though in events/projects that were created prior to 10.0.7.

When I have relinking issues with clips, the best solution I've found is to:
1. re-import the media as a new clip.
2. In each clip thats offline in a project sequence, go to the first frame of the missing clip
3. match frame (Shift + F) that first frame and you'll be at the first frame of use in the offline clip
4. copy the timecode of the clip in the event that you've match framed to
5. select the newly re-imported clip, if you sort by name it'll be immediately above or below the offline clip in the event
6. Type in the time code from #4
7. hit 'i' to set an inpoint
8. drag the inpoint selected clip onto the missing clip in your project sequence
9. select 'replace from start' in the pop up, and your clip is replaced.

It ain't perfect but the reality is you'll cry about it for more time than you'll actually spend doing it (I did). Once you've done it for a few clips though, you'll feel better about it. A hundred clips will suck to fix, but it is fixable and hopefully you won't have to deal with it ever again.

John Davidson | President / Creative Director | Magic Feather Inc.


Return to posts index

Jeremy Garchow
Re: Missing media and black video -- FCX's file management errors
on Feb 8, 2013 at 2:32:12 am

Are you working with aliased or imported media?


Return to posts index


Darren Roark
Re: Missing media and black video -- FCX's file management errors
on Feb 9, 2013 at 7:29:24 pm

Eugene Mirman has a great comedy album called God Is a Twelve-Year-Old Boy with Asperger's. I also think the same can be said for FCP X.

I have been dealing with fixing a huge mess of a project, thousands of shots, stills, 'untitled shots' for a doc. All the frustrating "the clips do not share the same media range, the frame rates are different, nah nah nah nah!" Often this is just trying to relink the exact file! This issue has come up many times for me as well, and I think I have at least an idea some of the reasons this happens.

-When media gets imported or moved FCPX doesn't get the opportunity to 'bless' the media with the metadata if it is suddenly shut down. I have gotten into the habit of hitting "organize event files" before I quit working. It has stopped a lot of these shenanigans.

- Another issue is conformed media from Cinema Tools really throws it for a loop. I have had many problems with slomo footage that was conformed to 23.98. I have been retiming them on the timeline which has stopped the black shots from happening.

- Corrupt media. I have used the corrupt clip finder from Digital Rebellion and in most cases, it's able to detect the clips that show up as black. FCPX seems to be completely unforgiving of anything being off by even a little bit.

As much as I love this software, the inability to override all the irritating warnings that come up really rubs me raw. But then I try track based editing again and I forgive.

John's technique works, it's the only way at this point until Apple installs the "trust me, I know what I am doing button". John's very informative video on shared storage convinced me to start using sparse disk images. Since doing that, I have had no new problems whatsoever.


Return to posts index

John Davidson
Re: Missing media and black video -- FCX's file management errors
on Feb 9, 2013 at 11:12:26 pm

[Darren Roark] "John's technique works, it's the only way at this point until Apple installs the "trust me, I know what I am doing button". John's very informative video on shared storage convinced me to start using sparse disk images. Since doing that, I have had no new problems whatsoever."

Aw, shucks. Thanks. I was thinking of making a new tute just walking through little hiccups (which aren't so little with 100+ clips to fix!) like this one. I'm hoping X developers create the ability to manage sparse disks within the app, but perhaps call them 'vaults' like in Aperture.

One of the weird things about this relinking issue I've found with old projects is that I've had clips pretend they don't have 4 channel audio and relinking is blocked. The clip isn't offline, but 4 channel audio is relegated to only 1 channel. That's how we came up with this process.

Anytime I get annoyed with the program as it is now, I just remember my old friend "General Error", and I feel a little better. :)

John Davidson | President / Creative Director | Magic Feather Inc.


Return to posts index

Darren Roark
Re: Missing media and black video -- FCX's file management errors
on Feb 10, 2013 at 1:42:26 am

Yes! I forgot about that issue with certain files from older projects doing this after updating. In my case, this project started around 10.0.2 so it has many issues from all the different versions of FCPX putting metadata cooties in the files.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]