FORUMS: list search recent posts

Excruciatingly looong backup time to LTO-6 with Bru-PE

COW Forums : Archiving and Back-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Neil Sadwelkar
Excruciatingly looong backup time to LTO-6 with Bru-PE
on May 4, 2016 at 3:13:18 pm
Last Edited By Neil Sadwelkar on May 4, 2016 at 3:14:15 pm

Maybe this is a one-off occurrence, but I began a LTO-6 backup from a LaCie Rugged 2 TB drive over USB3.0.

Total archive size is 2.04 TB. Just the backup took 11 hours. Meaning a read speed of about 50 Mbytes/sec which is fair for this type of hard drive, But I've seen faster even with these drives. I would have expected about 6-7 hours for 2.04 TB.

But the verify, is glacially slow. Its been 22 hours since the backup finished (34 hrs total) and the verify is still under way. I've never seen such slow performance for verify. And the verify goes on without the hard drive connected, so drive read speed isn't a factor.
In fact the source drive has been unmounted after the backup.

My Bru is Bru-PE 3.1.18 (Build 247), Bru version 18.1.0

The LTO-6 is a Tandberg connected over SAS via a Bolt to SAS PCIe box. It's a working installation that has been through maybe a 60 plus tapes in the past year or so.

The source contains many folders of image sequences (Arri Alexa Raw). Totally 268,511 files according to Finder.

Anyone observe this kind of speed (or lack thereof)? I sort of think this kind of speed bump crept in after Bru-PE 3.1.17 and now 3.1.18.

I may consider rolling back to BRU_PE_Rel_3.1.15.203 or BRU_PE_Rel_3.1.12.183 for the next drive, just to confirm that it's not a version specific thing.

My Bru-PE


-----------------------------------
Neil Sadwelkar
neilsadwelkar.blogspot.com
twitter: fcpguru
FCP Editor, Edit systems consultant
Mumbai India


Return to posts index

Neil Sadwelkar
Re: Excruciatingly looong backup time to LTO-6 with Bru-PE
on May 6, 2016 at 8:38:01 am

On the exact same system, I rolled back to Bru-PE, and backed up 1.74 TB off a 2 TB LaCie Rugged drive over USB 3.0. Composition of files was similar. Large number of file sequences from an Arri Alexa camera and many DPX file sequences of graded material. over 170,000 files.

This time the backup took under 6 hrs and verify, another 3 hrs or so. Well within previously observed time frames.

I think Bru-PE 3.1.18 is doing something that drastically slows down backup and verify timings.

Have started another LTO and will do one more after that. Let's see if this is repeatable.

-----------------------------------
Neil Sadwelkar
neilsadwelkar.blogspot.com
twitter: fcpguru
FCP Editor, Edit systems consultant
Mumbai India


Return to posts index

Tim Jones
Re: Excruciatingly looong backup time to LTO-6 with Bru-PE
on May 13, 2016 at 4:38:41 am

We're looking into the aggressive nature of App Nap since BRU PE's actual backup engine is running in a background thread. If it's left unattended for too long, App Nap reduces our priority and we slow down.

In the meantime, check the status of App Nap on your system (it's now a hidden option) using:

defaults read NSGlobalDomain NSAppSleepDisabled

Does that return 0, 1, or unknown?

To turn that on (disable App Nap), use:

defaults write NSGlobalDomain NSAppSleepDisabled -bool YES

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index


Neil Sadwelkar
Re: Excruciatingly looong backup time to LTO-6 with Bru-PE
on May 13, 2016 at 3:36:53 pm

Here's a transcript of my system about AppNap

Last login: Fri May 13 10:57:46 on console
xxxxxxxx:~ xxxx$ defaults read NSGlobalDomain NSAppSleepDisabled
2016-05-13 20:56:58.371 defaults[62761:409156]
The domain/default pair of (kCFPreferencesAnyApplication, NSAppSleepDisabled) does not exist
xxxxxxxx:~ xxxx$ cd /
xxxxxxxx:~ xxxx$ defaults read NSGlobalDomain NSAppSleepDisabled
2016-05-13 20:57:24.917 defaults[62807:409528]
The domain/default pair of (kCFPreferencesAnyApplication, NSAppSleepDisabled) does not exist
xxxxxxxx:~ xxxx$ defaults write NSGlobalDomain NSAppSleepDisabled -bool YES
xxxxxxxx:~ xxxx$ defaults read NSGlobalDomain NSAppSleepDisabled
1
xxxxxxxx:~ xxxx$

And my Energy Saver settings...



-----------------------------------
Neil Sadwelkar
neilsadwelkar.blogspot.com
twitter: fcpguru
FCP Editor, Edit systems consultant
Mumbai India


Return to posts index

Tim Jones
Re: Excruciatingly looong backup time to LTO-6 with Bru-PE
on May 13, 2016 at 7:18:14 pm

We believe that the App Nap shut off will be the big winner here. Let us know what the change results in.

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]