FORUMS: list search recent posts

BRU PE LTO4 Slow Backup

COW Forums : Archiving and Back-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jack Bonnett
BRU PE LTO4 Slow Backup
on Mar 15, 2016 at 11:35:20 am
Last Edited By Jack Bonnett on Mar 15, 2016 at 11:38:36 am

Hi There,

As with other posts in this thread we find ourselves out of support with our Archive drive and are now starting to see some problems.

We've got an HP Storageworks Ultrium 1760SAS connected to an old mac (Power PC OS 10.5.8 old) running BRU PE (2.something I think)

It's been a really good system for us so far but all of a sudden the archiving has started to run really slowly. It's currently taking about an hour per GB to archive any files from FW drives connected directly to the Mac..... and when you are sitting on a couple of TB of cards that need backing up that all of a sudden isn't very practical.

The drive has been recently and regularly cleaned

I've looked for the HP L&TT software and after a bit of hunting found it but it is now only available for OS 10.7 and above.

I know this is kind of our own issue as we are on outdated hardware but at the moment there's not really time/spare capacity to move everything over to another tower.

Does this sound like a dying drive issue or are there other issues that it could be? Does anyone have the ability to get hold of a version of L&TT tools that might run on a 10.5.8 system?

Thanks again folks.



Return to posts index

Tim Jones
Re: BRU PE LTO4 Slow Backup
on Mar 15, 2016 at 4:14:41 pm

Hi Jack,

LTO-4 SAS drives are rated at 80MB/sec for HH and 120MB/sec for FH. A Firewire 800 drive will deliver between 65MB/sec and 75MB/sec depending on how it's formatted and the data type.

With those numbers, what WERE you seeing before and what ARE you seeing now in BRU's summaries? You can get these numbers from the bruexeclog:
/Library/Application Support/BRU PE/log/bruexeclog
For example:
20160315 09:05:09|36227|tjones|[L163] START (r 18.1.0.25), CMD = 'bru -cvvvf /dev/null -b 128k /Volumes/ArGest Cube HDD45/LJA Training/'
20160315 09:05:09|36227|tjones|[L167] device = /dev/null, buffer = 128K bytes, media size = , archive id = 56e832b58d83, (Op)
20160315 09:05:33|36227|tjones|[L182] wrote 5533568 blocks (11067136 KBytes) on volume [1], 0:00:24, 461130 KB/sec

Since you're still running that very old version of BRU PE and the same version of OS X, the software has not changed. This leads to the hardware (including your Mac system's Firewire chipset) as the most logical culprit.

What number do you see if you use BRU PE's I/O engine to write to /dev/null (the bit bucket)?
sudo bru -cvvvf /dev/null -b 128k /Volumes/FirewireDrive/DataFolder
As an example (you may need to scroll this section horizontally to see the whole thing on The Cow...)-

$ bru -cvvvf /dev/null -b 128k /Volumes/ArGest\ Cube\ HDD45/LJA\ Training/
archive ID = 56e832b58d83
label =
buffer size = 128k bytes
media size =
c 0K [1] /
c 0K [1] /Volumes
c 0K [1] /Volumes/ArGest Cube HDD4
...
c 10985216K [1] /Volumes/ArGest Cube HDD45/LJA Training/FCP X 10.2 - Effects/Chapter 9 - Color Correction/FX2 09.11 NEW Pleasantville.mov
c 11007872K [1] /Volumes/ArGest Cube HDD45/LJA Training/FCP X 10.2 - Effects/Chapter 9 - Color Correction/FX2 09.12 NEW Broadcast.mov
bru: [I181] wrote 5533568 blocks (11067136 KBytes) on volume [1], 0:00:24, 461130 KB/sec

That 461MB/sec is higher than what you'll see, but I only have one of my Thunderbolt-conneted 6 drive arrays available to test right now.

Answer to these will give us more info to work with to troubleshoot what you're running into.

These same steps are good for any BRU user to check whether they are running into a source drive bottleneck or issues with their tape drive(s).

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

Jack Bonnett
Re: BRU PE LTO4 Slow Backup
on Mar 16, 2016 at 7:10:30 pm

That's some good troubleshooting!

I'll take a look when I can thanks for the pointers.



Return to posts index


Tim Jones
Re: BRU PE LTO4 Slow Backup
on Mar 23, 2016 at 6:54:07 am

Hi Jack,

Any updates?

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]