FORUMS: list search recent posts

Bru W042 error

COW Forums : Archiving and Back-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
John Kaley
Bru W042 error
on Feb 20, 2015 at 4:48:43 pm

Computer 1: Main Production computer (Mac)
Computer 2: Backup/Archive BRU LTO-5 computer (Mac)

The two computers are connected via Ethernet and I archive projects from Computer 1 to Computer 2

When I go to restore projects from Computer 2 to Computer 1, BRU generates an error W042. Something to do with symbolic links:

[W042] filename: warning - error setting owner/group: errno = code, description
BRU received an error from the operating system when attempting to set the owner id or group id of filename. The error occurred when BRU was executing the system call chown. The reason is indicated by the UNIX error message. On systems which support symbolic links, this error can occur when BRU attempts to set the owner/group id of a symbolic link which points to a file which does not exist. This can occur if the symbolic link filename is restored, but the file the symbolic link points to is not restored.


The permissions/sharing on Computer 1's destination volumes are set to "Read/Write" and "Ignore Ownership on this Volume"

The error does not occur if I restore locally on Computer 2.

Is there a simple permission setting that I'm missing on my Computer 1 drives? Is it an ethernet issue?


Return to posts index

Tim Jones
Re: Bru W042 error
on Feb 20, 2015 at 6:48:25 pm

That's why it's a warning [W042] and doesn't cause your restore to abort. You've answered your own question, BTW - Ownership and Permissions are ignored on the volume. This means that BRU can't reset them to the original values. BRU still restores the file properly.

You can either ignore the warnings, or enable ownership and permissions on the volume until the restore completes and then disable them again.

BRU does its best to restore exactly what it backed up.

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

John Kaley
Re: Bru W042 error
on Feb 20, 2015 at 10:41:27 pm

Thanks Tim.

Regardless if "Ignore Ownership on this Volume" is checked or unchecked, BRU still returns the error message. The volume privileges are set to Read&Write.

My main restore problem comes when I have to restore image sequences with over 1000 files; BRU aborts the restore because of the error messages. My workaround is to restore to the local computer and then transfer the files. I'd rather just transfer directly.

I'll have to brush up on my UNIX permissions and see if I can get it to work.


Return to posts index


Tim Jones
Re: Bru W042 error
on Feb 20, 2015 at 10:57:39 pm
Last Edited By Tim Jones on Feb 20, 2015 at 10:58:26 pm

Did you authenticate when your started BRU PE?

One additional change you can make is to boost the number of allowed warning messages in the brutab file. Open a ticket with our support guys (support.bru.com) and they'll help you set that up.

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

John Kaley
Re: Bru W042 error
on Feb 23, 2015 at 9:02:13 pm

Thanks Tim.

Yes, BRU is authenticated when started. I'm going to pursue my permissions issue first and try and solve the problem at the root.


Return to posts index

John Kaley
Re: Bru W042 error
on Feb 24, 2015 at 4:53:13 pm

I found a solution, so I'm posting it.

Using smb:// instead of afp:// to sign on to the network eliminates the BRU error messages. The trade-off is that the restore is MUCH slower. I'm looking into why that would be.

BTW, the two Mac are direct-connected using using the second ethernet port on each Mac.


Return to posts index


Tim Jones
Re: Bru W042 error
on Feb 24, 2015 at 7:09:42 pm
Last Edited By Tim Jones on Feb 24, 2015 at 8:24:55 pm

What if you specify smb2://?

[edit] it appears that Apple has removed that option from the mount types in Yosemite ... instead, try this option in the Terminal:

sudo sysctl -w net.inet.tcp.delayed_ack=0

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

John Kaley
Re: Bru W042 error
on Feb 24, 2015 at 8:23:54 pm

Thanks Tim,

smb2:// is not supported. Using OS 10.9 Mavericks on both machines. Maybe I can enable this?

Some time tests for restoring a 1.5GB project:
Using afp: 36 seconds (with error messages)
Using smb: 5mins 58sec. (no error messages)

Major time difference!


Return to posts index

Tim Jones
Re: Bru W042 error
on Feb 24, 2015 at 8:26:19 pm

I discovered and edited that post just as you posted. The other option is to modify Apple's lazy ACK with this command:

sudo sysctl -w net.inet.tcp.delayed_ack=0

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index


John Kaley
Re: Bru W042 error
on Feb 26, 2015 at 1:24:50 pm

Thanks Tim,
I'll test this when I can. Should this be entered in the terminal on both computers or just the BRU machine?



Return to posts index

Tim Jones
Re: Bru W042 error
on Feb 26, 2015 at 7:06:31 pm

Both machines so that you'll get good performance from both backup and restore.

Tim
--
Tim Jones
CTO - TOLIS Group, Inc.
http://www.tolisgroup.com
BRU ... because it's the RESTORE that matters!


Return to posts index

John Kaley
Re: Bru W042 error
on Mar 3, 2015 at 6:24:57 pm

Thanks Tim,
I tried the terminal command, and SMB is still much slower than AFP.

I'll probably end up calling support modifying the BruTab file as you've suggested as a work-around.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]