FORUMS: list search recent posts

i need the old 2.0.3 canon 7d firmware - trying to install magic lantern. can anyone send me the file or download link?

COW Forums : Canon EOS DSLR

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
sam Smith
i need the old 2.0.3 canon 7d firmware - trying to install magic lantern. can anyone send me the file or download link?
on Aug 10, 2014 at 6:49:08 pm

Hi there,

I stupidly just updated my canon 7D and now have realised it needs to be running on 2.0.3. Does anyone have the correct firmware they could send me?

I am using a mac book pro and am in the UK - don't know if that last point about being in the UK makes any difference but thought I would add it just in case.

Thanking you all!

Samantha.
sveater@hotmail.com


Return to posts index

Ryan Holmes
Re: i need the old 2.0.3 canon 7d firmware - trying to install magic lantern. can anyone send me the file or download link?
on Aug 11, 2014 at 2:10:34 am

Google is your friend for stuff like this: http://bit.ly/1plNKri

Ryan Holmes
http://www.ryanholmes.me
@CutColorPost


Return to posts index

sam Smith
Re: i need the old 2.0.3 canon 7d firmware - trying to install magic lantern. can anyone send me the file or download link?
on Aug 11, 2014 at 7:47:40 am

I have obviously tried this ryan or I wouldn't be asking on this forum.


Return to posts index


Ryan Holmes
Re: i need the old 2.0.3 canon 7d firmware - trying to install magic lantern. can anyone send me the file or download link?
on Aug 11, 2014 at 2:20:04 pm

[sam Smith] "I have obviously tried this ryan or I wouldn't be asking on this forum."

The links to the firmware you're requesting show up in that Google search Sam. It just takes a little clicking.

http://canoncanada.custhelp.com/app/answers/detail/a_id/39158/related/1/ses...

http://www.canon.com.au/en/Personal/Support-Help/Support-News/Firmware-Upda...

http://drivers.softpedia.com/get/SCANNER-Digital-CAMERA-WEBCAM/CANON/Canon-...

One other piece of advice, if you're running hacked firmware (i.e. Magic Lantern) you should never update the firmware on your camera. Since ML is modifying the actual firmware, if even temporarily, it may not work (and may in fact brick the entire camera) when booting on top of a firmware that it's not conditioned to work with yet. Additionally, if you're going to run software hacks you should start keeping a log of previous firmwares (both Canon and ML) so that should you update and have problems you can roll back to a previous working version. The ML hack is not authorized or supported by Canon. So proceeding slowly on any updates from either is recommended.

Ryan Holmes
http://www.ryanholmes.me
@CutColorPost


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]