FORUMS: list search recent posts

PP & UltraStudio Express

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Tim Phillips
PP & UltraStudio Express
on May 18, 2017 at 12:09:06 am

Hi all,

I saw a similar question on this forum, but mine is slightly different. Sorry for the extra post.

Is anyone successfully using a BM UltraStudio Express with Premiere Pro? I'm on a new iMac running 10.12.3 and using the latest CC update.

When I turn up the analog export from the UltraStudio on my Mackie mixer, I'm hearing a ton of hiss. Whether my timeline is playing or not.

Blackmagic tech support basically said that I can't expect good audio from the UltraStudio Express and that I should upgrade to their 4K box. They said a lot of hiss coming through the box was normal. It was a very odd phone call. And I find it very hard to believe that thousands of users of Premiere and this box are accepting hissy audio.

On my previous iMac I was using a Matrox MX02 Mini and it worked perfectly & did everything I needed it to do. Unfortunately it doesn't work with the newest Mac OS.

Any thoughts? Thanks.

Tim


Return to posts index

Peter Garaway
Re: PP & UltraStudio Express
on May 19, 2017 at 10:42:38 pm

Hi Tim,

Sorry I don't have much value to add here but thought I'd mentioned I successfully recorded to tape with the Blackmagic Express box a few years back. Seems odd they would say "hiss coming through the box was normal".

I don't have the equipment anymore to test or else I'd try it out.

Hopefully, someone will have more insight or maybe call back and fingers crossed you can speak with someone else ☺

Good luck!

Peter Garaway
Adobe
Premiere Pro


Return to posts index

andy patterson
Re: PP & UltraStudio Express
on May 19, 2017 at 11:11:09 pm

That sounds odd to me. Having said that I don't get any hissing sounds with my Intensity Shuttle using a Windows PC. I would like to think the Ultra Studio Express would be better than the Shuttle. Could there be some option that needs to be selected in your software? Did you try a few different drivers? Some times the drivers are buggy. A few screen shots might help.


Return to posts index


Kannan Raghavan
Re: PP & UltraStudio Express
on May 23, 2017 at 12:42:22 pm

Hey Tim,
I'm using a BM Ultrastudio Express with my MBP. Been using it for over 4 years. It works like a charm.
As I understand, you plug in the analog out XLRs from the breakout cable into the Mackie. I'm currently using the analog output for monitoring. Works well.
The first thing you can try is uninstalling the BM desktop video and installing one that is 4 or 5 versions back. Hope this works.

Kannan


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]