FORUMS: list search recent posts

Banding in the sky only after I render a clip

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Luke Pearson
Banding in the sky only after I render a clip
on Oct 31, 2016 at 9:19:08 pm

I have an opening scene in a video I'm working on that starts with a slow fade in. That first clip looks crisp and smooth until I render the clip. Then you can see terrible banding in the sky during the fade. It's also there after export.

The footage was shot on an FS7. thanks for any help!


Return to posts index

Duke Sweden
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:33:37 am

By "rendering" do you mean rendering the timeline to play back smoother, or encoding the clip with Media Encoder, for example? If you're encoding what codec are you using?

Also, you can eliminate most of the banding by adding like 3-5% film grain to your footage.


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:43:12 am

thanks for the quick reply. by "rendering" I mean in the timeline for smoother playback. as in, changing the render bar from yellow to green. When the render bar is yellow there is no banding and the dissolve is smooth and clean. as soon as I render it or export it, the banding is present.

I've exported to different codecs with no luck too. I've tried the grain too with no luck.


Return to posts index


Alan Lloyd
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:36:01 am

That sort of banding is usually the result of significant bitrate reduction.

It's not just the codec, it's the data rate.

And yes, adding just a touch of noise might help smooth things back out, just don't step on it too hard in the encoding/output!


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:44:36 am

thanks for the help. There is already noise added to the clip which isn't helping. Is there anything else I can do to stop the bitrate reduction?


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:50:06 am

here is a before/after render picture:





Return to posts index


Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:53:03 am

they kind of look the same after exporting and uploading jpegs but in the timeline they look night and day different. One is smooth and the other has noticeable banding in the sky


Return to posts index

Alan Lloyd
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:32:20 am

Another thought, in the form of a question: What are you outputting and what are your settings? (File type, resolution, data rate, etc.)


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:41:04 am

I've tried exporting in different formats/codecs/data rates with little change. The weird part is that the footage looks great when it's in the timeline with a yellow bar (unrendered) over it. There is absolutely no banding. It's not until I render or export the clip do you see the banding.


Return to posts index


Duke Sweden
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:18:34 am

From Adobe:
Video Rendering settings
Video Rendering settings control the picture quality, compression settings, and color depth that Premiere Elements uses when you play video from the Expert view timeline.

To access Video Rendering settings, choose Edit > Project Settings > Video Render. These settings include the following options:

Maximum Bit Depth

Allows Premiere Elements to use up to 32‑bit processing, even if the project uses a lower bit depth. Selecting this option increases precision but decreases performance.

File Format

Specifies the format of the preview video.

Compressor

Identifies the codec (compressor/decompressor) that Premiere Elements applies to generate movie previews. The project preset defines the codec. You cannot change it because it must conform to the DV standard.


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:39:04 am

i think the instructions you posted are for Premiere Elements but I get what you're saying. I checked this process in premiere pro too but nothing changed. In the sequence settings there is a checkbox for "max bit depth".


Return to posts index

Duke Sweden
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 2:14:44 am

Yeah, I went to check if the same settings were available in PPro and for some reason it wouldn't load. So I had to reboot. Then I got hungry and went on a food run.

You know, I see LOTS of PPro bugs here that only one person is experiencing. This seems to be one of them. Have you ever had this problem before? Or have you just not noticed? Do you have other footage with a lot of sky shot in them that you could compare?


Return to posts index


Alan Lloyd
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:29:56 am

Another issue I can see is that with the images as dark as they are there is very little dynamic range available for depiction of any gradient in the sky. While I'm sure it's called for in the narrative you're really limiting yourself into a corner with how little of the available palette that's being used in those images.


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:34:28 am

sorry! forgot to mention the images i posted are midway through the fade up. thats why they're dark. Thats the only place the banding is occurring so thats why I posted those.


Return to posts index

Alan Lloyd
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:45:52 am

That makes sense.

I'm not sure what to tell you at this point.

When you play the timeline is the banding there during the fade up?

If you output at "match sequence settings" is the banding there?

In the most extreme scenario, is substitution of a different shot possible within your narrative? One that would not have the sky so prominent, maybe?


Return to posts index


Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:57:53 am

The banding is there when I play it in the timeline if the clip is rendered (green). If it's still yellow (unrendered) there is no banding.

it's still there when you "match sequence settings" on output too.


Return to posts index

Chris Wright
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 2:27:53 am

is that a 8 bit transition? and is your render output 8 bit?


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 11:45:00 am

I've tried using a typical "dissolve" transition as well as changing the opacity. I also just tried "film dissolve" which is a 32 bit transition. they still all show banding after rendering.

how do I change my render output bit depth?


Return to posts index


John Pale
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 12:51:02 pm

What codec are your previews set to? Change it to Pro Res or some other 10 bit codec.


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:13:00 pm

where do i change the preview codec?


Return to posts index

John Pale
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 5:24:02 pm

[Luke Pearson] "where do i change the preview codec?"

Bottom portion of Sequence Settings. In some sequence presets, the default is MPEG I-Frame, which I believe is 8 bit.


Return to posts index

Jan Janowski
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:17:26 pm

That looks to be an 10 bit/8 Bit issue.

10 bit video displayed on 8 bit device will do exactly that...
Since you saw it correctly prior to render, what you saw it on was 10 bit.. Could it be the render outputs only 8 bit?


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 1:21:14 pm

how do I check to see what my render outputs are set to?


Return to posts index

Jeff Pulera
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 3:01:49 pm

Hi Luke,

When you do the final export, do NOT check the box for USE PREVIEWS, as this will carry the issue over from the low quality temp render files to the final output.

Thanks

Jeff Pulera
Safe Harbor Computers


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 5:15:14 pm

Let me know if anyone else has any ideas. Jeff was helping on another thread as well and we still couldn't come up with a solution that worked. I appreciate everyone's time.


Return to posts index

Richard Herd
Re: Banding in the sky only after I render a clip
on Nov 1, 2016 at 9:38:00 pm

WHat's your keyframe distance?


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 2, 2016 at 3:09:54 am

thanks for taking a stab at this, Richard. I've tried the keyframes at a bunch of different distances as well as using other fade methods such as black matte fading out revealing image, dissolve transitions, etc. None of those made a difference that I could tell. The fade up looks perfect until it was rendered or uploaded.


Return to posts index

Richard Herd
Re: Banding in the sky only after I render a clip
on Nov 3, 2016 at 12:02:27 am

But that doesn't answer the question. ? In the old days, like 5 years ago, haha, we could Force a keyframe using markers. I can't find a way to do that in Premiere. But if you find it, please let me know. Anyway before every dissolve I always placed a marker, 1 frame before the dissolve started.

I always set my keyframe distanct to half the timebase. So if you're in 24fps, keyframes at 12. If you're at 30, keyframes at 15 etc. And for me, I personally never use the default because the corresponding size in video file is really not that big given that we're dealing with video files which are already massive.

Another trick is this: the dissolve drag-and-drop thing uses some kind of blending mode and will interpolate frames if you do not have enough handle, so you can use your own blending mode by overlapping the clips and keyframing the opacity. If that doesn't work there are a few more techniques using Dynamic Link into After Effects.


Return to posts index

Alan Lloyd
Re: Banding in the sky only after I render a clip
on Nov 7, 2016 at 1:21:16 am

Ever get this sorted?


Return to posts index

Luke Pearson
Re: Banding in the sky only after I render a clip
on Nov 8, 2016 at 11:30:49 am

Unfortunately I did not. I tried every technique that was recommended with no luck. I had to move forward with the project as I had a deadline to hit. I'll try some camera tests soon and see if I can replicate the issue I was having with different shots. Here is the final edit (banding included):







Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]