FORUMS: list search recent posts

PrPro Buggy on new iMacPro

COW Forums : Adobe Premiere Pro

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Clay Coleman
PrPro Buggy on new iMacPro
on Feb 19, 2019 at 12:33:37 pm

Running the latest version of PrPro on a new iMacPro with 14 Cores, 64GB RAM, 16GB Graphics.

Performance is very buggy. Projects freeze up and crash, folders get deleted from the project, little things like title safe windows are broke, workspaces won't save properly, external video via Blackmagic card is broke, etc...

All of that makes PrPro basically unusable.

What gives? I've been through the standard protocol of re-installing, re-booting, and the usual but no help. Otherwise, the machine is running fine. Other apps like DaVinci are performing without issue.

Anybody else? Any suggestions?

Thx,
Clay


Return to posts index

Gary Huff
Re: PrPro Buggy on new iMacPro
on Feb 19, 2019 at 4:20:30 pm

[Clay Coleman] " folders get deleted from the project"

That indicates issues outside of Premiere, regardless of how well DaVinci Resolve runs.

[Clay Coleman] "little things like title safe windows are broke, "

Elaborate.

[Clay Coleman] "external video via Blackmagic card is broke"

Elaborate.

Also, when you say DaVinci Resolve is okay, what do you mean by that? Are you actively editing projects in Resolve? Just transcoding in Resolve? Just opening Resolve, clicking around on some panels, and then closing it back again?


Return to posts index

Merlin Vandenbossche
Re: PrPro Buggy on new iMacPro
on Feb 26, 2019 at 9:32:59 pm

This is little information to go on, a lot depends on codec and the type of footage you use.

Performance is very buggy. Projects freeze up and crash

It helps to reset your preferences (SHIFT + ALT while launching the app) and completely delete the dreaded cache folder in your user library. Always try those first. And try to create a completely new project and re-import the old one completely, do this especially if you updated your projects from an older version.

folders get deleted from the project,

This is a bit vague, you mean bins are deleted?

little things like title safe windows are broke

This is a bug, I can replicate it. You'll have to wait out for a bug fix.

workspaces won't save properly

Make sure to disable the 'import workspace from project' option under the workspaces menu. If not you'll always carry the workspace of the person who last saved the project. Maybe try deleting your old saved space and re-save it.

external video via Blackmagic card is broke, etc...

Make sure to install the latest 'Desktop Video' drivers from the download page of Blackmagic. PPro needs the drivers to send a signal through a blackmagic card (Resolve may have these built in?). And remember you can't just send any timeline through every card / mini monitor. Some support 4K, some don't. Sometimes the same footage placed in a 1080 timeline sends the signal when a 4K timeline doesn't (again, Resolve maybe scales this automatically since it is designed by blackmagic?)

Good luck! It sucks to have stuff go wrong like this! :-x


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2019 CreativeCOW.net All Rights Reserved
[TOP]