FORUMS: list search recent posts

ARRI Locaster (LED).... delay

COW Forums : ARRI

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
andy lewis
ARRI Locaster (LED).... delay
on Apr 25, 2017 at 4:33:04 am

I bought an ARRI Locaster LED in 2011 - low output but decent light, colour-adjustable and very portable.

Right from the first job I noticed that there was often a delay of a minute or five between switching it on and the light deciding to make an appearance. We even used to joke about it on set - it's testing the electricity before it commits itself. I actually wondered if that was really the case. We were filming in 6 different countries in one month so every time we plugged it in the current was different.

Fast forward to 2016 and the delay between switch and light has jumped to 10 minutes - 2 hours. It's now effectively useless as it can't be relied on to even turn on before filming starts.

I took it to ARRI who initially said that there was nothing they could do as a repair would be more expensive than a replacement. When I explained that the problem had been apparent from day 1, they offered to replace it with a Locaster 2 if I paid an additional 200 euros. I accepted this in the hope of a quick resolution. This was 6 months ago and they have only just got the Locaster 2 in stock.

I don't feel great about handing over 200 euros now. It's over 9 months since I left the Locaster in ARRI's office so obviously I've had to find (and pay for) alternatives.

So, apologies for rambling...

Has anybody experienced anything similar with an LED light?
Does paying 200 euros for a replacement (9 months after leaving the light for repair) seem reasonable to you?

I'm really disappointed and surprised that of all the lighting equipment I've bought, the only company that ever sold me something faulty is ARRI! That's not what I expected at all.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]