FORUMS: list search recent posts

Stand-alone E-sata and RAID 1 mirror - same controller

COW Forums : RAID Set-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mark Aisbett
Stand-alone E-sata and RAID 1 mirror - same controller
on Nov 16, 2010 at 1:23:49 am

Can any RAID experts make a quick comment as to whether it is possible to have a stand-alone hotswappable E-SATA drive running along side a RAID 1 Mirror on the same contoller.

Some people have advised me it should work provided you dont join the E-sata drive to the array. I found the exact opposite happened with me. I had to add it as a single Raid 0 drive, meaning it is not hot swappable.

Any opinions would be welcome.

The full details of my setup and requirements can be found below.

---------------------------------------------------------------------

Ok Guys, here is where I am at with my goal of connecting a stand-alone e-sata drive to a SBS 08 Server (C drive configured as RAID 1 mirror). Note that the MOBO is a S3420GPLC.

- In Bios, configured SATA/RAID mode to ESRT2 (Intel Embedded Raid Technology).

- After Post screen, pressed “Ctrl + E” which takes you to the Intel® Embedded Server RAID BIOS Configuration Utility. Once in the utility, I created a virtual drive, made up of 2 x 1TB drives. The virtual drive was automatically configured as a RAID 1 mirror. Note the SBS OS runs on this mirror volume.

- Whilst in the utility, I also noticed that the cd-rom drive was automatically included as a RAID controlled device (very annoying I think). In the BIOS, it appears as a RAID-embedded cd-rom device as well. There doesn’t appear to be a way to have it as a standard SATA cd-rom.

- I powered off the Server and connected a 1.5TB e-sata drive. Rebooted and pressed “Ctrl + E” again. Noticed that the new drive appeared as an “unknown” device and more importantly was not part of the original RAID 1 array created initially. According to someone (who has good RAID experience), the new SATA drive will usually work as a stand-alone drive unless you explicitly add it to the array. So, I left it alone and rebooted the Server into Windows but the new drive did not even appear in device manager. Unfortunately, his theory did not apply in my case.

- I rebooted Server and pressed “Ctrl + E” again to enter the utility. This time, I decided to create a new RAID array (with 1 drive lol). It was automatically configured as a RAID 0 volume but with only 1 stripe. So the RAID setup was a follows:
– Virtual Disk 0 = 2 x ITB forming a RAID 1 array (mirror)
– Virtual Disk 1 = 1 x 1.5TB forming a RAID 0 array (1 stripe)

- Rebooted the Server into Windows and voila, the new e-sata drive appeared as a drive in disk management. Initialised the disk and formatted it and all is well.
Ok, so I may have achieved my original goal but the present configuration is not without its faults. Here are some of the reasons:

- The e-sata drive is not hot-swappable (as some of you guys had warned me about). I was hoping it might have been treated as an AHCI device but it seems that as it is being treated as an ESRT2 device, it is not hot-swappable. You can create a hot-spare drive but that is just an inactive spare drive that is automatically rebuilt when one of the disks in the RAID 1 mirror fails. Any ideas on if or how this can be achieved. One idea I have is to go into the BIOS and change the RAID mode to “Intel® Matrix RAID” mode. That seems to be the newer RAID technology so maybe it will provide additional configuration options. I think in this mode, you swap “ctrl + e” with “ctrl + i”. My only concern is that if I change to this mode, will the mirror volume containing the OS need to be re-built? I also tried installing the “Intel® RAID Web Console 2” but it did not find any servers. Apparently, you can get into the BIOS version of this by pressing “Ctrl +G” (but I have not tried it yet). It’s called the “Intel® RAID BIOS Console 2 Utility”.

- The other issue I have is about the cd-rom. Why is it automatically treated as a RAID controlled device. When I booted off the SBS disk for testing, it couldn’t find the Windows installation so it asked for the RAID drivers. The raid drivers were on a cd-rom but Windows could not load the CD as it needed the RAID drivers as well. A silly situation I guess where RAID loads the Windows DVD into memory but then Windows can’t load a CD/DVD after that. Anyway, I guess I will have to put the RAID drivers on a USB stick and try that.

So, in short partially happy that I got the e-sata device going but would prefer it if it was hot-swappable. Also, would prefer it if the DVD drive was not controlled by RAID.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]