FORUMS: list search recent posts

Faulty component?

COW Forums : RAID Set-Up

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Daniel Arbogast
Faulty component?
on Nov 4, 2010 at 5:25:46 pm

I have a fiber channel raid connected to my G5 Mac. Yesterday video and audio suddenly started dropping out on the Volume. Audio was static and video would have all sorts of blocks and corruption.

This is the second time this has happened in the past few months. I am looking for advice on which component might be failing. It is RAID5 and the subsystem is reporting no disk errors. My thoughts are that the raids controller or maybe even the computers fiber channel card may be on its way out? The disk has since totally dropped off and can no longer be mounted.

I tried out a demo of data rescue to restore a few files and everything it returns is totally corrupt.
I will try out DiskWarrior next for rebuilding I suppose.

Any suggestions or advice would be appreciated. Really don't want this to happen again.


Here's a bit of output from terminal:
edittheta$ /sbin/fsck_hfs -fdr /dev/rdisk3s2
/dev/rdisk3s2
Using cacheBlockSize=32K cacheTotalBlock=1024 cacheSize=32768K.
Journal replay returned error = 6
Checking Journaled HFS Plus volume.
Checking Extents Overflow file.
Checking Catalog file.
Rebuilding Catalog B-tree.
hfs_UNswap_BTNode: invalid node height (1)
Rechecking volume.
Checking Journaled HFS Plus volume.
Checking Extents Overflow file.
Checking Catalog file.
Missing thread record (id = 32965)
Invalid extent entry (4, 832)
Incorrect block count for file A017_C013_0805Q7_001.R3D
(It should be 2097152 instead of 256)
Incorrect number of thread records
(4, 176)
CheckCatalogBTree: fileCount = 19939, fileThread = 19956
Checking multi-linked files.
Checking Catalog hierarchy.
Missing thread record (id = 38125)
Invalid volume file count
(It should be 19934 instead of 19939)
Checking Extended Attributes file.
Overlapped extent allocation (file 3 Extents Overflow BTree)
extentType=0x0, startBlock=0x2da35, blockCount=0x1400, attrName=(null)
Checking volume bitmap.
Volume Bit Map needs minor repair
Checking volume information.
Invalid volume free block count
(It should be 573459245 instead of 1830097600)
invalid VHB nextCatalogID
invalid VHB attributesFile.clumpSize
Volume Header needs minor repair
(2, 0)
Verify Status: VIStat = 0xa800, ABTStat = 0x0000 EBTStat = 0x0000
CBTStat = 0x0800 CatStat = 0x00004230
Repairing volume.
DoMinorRepair: Repair for type=-510 failed (err=32).
The volume Colossus could not be repaired.
volume type is pure HFS+
primary MDB is at block 0 0x00
alternate MDB is at block 0 0x00
primary VHB is at block 2 0x02
alternate VHB is at block 14642907054 0x368c907ae
sector size = 512 0x200
VolumeObject flags = 0x07
total sectors for volume = 14642907056 0x368c907b0
total sectors for embedded volume = 0 0x00


Return to posts index

Jon Schilling
Re: Faulty component?
on Nov 4, 2010 at 5:47:26 pm

Daniel.

You might want to contact the RAID Controller card company & give them that info. Once you've ruled that out, then you can move on to the next thing down the list that could be problematic.


Jon Schilling | Vice President of Sales & Marketing
RAIDON-USA Technology
STARDOM Storage by RAIDON
15356 East Valley Blvd., Suite B
City of Industry, CA 91746
Tel: 626-333-7888
http://www.stardom-usa.com/



Return to posts index

Daniel Arbogast
Re: Faulty component?
on Nov 4, 2010 at 6:38:38 pm

Spent a little time with support yesterday. Surprisingly enough they basically don't support this subsystem that is just coming on 5 years of age and said this should not be happening and recommended I reformat and rebuild.

I ran DiskWarrior, SUCCESS! Or so I thought... all files seemed fine and it was mountable. I rebooted my machine, now I can't see the device at all! What the heck....


Return to posts index


Bob Zelin
Re: Faulty component?
on Nov 5, 2010 at 5:25:11 pm

5 years for a drive array is very old. I still recommend exactly what your host adaptor company recommended - reformat and reraid your array.

Bob Zelin



Return to posts index

Daniel Arbogast
Re: Faulty component?
on Nov 5, 2010 at 5:32:08 pm

Thanks for your suggestions.

Re-ran DiskWarrior and copied all I could with , replaced a drive that reported a few errors and rebuilt... very odd glitch... hope its not a sign that the whole subsystem is on its way out as no physical errors have been reported. While I know 5 years for a hard drive is a long time I'd expect the other components to hold up for quite a while longer.


Return to posts index

Daniel Arbogast
Re: Faulty component?
on Nov 10, 2010 at 7:39:59 pm

Have reformatted the drive. When I copy over video files they have strange corruption / digital blocks appearing on the footage. Very strange... not really sure which part might be to blame. Maybe the fiber channel card or port on the subsystem?

Have also sent reports to QLogic (HBA manufacturer) and my Raid company.... :/ so frustrating. Kind of at a loss with a unusable 8TB volume...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]