FORUMS: list search recent posts

Issues with conversion after ffmpeg version upgrade

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Swapnil Daga
Issues with conversion after ffmpeg version upgrade
on Jun 12, 2012 at 11:47:44 am

Hi,

We are using ffmpeg to covert audios and videos from one format to other format.

Older version Details:
FFmpeg version 0.6.1, Copyright (c) 2000-2010 the FFmpeg developers
built on Jan 22 2011 15:15:24 with gcc 4.5.2
configuration: --enable-memalign-hack --enable-libmp3lame --extra-cflags=-I/local/include --extra-ldflags=-L/local/lib --arch=x86_64
libavutil 50.15. 1 / 50.15. 1
libavcodec 52.72. 2 / 52.72. 2
libavformat 52.64. 2 / 52.64. 2
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0.11. 0 / 0.11. 0
FFmpeg 0.6.1
libavutil 50.15. 1 / 50.15. 1
libavcodec 52.72. 2 / 52.72. 2
libavformat 52.64. 2 / 52.64. 2
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0.11. 0 / 0.11. 0


New version Details:
ffmpeg version N-41074-g9c27f29
built on May 27 2012 13:25:48 with gcc 4.6.3
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-runtime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass --enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 51. 55.100 / 51. 55.100
libavcodec 54. 23.100 / 54. 23.100
libavformat 54. 6.101 / 54. 6.101
libavdevice 54. 0.100 / 54. 0.100
libavfilter 2. 77.100 / 2. 77.100
libswscale 2. 1.100 / 2. 1.100
libswresample 0. 15.100 / 0. 15.100
libpostproc 52. 0.100 / 52. 0.100

We are facing issues with following conversions.
1. .MP4, .M2TS, .MOV and NTSC encoded video files to MKV/FLV/AVI formats

Commands used :
a. To FLV
ffmpeg.exe -i "D:Test DataVideosVideos all1_02_livingdead_NTSC.mov" -sameq -acodec libmp3lame -ac 2 -ar 22050 -ab 96000 -filter:v yadif -nr 500 -r 20 -g 500 -b 1200000 -me_range 20 -s 128X96 -report -y "D:Test DataVideosT_OutputFLV1_01_02_livingdead_NTSC.flv"
b. To MKV
ffmpeg.exe -i "D:Test DataVideosVideos all1_02_livingdead_NTSC.mov" -sameq -acodec libmp3lame -ac 2 -ar 22050 -ab 96000 -filter:v yadif -nr 500 -f flv -r 20 -g 500 -b 1200000 -me_range 20 -s 128X96 -report -y "D:Test DataVideosT_OutputMKV1_01_02_livingdead_NTSC.mkv"
c. To AVI
ffmpeg.exe -i "D:Test DataVideosVideos all1_02_livingdead_NTSC.mov" -sameq -acodec libmp3lame -ac 2 -ar 22050 -ab 96000 -vcodec mpeg4 -filter:v yadif -nr 500 -f avi -r 20 -g 500 -b 120k -me_range 20 -s 128X96 -report -y "D:Test DataVideosT_OutputAVI1_01_02_livingdead_NTSC.avi"


2. .RAM, .APE, .RA, .AIFF audio files to MP3/MP4/WMA formats

Commands Used:
a. To MP3
ffmpeg.exe -i "D:Test DataAudioTESTSRCdoublesize.ram" -ab 128000 -ac 2 -acodec libmp3lame "D:Test DataAudioTESTMP30_doublesize.mp3"
b. To MP4
ffmpeg.exe -i "D:Test DataAudioTESTSRCdoublesize.ram" -ab 128000 -ac 2 -acodec libmp3lame "D:Test DataAudioTESTMP40_doublesize.mp4"
c. To WMA
ffmpeg.exe -i "D:Test DataAudioTESTSRCdoublesize.ram" -ab 128000 -ac 2 -acodec wmav2 "D:Test DataAudioTESTWMA0_doublesize.wma"


When I run these commands, It throws error like
"Could not write header for output file #0 (incorrect codec parameters ?): Operation not permitted" and a 0KB file is created as output.


Am I going wrong somewhere.. Do I need to do some rectifications in the commands?
Any Pointers will be helpful.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]