FORUMS: list search recent posts

ffmpeg make install error

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ryan McMurray
ffmpeg make install error
on Mar 6, 2012 at 6:13:07 pm

i had ffmpeg installed via macports and then i noticed i didn't have libfaac enabled. i also was seeing issues with my encoded outputs not having the bit rates or other parameters that i had specified in my commands.
i decided to do a more manual re-install so i went by this guide http://pitchpublish.com/?p=173 until i had this error upon finally running install:

$ sudo make install
INSTALL libavdevice/libavdevice.a
LD libavutil/libavutil.51.dylib
ld: library not found for -lXfixes
collect2: ld returned 1 exit status
make: *** [libavutil/libavutil.51.dylib] Error 1

that was yesterday. today, i decided to try installing a different build of ffmpeg so i followed this guide (i'm running snow leopard on my mac) http://www.itecsoftware.com/install-ffmpeg-on-mac-snow-leopard

now i get this error when i install:

Undefined symbols:
"_sem_timedwait", referenced from:
_audio_read_packet in libavdevice.a(jack_audio.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [ffmpeg_g] Error 1

i have wasted a lot of time trying to get ffmpeg back and running correctly. i've googled everything i can think of and the answers i'm finding are too technical for me. i need clear instructions on what i might be able to do to fix this problem. i know jack and libavdevice are both in /usr/local/include but i don't know what to do with them (if anything).

any ffmpeg install wizards out there that might be able to lend a hand?

thank you,

-ryan


Return to posts index

Reuben Martin
Re: ffmpeg make install error
on Mar 8, 2012 at 3:24:12 am

The jack audio library / include files you have are probably not the correct version. I seriously doubt you need jack support on a Mac anyway. Disable jack support when setting up your configure options.


Return to posts index

Ryan McMurray
Re: ffmpeg make install error
on Mar 8, 2012 at 3:45:54 pm

thanks reuben!

with this in mind i rm'd the jack directory from /usr/local/include
and i rm'd jack* from /usr/local/lib
i rm'd the ~/ffmpeg folder and ran command:
svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
i cd to ffmpeg and run configure
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libx264 --enable-x11grab --enable-libvpx

then i run make and now i get a shiny new error:
Option number is ambiguous (number-footnotes, number-sections)
Try `texi2html --help' for more information.
make: *** [doc/developer.html] Error 2

what did i do to be cast into ffmpeg install hell this time?


Return to posts index


Reuben Martin
Re: ffmpeg make install error
on Mar 8, 2012 at 5:05:58 pm

run "./configure --help" to get a listing of all the options you can set. You can disable building documentation by appending "--disable-doc". From your config that you listed, you will probably want to disable x11grab as well. That functionality is kinda pointless on a Mac.


Return to posts index

Ryan McMurray
Re: ffmpeg make install error
on Mar 8, 2012 at 5:11:33 pm

hi all,

i found the root cause of this error and finally got ffmpeg installed.
here's what i did (in more detail than most command line veterans need because that's how i like MY instructions) in case anyone else runs into this problem:

in Terminal, run command:
texi2html -version

i found i was running version 5.0 of texi2html.
i read this post:
http://groups.google.com/group/ffmbc-discuss/browse_thread/thread/9fdf9194a...
where i learned that 5.0 is an old build and that i should remove it so a later version located in /usr/bin would be used in the ffmpeg make install instead.

so i ran command:
ls /usr/bin/texi2html
to make sure i had a version of texi2html in my /usr/bin

then i ran command:
which texi2html
to find out the location of texi2html that my system was seeing by default.

second to last, i got rid of the old version of texi2html by running command:
sudo rm /opt/local/bin/texi2html

and lastly, from the ~/ffmpeg folder i ran command:
sudo make install

and voila! install completed with no error.

love the cow.

-ryan


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]