FORUMS: list search recent posts

Streaming with ffserver & ffmpeg. Possible audio encoding issue

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Harold Hunt
Streaming with ffserver & ffmpeg. Possible audio encoding issue
on Feb 5, 2012 at 2:15:18 am

Hello,

I'm attempting to stream my desktop and audio with ffmpeg and ffserver. My ffserver config is posted below:

Port 8090
RTSPPort 1234
BindAddress 0.0.0.0
RTSPBindAddress 0.0.0.0
MaxHTTPConnections 2000
MaxClients 1000
MaxBandwidth 1000
CustomLog -
NoDaemon


File /tmp/stream.ffm
FileMaxSize 32M



Feed stream.ffm
Format rtp
File /tmp/stream.sdp
AudioBitRate 64
AudioChannels 1
AudioSampleRate 22050

VideoBitRate 128
VideoBufferSize 400
VideoFrameRate 15
VideoSize 384x240

VideoGopSize 12

VideoHighQuality
Video4MotionVector

AudioCodec libmp3lame
VideoCodec libx264



Also my ffmpeg command that I am using to stream is below.
ffmpeg -f x11grab -r 25 -s 384x240 -i :0.0 -f alsa -ac 2 -ar 44100 -i hw:0,0 -f rtp rtp://192.168.1.102:8090/stream.ffm

It has no problems running, however when I try to use either VLC or mplayer to play the stream, it will crash, both complain about audio not being encoded properly.

Thanks,
Harold


Return to posts index

Reuben Martin
Re: Streaming with ffserver & ffmpeg. Possible audio encoding issue
on Feb 5, 2012 at 8:02:41 pm

ffserver is a crusty old relic of the past that is not well maintained. You probably need to encode the video/audio before sending it to ffserver rather than depending on ffserver to transcode it. Not really sure though, I never use it. There are much better alternatives available. http://www.rtmpd.com/


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]