FORUMS: list search recent posts

Overlay a Animated Logo on a Video

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sergio Fonseca
Overlay a Animated Logo on a Video
on Dec 2, 2011 at 1:13:20 pm

This is my first post on this forum so i don't know if this the best forum for this issue or if I should put it on the bug tracker of ffmpeg. Sorry for any inconvenience.

I am trying to overlay an animated logo (mov video) with transparency using ffmpeg. I have almost succeeded on doing so.

I have created a MOV Video without sound with 32bpp to have the alpha channel for transparency. I have created the following ffmped command:
ffmpeg -i video.mpg -y -f mp4 -vcodec libx264 -b 3216k -vf "movie=Animatedlogo.mov[wm]; [in][wm] overlay=0:0 [out]" out.mp4

The problem with this command is that Animated logo isn't repeated over the video. The Animated logo is played only once and it's last frame keeps frozen on the rest of the video.

I know i could create an animated logo that has several loops of the animated logo. But i don't think this is the best option. I don't even know what happens if the overlay video is longer than it's input source.

I think the issue is that the libavfilter should have a loop option for video overlays which i don't think that it has.

Does anyone know if there is a better option for this? Is this a bug? Or is this a must have improvement?

Thanks in advance.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]