FORUMS: list search recent posts

FFmbc ubuntu

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Doug Bay
FFmbc ubuntu
on Apr 23, 2011 at 12:01:03 pm

I would like to install FFmbc on ubuntu 10.10. I found a walkthrough for debian but it does not work. Does someone have a walkthrough for installing it on Ubunut?


Thanks,
Doug



Return to posts index

Milivoj Ivkovic
Re: FFmbc ubuntu
on Sep 17, 2012 at 9:07:08 pm

You certainly have solved your problem by now, but in case others come across this thread, I just did the following on Ubuntu 12.04 LTS:

Make sure you have the necessary tools installed:

sudo apt-get install build-essential yasm

After downloading the latest source of ffmbc, and unpacking it into ~/src/

cd ~/src/FFmbc-0.7-rc7

./configure --enable-gpl --enable-nonfree --enable-runtime-cpudetect
make
sudo make install


make gave out lots of warnings, but it seems to work fine anyway.


Return to posts index

Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 23, 2012 at 3:36:42 am

I compiled a 64-bit .deb package for Ubuntu 12.04.1 LTS from my system.
Download at nerdsonstandby.com/dwnlds/ffmbc-0.7_0.7-rc7-1_amd64.deb Please prefix the install as Milivoj Ivkovic noted above with the yasm dependency.
sudo apt-get install build-essential yasm
Let me know if it doesn't work. It installed on my system.


Return to posts index


Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 22, 2012 at 7:27:44 pm

I too am interested in converting prores. My system is running Ubuntu 12.04.1 64-bit. I can get a clean picture turning 422 normal quality to mpeg or whatever with FFmpeg, however, I am loosing audio altogether. I would like to use FFmbc if it will be professional.


Return to posts index

Milivoj Ivkovic
Re: FFmbc ubuntu
on Oct 22, 2012 at 7:57:43 pm

I would like to use FFmbc if it will be professional.


ffmbc is quite "professional". It is it's target audience after all. However, it is not "casual-user-friendly". It's main advantage - being a command-line program, thus scriptable - is a disadvantage for other uses.

You can probably find help on the correct options to use for your purpose in the wiki (http://code.google.com/p/ffmbc/w/list), in the ffmbc-discuss google group, or with a specific web search. Note that ffmpeg now also supports ProRes, and is more widely used than ffmbc. So search for both.

Maybe we can help here as well, if you let us know what result you want, and show us the output of ffmbc -i "$your_file"


Return to posts index

Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 22, 2012 at 8:25:10 pm

FFmbc output from that file is:
FFmbc version 0.7-rc7
Copyright (c) 2008-2012 Baptiste Coudurier and the FFmpeg developers
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'PIX_001_002.mov':
Metadata:
major_brand: qt
minor_version: 537330688
compatible_brands: qt
creation_time: 1970-01-01 00:00:00
timecode: 00:00:00:00
Duration: 01:00:00.00, start: 0.000000, bitrate: 133219 kb/s
Stream #0.0(eng): Data: unknown (tmcd)
Metadata:
reel_name(eng): 001
Stream #0.1(eng): Video: prores, yuv422p10le, 1920x1080i tff, 130910 kb/s, PAR 1:1 DAR 16:9, 29.97 fps
Metadata:
codec_name: Apple ProRes 422
Stream #0.2(eng): Audio: pcm_s24le, 48000 Hz, 1 channels, s32, 1152 kb/s
Stream #0.3(eng): Audio: pcm_s24le, 48000 Hz, 1 channels, s32, 1152 kb/s
At least one output file must be specified


The last time I tried, the video was perfect, however, the audio is non existent.
I used:
ffmbc -vcodec prores -profile 2 -an -i infile.mov -t 360 -r 29 -b 12000k -acodec copy outfile.mpg


Return to posts index


Milivoj Ivkovic
Re: FFmbc ubuntu
on Oct 22, 2012 at 11:03:07 pm

Looks like you suppressed the audio with "-an".

You could try something like this:

ffmbc -i infile.mov -vcodec mpeg2video -b 12000k -acodec copy outfile.mpg

(I cannot test it right now, but hopefully that will be closer to what you are trying to do)


Return to posts index

Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 23, 2012 at 1:20:22 am

Tried the code you suggested. Here is some of the output:
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4821 size=5760
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3139 size=3456
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3139 size=3456
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3749 size=5760
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3749 size=5760
[mpeg @ 0x1351700] buffer underflow i=1 bufi=2055 size=3456
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=2055 size=3456
[mpeg @ 0x1351700] buffer underflow i=1 bufi=2665 size=5760
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=2665 size=5760
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=4694 size=5760
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3012 size=3456
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3012 size=3456
buffer underflow i=1 bufi=3622 size=5760
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=3622 size=5760
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times
[mpeg @ 0x1351700] packet too large, ignoring buffer limits to mux it
[mpeg @ 0x1351700] buffer underflow i=1 bufi=5651 size=5760
Last message repeated 1 times


Return to posts index

Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 23, 2012 at 4:08:48 am

Okay. Figured it all out for what I was trying to do. FFmbc, as it seems, was getting over run trying to output the audio even though I wanted it to copy the codec. I ended up using the line as noted below and all is encoding and playing back well. I'll double check the A/V sync further into the trans-code after the first one finishes.
ffmbc -i infile.mov -vcodec mpeg2video -b 12000k -acodec ac3 -ab 384k outfile.mpg
I sure hope this helps someone else.
Again, I am trans-coding Apple ProRes 422 Normal Quality recorded at 145Mb/s on a Sound Devices PIX 240i.


Return to posts index


Milivoj Ivkovic
Re: FFmbc ubuntu
on Oct 23, 2012 at 8:01:23 am

Maybe the mpeg video standard doesn't accept 24 bit audio, which is what you had in your original. That would explain why it now works, since you also transcode the audio.

BTW, you had a "-t 360" option in your original line, for testing I guess. If you want to restrict the duration, put that option before the input file. To transcode only the first 60 seconds:

ffmbc -t 60 -i $INPUT ...etc.


Return to posts index

Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 24, 2012 at 3:59:15 pm

I will try an output to another codec and container at another time to experiment with the audio.

A only slightly related question.

How do I get my Ubuntu 12.04 64-bit system to process the trans-code on all/more of my processor cores? FFmbc is only using one core on 100% of the trans-code.


Return to posts index

Milivoj Ivkovic
Re: FFmbc ubuntu
on Oct 24, 2012 at 4:22:02 pm

How do [...] process the trans-code on all/more of my processor cores?


-threads X (where is X is the number of threads to use)

To use all available cores:
-threads 0


Return to posts index


Brian VanMeeteren
Re: FFmbc ubuntu
on Oct 24, 2012 at 6:50:08 pm

"-threads 0" doesn't seem to default to all available. Errors out. I then entered 4 and its chugging along. Doesn't utilize the last three cores nearly as much as the first but at least they are doing something.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]