FORUMS: list search recent posts

Install FFMpeg + x264 + AAC + libavfilter on debian lenny

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Lossius Thomas
Install FFMpeg + x264 + AAC + libavfilter on debian lenny
on Jan 12, 2011 at 11:20:02 am

Hello all,

Sorry for my spelling, I'm French ...

My OS is debian lenny.

It's been three days (much more actually) that I have problems with FFmpeg, my goal is to install FFMPEG + x264 + AAC + libavfilter.
The encoding is done only with the x264 + AAC codecs, but FFMpeg should support many incoming formats.

5 methods I tried, but none seems to work, I get "Unknown encoding libx264" or "unrecognized option-vf" or make fails.

I'm stressed out, here is the last procedure I followed:

cd / home / src
wget http://freefr.dl.sourceforge.net/project/lame/lame/3.98.4/lame-3.98.4.tar.g...
tar-xvf lame-3.98.4.tar.gz
cd lame-3.98.4
. / Configure
make
make install

cd / home / src
git clone git: / / git.videolan.org/x264.git
cd x264
. / Configure - enable-pic - enable-shared
make
make install

apt-get install libfaad libfaac-dev-tools-dev libgsm libgsm1 libgsm1-dev libvorbis-dev libxvidcore4-dev

# FFMPEG SVN-r25942
svn checkout svn: / / svn.ffmpeg.org / soc / libavfilter
cd libavfilter
. / Checkout.sh
cd ffmpeg
git clone git: / / git.ffmpeg.org / libswscale /
export LD_LIBRARY_PATH = / usr / local / lib: / usr / lib: / lib
. / Configure - enable-libx264 - enable-gpl - enable-pthreads - enable-libmp3lame - enable-avfilter - enable-libmp3lame - enable-libvorbis - enable-libxvid - enable-libgsm - enable-postproc - enable-libfaac - enable-pthreads - enable-gpl - enable-x11grab - enable-nonfree - enable-shared - disable-ffplay - disable-ffserver

ffmpeg-v


I really hope someone can help me, I'm desperate!


Return to posts index

Michael Rampe
Re: Install FFMpeg + x264 + AAC + libavfilter on debian lenny
on Jan 19, 2011 at 9:51:56 pm

[Lossius Thomas] "It's been three days (much more actually) that I have problems with FFmpeg, my goal is to install FFMPEG + x264 + AAC + libavfilter."

Not sure about your issues... but:

Do you really need the SOC libavfilter? A lot of the SOC filters are now present in the trunk and unless there is something specific you need in libavfilter, I would recommend the FFmpeg SVN trunk rather than the version that SOC libavfilter needs/gets.

Michael


Return to posts index

Lossius Thomas
Re: Install FFMpeg + x264 + AAC + libavfilter on debian lenny
on Jan 20, 2011 at 10:44:51 am

thank you for your post but my problem is solved, i've found a issue :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]