FORUMS: list search recent posts

Error in http dynamic streaming TypeError - Error #1009

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
moahammad yazdian
Error in http dynamic streaming TypeError - Error #1009
on Oct 21, 2014 at 12:19:39 pm
Last Edited By moahammad yazdian on Oct 23, 2014 at 8:09:25 am

Hello everyone,
I am making mutli-bitrate streaming in FMS and FFMPGE.
In FFMPEG I create 4 bitrate of source video and publish it on the FMS through RTMP protocol (rtmp://my-server/livepkgr/mystreamName1?adbe-live-event=liveevent).

Now all configurations is working currently but sometimes I get this errors:
1- TypeError - Error #1009
2- Argument Error invalid bitrate

This is my FFMPEG syntaxt to create multi-bitrate:
ffmpeg -re -i j:\movie\warz.mkv
-preset ultrafast -threads 1 -vcodec libx264 -b:v 720k -r 24 -g 24 -keyint_min 4 -x264opts "keyint=4:min-keyint=48:no-scenecut" -s 856*360 -acodec libmp3lame -b:a 16k -ac 1 -ar 44100 -f flv rtmp://12.11.1.2/livepkgr/relation720p?adbe-live-event=relation
-preset ultrafast -threads 1 -vcodec libx264 -b:v 600k -r 24 -g 24 -keyint_min 4 -x264opts "keyint=4:min-keyint=48:no-scenecut" -s 856*360 -acodec libmp3lame -b:a 16k -ac 1 -ar 44100 -f flv rtmp://12.11.1.2/livepkgr/relation360p?adbe-live-event=relation
-preset ultrafast -threads 1 -vcodec libx264 -b:v 350k -r 24 -g 24 -keyint_min 4 -x264opts "keyint=4:min-keyint=48:no-scenecut" -s 570*240 -acodec libmp3lame -b:a 16k -ac 1 -ar 44100 -f flv rtmp://12.11.1.2/livepkgr/relation240p?adbe-live-event=relation
-preset ultrafast -threads 1 -vcodec libx264 -b:v 98k -r 24 -g 24 -keyint_min 4 -x264opts "keyint=4:min-keyint=48:no-scenecut" -s 342*144 -acodec libmp3lame -b:a 16k -ac 1 -ar 44100 -f flv rtmp://12.11.1.2/livepkgr/relation144p?adbe-live-event=relation
-preset ultrafast -threads 1 -vcodec libx264 -b:v 98k -r 24 -g 24 -keyint_min 4 -x264opts "keyint=4:min-keyint=48:no-scenecut" -s 342*144 -acodec libmp3lame -b:a 16k -ac 1 -ar 44100 -f flv rtmp://12.11.1.2/livepkgr/relation98p?adbe-live-event=relation

and this is my F4M file:


http://12.11.1.2/hds-live/livepkgr/_definst_/relation


Please advise me to fix this problem
any help will be appreciated


Return to posts index

Lou Logan
Re: Error in http dynamic streaming
on Oct 21, 2014 at 5:53:57 pm

If the problem is coming from ffmpeg then please show your command and the complete ffmpeg console output.


Return to posts index

moahammad yazdian
Re: Error in http dynamic streaming
on Oct 25, 2014 at 5:13:00 am
Last Edited By moahammad yazdian on Oct 25, 2014 at 5:49:25 am

Thank you Lou for replay
FFMPEG is working correctly but when my Flash Media Server stream videos for users, some users get the TypeError-Error#1009 Or TypeError-invalid bitrate.

Do you know where is the problem? In FFMPEG or Flash Media Server


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]