FORUMS: list search recent posts

ffmpeg target ntsc-dvd bitrate-setting (-b) not working

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Kurt Kocher
ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on Oct 31, 2013 at 11:03:15 pm

I use this ffmpeg-command:
ffmpeg -i sourcefile.mov -target pal-dvd -b 8000k outputfile.mpg

FFMPEG says:
Stream #0:0(eng): Video: mpeg2video, yuv420p, 720x576 [SAR 64:45 DAR 16:9], q=2-31, 8000 kb/s, 90k tbn, 25 tbc

but the output file has a bitrate much lower than 8000 kb/s (frame= 2895 fps=168 q=2.0 size= 32716kB time=00:01:56.47 bitrate=2301.0kbits/s)

Does anyone know how to set a custom bitrate when using "-target pal-dvd"?


Return to posts index


Reuben Martin
Re: ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on Nov 1, 2013 at 3:40:15 am

If you must have your bitrate exactly at 8000k, you would have to do 2 pass encoding. FFmpeg won't use that full 8000k when it doesn't need to. It would just be a waste of space without any quality benefit.

If you want high quality, setting bitrate is a poor way to achieve that. There are many other settings with far bigger influence on quality than bitrate. I would leave the bitrate setting out entirely unless you are having to meet hardware requirements of some sort.

If you are trying to get higher quality, try something like

ffmpeg -i sourcefile.mov -target pal-dvd -qscale 2 -trellis 2 outputfile.mpg


Return to posts index

Kurt Kocher
Re: ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on Nov 1, 2013 at 2:54:56 pm

Thanks alot Reuben.

I used "-qscale 1 -trellis 2" and get much better results.

Do you have a link or any tipps on where I can find rersources on how to get the quality even higher with -target dvd?


Return to posts index


Reuben Martin
Re: ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on Nov 2, 2013 at 12:03:12 am

Besides those 2 options, most other settings available to up the quality for mpeg2 have to do with motion detection. Although one other thing that can improve quality quite significantly is to flag the codec to use an interlaced DCT if your original source happens to be interlaced. (If your source is interlaced and you don't force the codec to respect that, it can smear the video)

A quick place to start would be here:
FFMPEG FAQ

You can use that as a starting place for options to look up and see what they do, and how you might what to deviate from the standard setting, in the general codec documentation.


Return to posts index


Lou Logan
Re: ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on Nov 2, 2013 at 12:25:47 am

[Reuben Martin] "ffmpeg -i sourcefile.mov -target pal-dvd -qscale 2 -trellis 2 outputfile.mpg"

Using "-qscale:v" instead of "-qscale" will remove any ambiguity issues since this option can be used for audio or video (encoder dependent).


Return to posts index

Steven Wilson
Re: ffmpeg target ntsc-dvd bitrate-setting (-b) not working
on May 1, 2014 at 12:05:34 am

I have been struggling with the -b and format options, and this is the only thing that seems to produce a noticeably higher quality result (or any change whatsoever...) Thanks!


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]