FORUMS: list search recent posts

encoder 'aac' not working

COW Forums : FFmpeg

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Peter Robertson
encoder 'aac' not working
on Feb 7, 2013 at 6:24:29 pm

What does this error message mean and how to fix it:

The encoder 'aac' is experimental but experimental codecs are not enabled, add '-strict -2' if you want to use it.

??

Peter

Pedro


Return to posts index

Michael Rampe
Re: encoder 'aac' not working
on Feb 7, 2013 at 10:00:12 pm

[Peter Robertson] "add '-strict -2' if you want to use it."

This is how you fix it. Just add this to your encode options.

Basically, this is the built-in AAC encoder that is still in development. I have found it to work very well. The other option if you want to encode AAC audio is to compile and link libfaac which is an external library.

Post your configure options for more help, you may have libfaac already.

Michael


Return to posts index

Reuben Martin
Re: encoder 'aac' not working
on Feb 8, 2013 at 1:40:36 am

It can also be built with libaacplus if you want to encode HE-AAC (a.k.a AAC+). However most publicly available builds of ffmpeg are not build with this library enabled. Same goes for libfaac. If you want to use either of those two encoders, you will probably need to compile them yourself.


Return to posts index


Peter Robertson
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:27:17 am

Thanks. I got it to work. And you're right it does work pretty good. This is a much better version of ffmpeg than the previous one I had or maybe just a better installation. How do I find my configuration options to see if I have AAC codec installed. I think i remember seeing a warning during my installation--something about the pkg perhaps...?

Pedro


Return to posts index

Peter Robertson
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:37:49 am

Fyi.. i'm using max osx. And i remember i could not enable some of the options like libfaac, libfaad and nonfree. Can i just run ./configure and make, make install to fix the problem?

Pedro


Return to posts index

Michael Rampe
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:40:56 am

[Peter Robertson] "i'm using max osx. And i remember i could not enable some of the options like libfaac, libfaad and nonfree. "

No. You have to install these libraries separately first. libfaad is now redundant. libx264, libfaac and libmp3lame are a must for a very basic set.

Michael


Return to posts index


Jim Sustacek
Re: ncoder 'aac' not working
on Feb 8, 2013 at 1:16:39 pm

If you are running Mac OS X, you can just grab a precompiled binary from here:

http://ffmpegmac.net/

They've got 32-bit (OS 10.5) and 64-bit (OS 10.6+) versions, just updated to FFMPEG 1.1.2. These are already built with AAC support (using the "-strict experimental" or "-strict -2" commands, of course).


Return to posts index

Peter Robertson
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:55:45 pm

Thanks. So the precompiled binary will have libx264, libfaac and libmp3lame?

Another question--anyone running ffmbc? I want to be able to transcode HDV to ProRes.

Pedro


Return to posts index

Jim Sustacek
Re: ncoder 'aac' not working
on Feb 8, 2013 at 4:26:00 pm

This binary does not have libfaac, sorry. But it does have libx264 and libmp3lame -- the author has posted his compile command here:

http://ffmpegmac.net/How%20To/

Personally, we've been using FFMPEG's built-in AAC encoder with "-strict experimental" and it's been working great for us. Definitely try it in your workflow and see if it works for you first -- it sure beats trying to compile your own!


Return to posts index


Lou Logan
Re: Encoder 'aac' not working
on Feb 8, 2013 at 11:59:18 pm

Also see the FFmpeg and AAC Encoding Guide at the FFmpeg Wiki for examples and details on each AAC encoder supported by ffmpeg.


Return to posts index

Lou Logan
Re: Encoder 'aac' not working
on Feb 8, 2013 at 11:55:30 pm

[Peter Robertson] " Thanks. So the precompiled binary will have libx264, libfaac and libmp3lame?"

Not with libfaac (same with libfdk_aac or libaacplus). It requires the ffmpeg configure option of "--enable-nonfree" and therefore the resulting ffmpeg binary is non-distributable.

[Peter Robertson] "Another question--anyone running ffmbc? I want to be able to transcode HDV to ProRes."

ffmpeg can encode to ProRes too:
ffmpeg -i input -c:v prores -profile:v 0 -c:a pcm_s16le output.mov
The "-profile" option will determine the specific ProRes type:
  • 0 proxy
  • 1 lt
  • 2 standard
  • 3 hq


What's the difference? See the Apple ProRes White Paper.


Return to posts index

Peter Robertson
Re: Encoder 'aac' not working
on Feb 12, 2013 at 9:28:17 pm

very nice! Works great. Thanks for the code.

Pedro

Pedro


Return to posts index


Michael Rampe
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:38:15 am

[Peter Robertson] "How do I find my configuration options to see if I have AAC codec installed."

Just type $ ffmpeg
... and look for --enable-libfaac
here is mine on the box I am on today:

$ ffmpeg
ffmpeg version N-48401-gfc86f86 Copyright (c) 2000-2013 the FFmpeg developers
built on Jan 11 2013 14:13:05 with gcc 4.2.1 (GCC) (Apple Inc. build 5664)
configuration: --enable-gpl --enable-postproc --enable-swscale --enable-avfilter --enable-libmp3lame --enable-libx264 --enable-libfaac --enable-libfreetype --disable-shared --enable-static --enable-pthreads --arch=x86_64 --enable-nonfree --enable-frei0r --extra-cflags=-I/usr/local/include --extra-ldflags=-L/usr/local/lib
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 85.100 / 54. 85.100
libavformat 54. 59.100 / 54. 59.100
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 30.102 / 3. 30.102
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100


Return to posts index

Peter Robertson
Re: ncoder 'aac' not working
on Feb 8, 2013 at 3:32:48 pm

Yeah, looks like I don't have it enabled. Here's what I have:

ffmpeg version N-49695-g4e2c636 Copyright (c) 2000-2013 the FFmpeg developers
built on Feb 7 2013 13:15:40 with gcc 4.2.1 (GCC) (Apple Inc. build 5666) (dot 3)
configuration: --enable-libx264 --enable-gpl --enable-shared
libavutil 52. 17.101 / 52. 17.101
libavcodec 54. 91.102 / 54. 91.102
libavformat 54. 61.104 / 54. 61.104
libavdevice 54. 3.103 / 54. 3.103
libavfilter 3. 35.101 / 3. 35.101
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

What is the best way to uninstall ffmpeg?

Pedro


Return to posts index

stephen dixon
Re: ncoder 'aac' not working
on Feb 9, 2013 at 12:36:58 pm

just compile with libfaac and it will overwrite the old version.

Stephen Dixon
Editor, Animator, Motionographer
Museum Victoria


Return to posts index


Jim Sustacek
Re: encoder 'aac' not working
on Feb 8, 2013 at 1:30:53 pm

"-strict experimental" also works -- that's the way it's described in the ffmpeg documentation:

http://ffmpeg.org/ffmpeg-codecs.html

-2 is just the integer value they use to represent "experimental" -- I assume 0 is "normal", 2 is "very", etc.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]