FORUMS: list search recent posts

h264 file from Canon t2i plays audio only

COW Forums : DSLR Video

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bill Antonucci
h264 file from Canon t2i plays audio only
on Nov 16, 2012 at 9:20:28 pm

I was recently transcoding a batch of h264 files shot on a Canon t2i, and noticed that one of the MOV files did not have a previewable icon. I double clicked the file and quicktime opened an audio only window. The audio will play back fine but there is no video.

When I get the info on the clip it reads ; format: Linear PCM, 16 bit little-endian signed integer, 2 channels, 48000 Hz

The cilp is still 4GB, which leads me to believe there is video information in the file. Has anyone come across this before and if so, have any solutions.


Return to posts index

Steve Crow
Re: h264 file from Canon t2i plays audio only
on Nov 16, 2012 at 11:51:26 pm

The only thing I can think of is that the clip ended prematurely somehow and it never closed out properly. I could see this happening if you get one of those strange Canon error messages while filming - I'm think of the one that says something like "I'm going to shut down on you any second!" Or perhaps if it exceeding its clip length limit and that corrupted it,

I am assuming you are talking about the raw video H264 right off the card and not after transcoding.

You might try some other video players like VLC to see if it see's anything but I have a bad feeling about this one. I had a similar issue on the audio side with my Zoom H4N when an audio clip ended badly and I couldn't access any of the audio from the file even though the file size led me to believe it was in there somewhere.

Steve Crow
Crow Digital Media
http://www.CrowDigitalMedia.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]