FORUMS: list search recent posts

266x Kingston Card giving card read errors when shooting video. Fast enough?

COW Forums : DSLR Video

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
brett rolstad
266x Kingston Card giving card read errors when shooting video. Fast enough?
on Jan 20, 2012 at 6:58:58 pm

So I just got off the phone for the second time with Canon. They suggested going with a faster card. Well anytime I shoot an extended length of time of video I'm getting a card read error, and at first thought it could be the camera but same error on a brand new 7d other than my own. So it has to be a card issue right? I'm shooting with a 16gb kingston 266x and from other forums many have said they've used this card with no issue so I'm stumped. Canon suggested it was a card issue and you need at least 300x to handle video. At wits end with this and Canon seems just as stumped as I am, is it a software issue between canon and Kingston? I only say this because it only seemed to occur after I formatted the card, but this admittedly may be pure coincidence. Any Guidance or input would be greatly appreciated before I make the very expensive jump to all new cards.
btw I have the latest firmware installed.


Return to posts index

Ed Cilley
Re: 266x Kingston Card giving card read errors when shooting video. Fast enough?
on Jan 20, 2012 at 9:13:29 pm

I've had issues with the Kingston. Even though it is rated fast, it just doesn't seem stable to me.

Try a Sandisk or even Transcend - run some tests before you loose important data.


_________________________________________________
Anything worth doing at all, is worth doing well.
- Philip Dormer Stanhope, Earl of Chesterfield


Return to posts index

brett rolstad
Re: 266x Kingston Card giving card read errors when shooting video. Fast enough?
on Jan 21, 2012 at 7:48:39 pm

Yeah, it's just strange because a lot of people were saying that they were using that exact card. Kingston offers a 600x at a reasonable price, I'm tempted to try that but I'm afraid of buying that and having the same issue. I think I'll try a Sandisk first.


Return to posts index


Henry Jackson
Re: 266x Kingston Card giving card read errors when shooting video. Fast enough?
on Mar 20, 2012 at 2:16:40 am

Had precisely the same issue on a 7D with 2 different Kingston 16GB 'Ultimate' 266X. I bought the cards at the same time and they both simultaneously started giving me the 'read error' messages. A strange coincidence that they both started to go at the same time (roughly 3 months after purchase).

I went out and bought a Sandisk 16GB Ultra (technically slower) and it has worked without a problem thus far. So i personally can't see it being a speed issue, more a card reliability issue.
Extremely irritating as i was mid documentary and lost a few key shots, you live and you learn, and you definitely get what you pay for...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]