FORUMS: list search recent posts

dead pixels on my 7D

COW Forums : DSLR Video

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bob Pierce
dead pixels on my 7D
on Nov 11, 2011 at 2:03:58 am

Just 3 months after the warranty exprired, my 7d developed a big bright white dead pixel right smack in the center of the frame. It's visible at every iso setting. I've tried manual sensor cleaning (many times) to no avail. Does anyone here have advice or experience with this?
Thanks!
Bob


Director of Photography • Editor
http://www.lightstreamassociates.com




Return to posts index

Peter Burger
Re: dead pixels on my 7D
on Nov 11, 2011 at 7:57:43 am

Had that same problem with my T2i.
You could try mapping the pixel out: Switch off the camera, remove the lens, put the body cap on and switch the camera on.
In the menu chose "sensor cleaning" --> "clean manually". After a few seconds switch the camera off. Now the dead pixel should be gone.
Should be working with any Canon DSLR.

------------------------------------------
"Tragedy is a close-up; comedy, a long shot." - Buster Keaton


Return to posts index

Bob Pierce
Re: dead pixels on my 7D
on Nov 11, 2011 at 2:17:16 pm

HI Peter,
Thanks for responding. Yes, I tried that but apparently I'm one of the unlucky ones. Hot pixel remains. I was wondering if anyone here had this experience and had their camera serviced?
Bob


Director of Photography • Editor
http://www.lightstreamassociates.com




Return to posts index


Michael Sacci
Re: dead pixels on my 7D
on Nov 12, 2011 at 6:49:59 pm

Not an answer to your question but if you have footage you need to fix, take a look at this plug-in
http://www.digital-heaven.co.uk/dh_reincarnation

they have a free trial so you have test it out.

I would call Canon and get an estimate on replacing the sensor, not much else you can do. Check to see if there are any authorized repair centers in your area.


Return to posts index

Bob Pierce
Re: dead pixels on my 7D
on Nov 16, 2011 at 2:21:27 pm

Hey Guys,
Thank you for your good ideas. I ended up sending the camera to Canon's repair facility in NJ. They told me they sometimes give customers a month or 2 grace period on the warranty, but mine was too far past the date.

If your camera is getting close to the 1 year period, I'd recommend everyone put a lens cap on it and shoot a long time exposure and look closely for any bright spots. Much better to discover this before it costs you money.
Bob


Director of Photography • Editor
http://www.lightstreamassociates.com




Return to posts index

isaac shrem
Re: dead pixels on my 7D
on Aug 14, 2013 at 11:33:40 pm

Hey Bob.

Can you let me know how much it coast you to replace the sensor? Or fix this problem?
Thanks!

Isaac


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]