FORUMS: list search recent posts

5d Mark 3 Live View Malfunction?

COW Forums : DSLR Video

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jose Santiago
5d Mark 3 Live View Malfunction?
on Apr 23, 2013 at 7:16:15 pm

I have just purchased the 5d mark 3 about 1 month ago. I shoot primarily wedding videography and I upgraded from a 7d.

I've noticed that when I turn on the camera (and it has no lens on it) If I press the start stop button it will activate the live view. Of course it will be black because there is no lens on it, but I can still hit record if I like. Well if I let the camera time out and hit the start button again I will get the warning to check if there is a lens on it. If I hit it again it will not activate live view, it will just stay on the warning screen.

This never used to happen on my 7d. I also noticed that if I have another type of lens on it besides a canon lens it does the same thing. The only time it will go into live view after timing out is if I have a canon lens on it.

Sidebar, if I push the shutter button halfway down when the camera has times out it will bring up the warning, and then if I push the start button it will activate the live view. I hope this all makes sense.

I'm not sure if this is the way the 5d mark 3 operates or if there is something wrong with my camera. Any information will be highly appreciated. Thank you.


Return to posts index

Noah Kadner
Re: 5d Mark 3 Live View Malfunction?
on Apr 25, 2013 at 8:50:18 pm

Why not just leave a lens on?

Noah

Call Box Training.
Featuring the Panasonic GH2 and Panasonic AC160/130.


Return to posts index

Warren Eig
Re: 5d Mark 3 Live View Malfunction?
on Apr 25, 2013 at 9:07:41 pm

Um, never power on the camera without a lens or body cap. unless you want to attract dust.

Warren Eig
O 310-470-0905


email: warren@babyboompictures.com
website: http://www.babyboompictures.com


REEL: http://www.babyboompictures.com/BabyBoomPictures/Reels.html




Return to posts index


Jose Santiago
Re: 5d Mark 3 Live View Malfunction?
on Apr 25, 2013 at 9:16:06 pm

My apologies. I meant a body cap.


Return to posts index

Brent Dunn
Re: 5d Mark 3 Live View Malfunction?
on May 7, 2013 at 5:25:55 pm

Try cleaning the sensors on your lens and the body where the lens and body connect. Maybe there is dust or oil from your hands on it.

I haven't heard of this problem.

Brent Dunn
Owner / Director / Editor
DunnRight Films
DunnRight Video.com
Video Marketing Toolbox.net

Sony EX-1,
Canon 5D Mark II
Canon 7D
Mac Pro
with Final Cut Studio Adobe CS6 Production






Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]