FORUMS: list search recent posts

Unable to delete user defined field and new user defined field is not showing up in work node

COW Forums : Square Box CatDV

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jay Lloyd
Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 20, 2014 at 4:14:08 pm

Hello,

I am running CatDV Pro 10.0.8(OSX 10.8) and Server 6.8.2(OSX Server 10.8). I just noticed that I can't delete any user defined field from CatDV Pro. I didn't have this problem before when I was running 10.0.6. The preference and field definition set are saved on the Server.

Also, if I add any new user defined field or modify existing ones, they are not showing up in "Trigger" and "Publish" tab in Worker Node.
So I can't set up any new action with Work Node because I simply can't filter out the files I need.

Any suggestions?

Thanks

J


Return to posts index

bryson jones
Re: Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 20, 2014 at 7:29:10 pm

Sounds like this might be permissions.

Did you do an OS X permissions repair after the upgrade? (might be useless but try it first.) Also, contact support on this.

Once you save the field set you might have to quit and reopen the worker but the fields should update.

Remember, you can always use the USER Field ID to program the worker. The fields are there, just not named.

If you don't see the user fields even, then you need to raise the "Num. user fields:" setting in the CatDVServer tab of the Worker configuration.

(Note that you must remove your field set info in order to change this.) Just put it up to 100 or something slightly beyond your field needs.

bryson

bryson "at" northshoreautomation.com

northshoreautomation.com


Return to posts index

Jay Lloyd
Re: Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 26, 2014 at 1:40:10 pm

Thanks Bryson

I solved the problem by setting the field set.

But now I have another problem.

Let's say I have an user field called "proxy"(USER 20) in the "production" field set. But I also have an user field called "proxy"(USER 15) in a different field set. Let's say the field set is called "archive".

Now, how do I set up the worker node to watch the "proxy" field in order to trigger the same action(generating proxy files)?

If I set the field set to "production" in worker node, then the files with the "proxy" field in "archive" field set won't trigger the action because the actual name of the "proxy" field is USER 15 instead of USER 20.

If I delete the field set setting in worker node, I still can't refer to the same "proxy" field because it just lists all the user fields as USER XX. If I choose USER 20, how do I know which USER 20 is it? Is it from the "production" field set or the "archive" field set?

What I did was to put all the user fields in the same field set, and all the groups were set to use the same field set.
Is this the best solution?

Thanks

J


Return to posts index


bryson jones
Re: Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 26, 2014 at 8:20:20 pm

This is a common problem in larger deployments and the answer, as in most things DAM-related, is planning.

The short answer is buy another Worker. But that may not be feasible for you.

If you log into a North Shore integrated system you'll see a set of fields left blank in every server. The first 20 are reserved for common automation related fields so that regardless of the meta schema, the Worker (which can only subscribe to one field set per node) can perform actions based on those fields.

Also, we most commonly simply make one large field set with all fields in one set, if permissions allow, so that instead of re-using USER 25, let's say, you just add the other field as a higher number. Production 1 uses 20-50 and production 2 is fields 51-75 or whatever.

Documentation and planning is key, from day one. Going back later and patching things like this up is a bummer.

So to summarize, establish a common set of fields that are either assigned or reserved for automation across all fieldsets or standardize your fieldset. There's no penalty for leaving blank fields in your db.

bryson

bryson "at" northshoreautomation.com

northshoreautomation.com


Return to posts index

Scott Goddard
Re: Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 26, 2014 at 10:55:31 pm

The man speaks the dark arts of DAM.

Ignore at your peril!

Scott Goddard

Neo Verite Limited
http://neoverite.com


Return to posts index

bryson jones
Re: Unable to delete user defined field and new user defined field is not showing up in work node
on Feb 27, 2014 at 5:40:57 pm

Amazing...

bryson

bryson "at" northshoreautomation.com

northshoreautomation.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]