FORUMS: list search recent posts

Proxies not playing in some web clients

COW Forums : Square Box CatDV

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Eric Strand
Proxies not playing in some web clients
on Mar 26, 2012 at 10:16:47 pm

I'm pretty sure this is a QT problem, but I just don't know where else to turn. Our proxies aren't playing in the web client some of the time. It seems that they play on Macs without QT X. When I try to play them on Macs with QT X or my boss' iPad, I get a QT logo with a question mark. In Safari, I will then get a QT error -1, which I have not been able to find info on when I google it. They do not play in Firefox, Chrome or Safari; and, as I aside, this occurs in Safari on my boss' iPad. I've posted info on the proxy codec and file specs. I'm hoping that maybe the developers have seen or heard about this problem with QT before. Thanks!





Return to posts index

Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 12:38:48 am

try h.264 as the codec. Looks like it's using AVC

Non-linear: all the time and nothing but.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 1:41:45 pm

I thought that was interesting too but I am using h.264. I set up the QT export dialog options inside CatDV to Apple's h.264.



Return to posts index


Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 2:44:23 pm

huh,
I'm just guessing but what happens if you pick the MPEG-4 video selection instead of the h.264? And we tend to fixate on the video. What about going to uncompressed audio instead of aac?

Non-linear: all the time and nothing but.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 4:10:30 pm

So I tried that, didn't seem to have any effect. However, all the videos, both the mpeg4 and the h264 were playing on one of the computers with QT X. That computer that they worked on has perian, but that couldn't be it, every computer comes with h.264 and my boss shouldn't have to download anything special to see them on his iPad. They still weren't playing on one of the other computers here, even though they're nearly identical setup (except for Perian). I swear it's like sometimes they work, sometimes the don't.


Return to posts index

bryson jones
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 4:14:21 pm

Browsers are maddening.

Know that we limit folks to only the latest builds of everything. (That doesn't explain the iPad.) Have you tried the videos on an iPad or iPhone without the web client?

That'll at least give you answers about the video itself and the browser and then you could turn it over to support.

I'd post a couple and see if they play differently or at all in just Safari on the mobile devices.

bryson

bryson "at" hidefcowboy.com

hidefcowboy.com


Return to posts index


Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 4:19:40 pm

Perian can give you some really odd results. Sometimes it replaces a codec for playback and it masks the fact that you don't have the "right" thing on the machine. I had to take it off the one MacPro I had it on.

I have a brand new iPad in my hand (well, on the desk, actually) and we're doing some testing with our streaming services, mostly relating to security. We've been using h.264 MP4s for a couple of years and they're fine on the iPads and iPhones. As a matter of fact it's all I use now for web stuff. We use the JW player and it deals with all the calls to the different media for us.

Non-linear: all the time and nothing but.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 4:53:40 pm

I just tried a h264 mp4 and that didn't have an effect; still didn't play on that one machine. My boss is out with is iPad right now, but I'll have him try just a video not in the browser when he gets a chance. Thanks for the continued help.


Return to posts index

Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 4:55:50 pm

you want to put a sample up on a public folder (Dropbox?) and I'll take a look at it? Got an iPhone there?

Non-linear: all the time and nothing but.


Return to posts index


Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 5:33:11 pm

Hey Robb,

Since they're really small files I just uploaded a video here. This is one of the h264 QT .mov's that plays on some computers but not others. I personally don't have an iPhone, I'll see if I can borrow someone's here.

3909_aa012601.mov.zip


Return to posts index

Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 5:44:47 pm

on the iPad it wouldn't open in VLC, but it opened, unzipped and and played in GoodReader. There wasn't any option to open it in the native player. You might want to make sure it comes out a .MP4 instead of .MOV. And if you have a place to put it out on the web I could try it in the browser. The browser won't deal with it when it's zipped.

Non-linear: all the time and nothing but.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 5:47:10 pm

I have a dropbox I can throw it up on. What address would you want me to invite? I'm not sure if you can do private messages on the COW, or how you want to let me know.


Return to posts index


Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 6:12:07 pm

you might be able to put it in public
but for me use nledit @ mac.com

I was just about to throw it on mine

Non-linear: all the time and nothing but.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 6:15:03 pm

Oh nice, didn't know about the Public folder.

http://dl.dropbox.com/u/13539599/AA0126_01.mov


Return to posts index

Robb Harriss
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 6:19:50 pm

well, it works fine on the new iPad (3rd generation), the iPhone (3Gs) and MacBook Pro Safari, latest version. Looks good to go.
Be aware that on the new iPad it doesn't look good because of the screen resolution. Looks fine everywhere else.

Non-linear: all the time and nothing but.


Return to posts index


Eric Strand
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 6:44:47 pm

Hmmmmmmmm thanks Robb, I really appreciate the effort.

Bryson - at this point Robb and I have both tested it in a variety of environments. I've tried mpeg4, h264 mp4, uncompressed audio. We know that the files play without the web client and they play in the web client sometimes. Seems to be that middle point of QuickTime delivering the file. Like I said, I don't believe this is a CatDV issue, I just don't know where else to turn. I'm not aware of any type of error log in the Web Client that I could shoot to support. Do you have any recommendations on how I could maybe delve deeper into what is happening behind the scenes?

Thanks again.


Return to posts index

bryson jones
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 9:05:17 pm

This one now needs to go the official guys. I'll alert support to pick up from here. Thanks for the testing so far.

bryson

bryson "at" hidefcowboy.com

hidefcowboy.com


Return to posts index

Matthew Stamos
Re: Proxies not playing in some web clients
on Mar 27, 2012 at 10:34:40 pm

Really great to see people helping out and pitching in... we have all been there at some point!
Eric go to this link and start a ticket and we will see what we can do to help!
http://www.squareboxmedia.co.uk/helpdesk/


Return to posts index

Brad Starkey
Re: Proxies not playing in some web clients
on Mar 28, 2012 at 2:45:57 am

Will it play if you use HTML5 instead of QuickTime video on the web client?


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 28, 2012 at 4:43:44 pm

Hey Brad,

On the iPad in Safari HTML5 nor Quicktime worked.

On this one computer here Safari: QT doesn't work, HTML5 does work, Firefox QT asks for plugin, but then can't find one to install and HTML5 doesn't work, Chrome HTML5 works but it is stuttery.

On another computer Safari: QT does work, HTML5 does work, Firefox QT works but HTML5 doesn't, Chrome HTML5 works, QT works after it asks to allow plugin to run.


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 28, 2012 at 9:23:41 pm

Hey Matt,

Just submitted a ticket to the Squarebox guys.


Return to posts index

Stuart Peck
Re: Proxies not playing in some web clients
on Mar 30, 2012 at 10:32:36 am

Hey Eric,

Thanks for the email to our, I shall take this over and reply to you via the support email. As Bryson say, browsers can be and are a pain. I generally do testing for browser every month at least as there is always a firefox update or another update that potentially bring it to it's knees. Since version 7 of firefox, CatDV hasn't worked as well as previous versions of Firefox, i tend to use either Chrome with HTML 5 or Safari on HTML 5 or Quicktime depending what i'm testing. As for limited codec support for Chrome...However, H.264 and MP$ are fine, What else are we gonna use for a proxy :)

I then tend to veer people away from firefox when supporting browsers for CatDV, i've never had consistant results with firefox so I won't recommend that for a solution.

Safari 5.2.1 and Chrome versions 17.0 and 18.0 are working great for me with proxy currently.

As far as your specific issue lets chat over email and we can get to the bottom of the issue. I'm sure you have been trying to diagnose this but I will ask you to go back to point 0, as far as making sure we have all the right components we need and that media is playing independently of CatDV (ie QT) We can then diagnose it correctly. Most of the time, proxy not playing is down to path and or you have changed it and CatDV server needs a restart. EIther that or there is a codec issue somewhere along the line.

Chat soon over email

Regards

Stuart

Sqareboxmedia
CatDV / MME / Focalpoint /


Return to posts index

Eric Strand
Re: Proxies not playing in some web clients
on Mar 30, 2012 at 4:16:46 pm

Sounds great Stuart. I look forward to your email.

Eric


Return to posts index

John Vaudin
Re: Proxies not playing in some web clients
on Apr 5, 2012 at 2:41:06 pm

I downloaded the sample file that you posted and tried playing it both in CatDV Client and also the Web Client with Chrome, Firefox, IE and Safari - using QuickTime rather than HTML5 - and it plays reliably in all of those environments.

I'm afraid I can only conclude that it must be due to some codec or other software that you have installed on the machine(s) giving problems.

Sorry I can't help.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]