FORUMS: list search recent posts

DaVinci Resolve 15 problem :(

COW Forums : DaVinci Resolve

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Murat Egretli
DaVinci Resolve 15 problem :(
on Apr 20, 2018 at 6:09:45 pm

Hi there,

I asked this question before on Blackmagic forum but I couldn't find a solution. Maybe there is someone experienced enough to help me here.

I downloaded free version of DaVinci Resolve 15. It is too slow. It's way slower than free version of 14. I know it is still public beta but I wanted to share this problem anyway. When I add a footage from media pool to edit page it's ok. But when I click Fusion panel it freezes about 2-3 seconds. It generally freezes like this. There are some Yotube tutorials out there but they don't seem to have this problem. What do you think? You have this problem? Maybe my machine is slow, not sure.

Here is my computer specs:

Intel(R) Core(TM) i3-7100 CPU @ 3.90GHz

NVIDIA GeForce GTX 1060 3GB

16 GB DDR4-2132 (1066 MHz) RAM

What should I do? I need help.


Return to posts index

Tero Ahlfors
Re: DaVinci Resolve 15 problem :(
on Apr 20, 2018 at 8:17:37 pm

Well the program is in beta so there will be problems with that. That said your CPU is kinda slow and your GPU is pretty low on the VRAM side. I personally wouldn't go any lower than a four core i5. You can also try setting the Fusion to work CPU only in the preferences.


Return to posts index

Duke Sweden
Re: DaVinci Resolve 15 problem :(
on Apr 20, 2018 at 10:31:34 pm

Right although if he's new at this he'll have no idea where preferences is. It's in the top left where it says Davinci Resolve. Click that and you'll see Preferences in the dropdown. Also, if you are using a 2 monitor setup, click dual monitor under workspace and turn it "on". That will help with Fusion as well.

Dell XPS 8920
Intel i7 core 7700 build
GeForce GTX 1050ti
32 Gigs of RAM
3 7200 RPM SATA Drives
Windows 10 64-bit
DaVinci Resolve 14.3


Return to posts index


Murat Egretli
Re: DaVinci Resolve 15 problem :(
on Apr 21, 2018 at 9:51:15 am

Thank you for the answers. I think I need to uprgrade my CPU then :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]