FORUMS: list search recent posts

Release of DaVinci Resolve 14

COW Forums : DaVinci Resolve

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Peter Chamberlain
Release of DaVinci Resolve 14
on Sep 7, 2017 at 7:02:19 am

We are pleased to announce the release of DaVinci Resolve 14.

This is a no charge update for all existing DaVinci Resolve Studio customers. The free version is also available on our support web site.
https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion

For details of what's new in DaVinci Resolve 14 please review the read me below.

Whats new in DaVinci Resolve 14

Collaboration

• All new collaboration workflow which allows multiple users to work on the same project at the same time
• Added ability for collaborating video/audio editors and colorists to work on the same timeline at the same time
• Resolve Collaboration supports any shared storage technology and works with a PostgreSQL shared database server
• Support for live saving all collaborator actions in a collaborative project
• Support for Project Manager indicators to show collaborative projects
• Ability for collaborators to pick a profile on their shared projects
• Ability to open a bin in read-only mode by Alt/Option + click
• First come first serve write access for Media Pool Bins with read access for everyone else
• Live Media Pool side bar bin updates including user locks and refresh available indicators
• Timeline indicators to show user locks and refresh available
• Live update of Color Page thumbnail icons to indicate user locks and refresh available
• Live sharing of Color Page still galleries
• New compare timeline tool to simplify merging timelines from multiple collaborative users
• Live group chat feature on collaborative projects

Improved Performance, Fluidity And Usability

All new image processing engine with numerous performance improvements and optimizations

• New image processing engine which maximizes single and multi-GPU utilization
• Support for GPU processing using Metal on Mac
• New optimized Performance Mode for improved playback
• New dynamic memory manager for optimized CPU memory usage
• Improved performance on single GPU laptops and workstations
• Improved editing and playhead fluidity on the Edit page timeline
• Dramatically improved latency of JKL playback
• Improved Color Page playback start/stop latency
• Improved Multicam playback performance
• Improved organization of Project Settings, User Preferences and System Preferences
• Improved organization of the Workspace menu
• Improved pan and zoom on viewers when using the trackpad with support for an Alt/Option modifier
• Improved scrubbing and playback performance for compressed CinemaDNG clips
• Improved performance when scrubbing H.264 and similar codecs
• Support for hardware accelerated H.264 decoding when using NVIDIA GPUs on Linux and Windows
• Support for improved CPU usage

All new database engine for improved management and performance on PostgreSQL and DiskDB

• All new live save option where changes are saved as you work
• Support for incremental fast saves in the new and improved DiskDB
• Ability to save, load, update and delete user UI layout presets

Improved media access and performance

• Improved H.264 encode and decode performance
• Improved decode performance of 10-bit 4K H.264 media on DaVinci Resolve Studio
• Improved playback performance for 4K AVC Intra clips
• Improved performance for file listing in Media Storage
• Improved scrolling performance in Media Storage folders and Media Pool bins with many clips
• Improved speed of importing AAF timelines
• Improve speed of Optimized media generation, transcoding and fusion rendering
• Support for Optimized Media in 3D stereoscopic clips
• Support of high frame rate timelines up to 120 frames per second - DaVinci Resolve Studio only
• Support for up to 16Kx16K source images and timeline resolution
• Ability to drag a file or folder from Finder/Explorer to Media Storage in order to navigate there
• Improved performance when loading Gallery stills
• Improved audio quality when scrubbing a clip in the source viewer


Audio

• New Fairlight audio processing engine for all audio in Resolve
• A dedicated Fairlight page with audio editing, mixing, finishing and mastering controls
• Support for unlimited audio tracks and 8 main, sub and aux outputs
• Support for Fairlight Audio Accelerator with MADI and Fairlight Audio Interface
• Support for Fairlight free standing and desktop consoles
• Single and dual monitor UI configurations on the Fairlight page
• Fairlight page includes Media Pool, timeline, metering, mixer, effects, video preview, timeline index and inspector
• Support for Media Pool option to only Show Clips with Audio or Show All Clips in the Fairlight page

Key features

• Six band EQ for every track
• Expander/Gate, Compressor and Limiter Dynamics for every track
• 2D Pan control for sound placement
• Timeline toolbar includes a pointer and a marquee tool, automation state, snapping, flags, markers and timeline options
• Automation includes trim state, touch, latch or off mode, event selection
• Ability to individually enable fader, mute, pan, EQ, compressor, Gate, Aux, Limiter and Plugins
• Ability to render multiple audio buses and tracks
• Added support for up to 8 faders on 3rd Party Audio Control Surfaces using HUI protocol on Mac and Windows

Monitoring and metering features

• Level meters for all channels, Masters, Subs, Aux and groups
• Monitoring of main outputs available in mono, stereo, 5.1, Atmos, Auro, DTS, IMAX and multichannel up to 22.2
• Compound metering, including speaker group selection, phase and loudness with integration control
• Video preview available as docked or popup viewer with SDI video output
• Ability to setup speaker configurations using
⁃ Blackmagic Design video I/O hardware devices
⁃ Blackmagic Design Fairlight Audio Interface
⁃ System Audio or connected USB audio devices


Timeline features

• Track sidebar includes controls for gain, automation, lock, solo, mute and record
• Track sidebar includes indicators for track number, name, color, linked track and meters
• Timeline clips include user selectable indicators for clip name, gain, FX, group, EQ, source, speed, linked status, stem/channel bit depth, sample rate and source channel
• Timeline clips include waveforms with borders, gain level, fade handles and automation keyframe control
• User selection of timecode display with subframes and samples, feet and frames or only samples
• Five preset and custom user selectable track height with locks
• New timeline index shows tracks and markers
• Added support for stepping single frames on the Fairlight page using K+J and K+L keys
• Added support for half-speed playback on the Fairlight page using JKL keys
• Added support in the Fairlight page timeline for moving tracks up/down
• Added support for locking tracks in the Fairlight page
• Added support for the Razor command in the Fairlight page
• Support for layered audio editing allowing stacked clips on a single audio track
• Added option to switch between overwrite mode and layering mode when editing audio clips

UI dialogs for setup and assignment

• Each mixer track includes input selection, effects, insert, EQ and dynamics graphs, output selection, aux, pan, main and submix selections
• Mixer also includes track name and color, grouping, record, mute and solo selection and gain fader with meters


General audio improvements

• Support for pitch correction when performing speed changes on all platforms
• Support for pitch correction during FFW and FRW playback on the Edit page timeline

Edit

Key new features

• Support for track colors on the timeline
• Support for dragging just video or audio from the source viewer
• Support for a toggle to switch between single viewer and dual viewer mode
• Support of OFX plugins as filters in Timeline
• Ability to drag and drop a transition from one clip to another
• Redesigned Effects Library for easier navigation and search
• Playback now continues when performing a trim during looped playback
• Support for improved "Play Around" functionality with contextual behavior depending on selection
• Support for Blur Dissolve transition
• Support for audio waveforms on Multicam Clips, Compound Clips and Timeline Clips
• Support for alpha rendering from source when using Fusion Connect
• Added support for Live Preview of clip thumbnails in the Media and Edit page source viewers
• Added menu options and shortcuts for marking and clearing split Video and Audio In and Out marks
• Added menu option and shortcut for creating a SubClip
• Improved scrolling on timeline when using Alt/Option + mouse wheel to scroll

Clip adjustment improvements

• Ability to "Remove Attributes" from one or multiple clips
• Added support for Crop Softness in Paste Attributes
• New menu option to freeze frame the current frame under the playhead
• Ability to select all keyframes in Keyframe and Curve editor using Ctrl/Command+A
• Ability to linearize/smoothen curves for multiple selected keyframes in the Keyframe and Curve editor

Clip trim improvements

• Ability to Alt/Option+Shift drag to resize a clip’s In or Out point over an adjacent clip to automatically create a transition
• Ability to Alt/Option+Shift drag a clip from the Media Pool to overlap a clip in the timeline to add a transition
• Support for two new trim commands in the Trim menu
⁃ Slip Playhead to In
⁃ Slip Playhead to Out
• Support for slip functionality when performing an Extend Edit
• Ability to duplicate and superimpose dragging selected clips from a track while holding down Alt/Option + Shift
• Support for snapping when dragging and placing text elements in a Title in the Timeline viewer
• Support for improved snapping when performing ripple edits
• Ability to perform playback using JKL in Dynamic Trim Mode when no clip or edit point is selected
• Added support for displaying the composited preview in 2-Up and 4-Up modes when trimming

Conform improvements

• Support for user selectable conform criteria when performing "Reconform from Bins"
• Ability to "Reconform from Media Storage folders" for a Timeline
• Reconform from Bins now has support for selected clips or all clips
• Force Conform has been renamed to Conform Lock
• Support for missing on disk indicators and missing in Media Pool indicators in the Timeline
• Support for importing 3D Warp Pitch and Yaw parameters in AAF from Avid Media Composer
• Support for the following Index filtering options
⁃ Show Clip Color
⁃ Show Clips with Composite Effects
⁃ Show Clips with Transform Effects
⁃ Show Clips with Filters
⁃ Show Clips with Speed Effects
⁃ Show Fusion Connect Clips
⁃ Show Compound Clips and Nested Timelines
⁃ Show Clip conflicts
⁃ Show Flags of a particular color
⁃ Show Markers of a particular color
⁃ Show Stills and Freeze Frames
• Ability to see conflicts in the Index Match column
• New Position Lock on toolbar to lock ripple on tracks and timelines for Online Editing
• Project setting to enable/disable automatically Conform when adding clips to Media Pool
• Ability to set default number tracks and types in Project Settings > Editing > New Timeline Settings

Marker improvements

• Ability to display marker information as viewer overlays
• Ability to list clip markers in the Media Pool list view
• Ability to convert an In and Out point selection into a duration marker
• Ability to navigate between markers from the option menu in the viewers
• Ability to search and filter in the Index using Marker Name and Marker Notes fields
• Ability to multi select timeline markers using a marquee

Media Pool improvements

• Support for multiple Media Pool windows either as a 2-up/4-up docked view or as new pop-up windows
• Ability to hover over Media Pool thumbnails to mark in and out
• Ability to "Rediscover Optimized Media" in the Media Pool
• Ability to "Unlink Selected Clips" in the Media Pool
• Support for missing on disk indicators in the Media Pool for both the thumbnail and list view
• Support for Smart Bin and Smart Filtering based on Display Name
• Ability to Create Bin With Selected Clips
• Ability to create Smart Bin filters using Marker Name and Marker Notes
• Ability to search in the Media Pool using Marker Name and Marker Notes fields
• Ability to perform comma separated text matches in Media Pool search, Smart Bins and Smart Filters
• Ability to add/remove items from current selection with keyboard modifiers (Ctrl/Command, Shift and Alt/Option)
• Ability to Alt/Option drag clips in the Media Pool to duplicate them and put them in another bin
• Added ability to edit and update existing Media Pool custom column layouts
• Added a new column for audio codec in the Media Pool

General improvements

• Previous/Next clip now ignores selection when the selected clip is not visible
• Support for a "Playback post-roll" option in the Timeline menu
• Ability to drag video only or audio only from the timeline to the Media Pool
• Support for retaining playhead position and in and out positions when swapping timelines
• Ability to drag a OpenFX/ResolveFX filter onto one or multiple selected clips
• Support for selecting resize algorithm per clip in the Inspector
• Support for a progress bar when applying Lens Correction
• Support for 100% levels in EBU Color Bar generator
• Ability to search “All Fields" when applying a search filter in the Index
• Support for toggling "Show Reference Wipe" is now available on the Edit page
• Ability to Alt/Option click only the audio or video to override a linked clip selection
• Added support for new Four Color Gradient generator
• Added menu options and shortcuts for marking and clearing split Video and Audio In and Out marks
• Added menu option and shortcut for creating a SubClip
• Added support for viewing track layers in the Edit Index

Color

ResolveFX improvements

• ResolveFX plugins are now sorted into logical groups of effects
• Support for starred favorites for OpenFX is now available on the Color page
• Ability to paste tracking data between the FX tracker and the Power Window tracker
• Improved ResolveFX Lens Flare
• Support for Gamut Mapping in the ResolveFX Color Space Transform plugin
• Support for Tone Mapping in the ResolveFX Color Space Transform plugin

New ResolveFX Plugins

• ResolveFX Face Refinement - GPU Accelerated - DaVinci Resolve Studio only
• ResolveFX Warper - DaVinci Resolve Studio only
• ResolveFX Match Move - DaVinci Resolve Studio only
• ResolveFX Color Stabilizer - GPU Accelerated - DaVinci Resolve Studio only
• ResolveFX Timelapse Deflicker - GPU Accelerated - DaVinci Resolve Studio only
• ResolveFX Contrast Pop - GPU Accelerated - DaVinci Resolve Studio only
• ResolveFX Color Compressor - GPU Accelerated
• ResolveFX Abstraction - GPU Accelerated
• ResolveFX Watercolor - GPU Accelerated
• ResolveFX Lens Distortion - GPU Accelerated
• ResolveFX Gamut Mapping - GPU Accelerated
• ResolveFX Dead Pixel Fixer - GPU Accelerated
• ResolveFX Alpha Matte Shrink and Grow - GPU Accelerated
• ResolveFX Color Palette - GPU Accelerated
• ResolveFX Dehaze - GPU Accelerated
• ResolveFX Sharpen - GPU Accelerated
• ResolveFX Sharpen Edges - GPU Accelerated
• ResolveFX Soft Sharpen Skin - GPU Accelerated
• ResolveFX Camera Shake - GPU Accelerated
• ResolveFX Deband - GPU Accelerated
• ResolveFX Grid - GPU Accelerated

General improvements

• Support for a new advanced Stabilizer in the Tracker palette
• Improved ResolveFX tracker when using multiple tracking points
• Ability to add and control ResolveFX and OpenFX plugins under Modes from the DaVinci Resolve Advanced Panel
• Support for improved jog and shuttle control on DaVinci Resolve Advanced Panel
• Ability to toggle LightBox SDI output from the DaVinci Resolve Advanced Panel using Shift Down + CONFORM
• Ability to toggle full screen LightBox from the DaVinci Resolve Advanced Panel using Shift Up + CONFORM
• Ability to press and hold Reset on the DaVinci Resolve Micro and Mini panels to reset the node graph
• Ability to press and hold Previous/Next Frame on the DaVinci Resolve Micro and Mini panels to jump to the beginning/end of the clip
• Ability to press play/reverse repeatedly on the DaVinci Resolve Micro and Mini panels to increase playback speed
• Ability to set the LCD brightness of the DaVinci Resolve Mini panel using LCD brightness in Control Panel settings
• Ability to set the key backlighting of the DaVinci Resolve Micro and Mini panels in Control Panel settings
• Ability to remember Bars vs. Wheels when switching to Primary from a Control Panel
• Improved various knob and parameter sensitivities on the DaVinci Resolve Micro and Mini panels
• Added support for manual IP configuration for DaVinci Mini panels
• Support for white balance picker to automatically set temperature and tint
• Support for white and black point picker for automatic color balance
• Improved quality when using Hue vs. Lum curves
• Support for Gamut Mapping from Timeline to Output Color Space in Resolve Color Management
• Support for Tone Mapping from Timeline to Output Color Space in Resolve Color Management
• Support for the Common LUT Format (CLF) with examples - DaVinci Resolve Studio only
• Support for scopes as an overlay on the Cinema viewer
• Support for new commands and shortcuts to move selected keyframes
• Selection of multiple keyframes no longer needs a modifier key
• Support for track color on Color page timeline
• Added support for a locked node indicator in the node graph
• Support for plugin name on FX nodes
• Support for full height OpenFX inspector in full screen mode
• Ability to set default number of neighboring clips for Split Screen in Project Settings > Color
• Support for Clip Color indicators in the Color page Timeline
• Support for adding any Media Pool clip as a matte to the current clip on the Color page
• Added support to ARRI look (CDL + LUT) for Alexa SXT Quicktime clips
• Added Canon Log 2 support in Resolve Color Management
• Added RED Wide Gamut colorspace and Log3G10 gamma support in Resolve Color Management
• Ability to generate LUTs in Resolve Color Management, ACES and ACEScc projects
• Improved support for ACES v1.0.3
• Support for ACEScc, ACEScct and ACEScg color spaces in Resolve Color Management
• Support for ACEScc, ACEScct and ACEScg color spaces in the ResolveFX Color Space Transform plugin
• Support for ACEScc, ACEScct and ACEScg IDTs and ODTs when using ACES
• Added a new LMT Neon Suppression CLF
• Support for clip output render caching from pre and post group node graph
• Support for showing picker RGB values in 8 bit or 10 bit available in the View menu
• Ability to to toggle the viewer overlay mode on/off using Shift + `
• Support for Ctrl/Command and Ctrl/Command+Shift for half and quarter increments in Printer Lights Hotkeys
• Added support for selecting all clips in the Color page using Command/Ctrl+A
• Added Color page thumbnail indicator for Edit page OpenFX applied on clips
• Improved viewer image quality when zooming in and out of the Color page viewer
• Added support for latest X-rite ColorChecker chart
• Improved color match behavior for X-Rite Color Checker Classic color chart

Media

• Support for source viewer video I/O playback of clips not at the project frame rate
• Support for user selectable checksum methods in Clone Tool option menu
• Ability to unmount drives from Media Storage on Mac and Windows
• Ability to set custom whole number frame rates from 1 to 120 fps in Clip Attributes
• Support for option to import ARRIRAW clips at the Open Gate resolution in Project Settings > CameraRAW > ARRI
• Support for automatically cropping ARRI Quicktime clips to show only the active area of the sensor
• Added support for additional clip metadata in CinemaDNG files, including shutter, ISO, focal length and lens information
• Added support for viewing location metadata for QuickTime clips with geotagging
• Added support for viewing location metadata on Blackmagic Design CinemaDNG clips
• Support for decoding clips from the Canon C200 camera
• Support for decoding AC-3 audio in MTS and Quicktime files on Windows and Mac
• Support for latest EasyDCP library
• Support for decoding Nikon RAW files
• Support for encoding and decoding Cineform files on all platforms
• Support for decoding MultiPart OpenEXR
• Support for decoding and encoding 32-bit float OpenEXR clips
• Support for Constant and Variable bitrate in Quicktime ProRes and DNxHR codecs
• Support for H.264 multi-pass encoding on Mac
• Support for decoding H.264 Intra 422 10bit - DaVinci Resolve Studio only
• Support for encoding to the MP4 format
• Support for decoding High 10 Profile H.264 files on DaVinci Resolve Studio
• Support for encoding VP9 profiles with higher bit-depth
• Support for Network Optimization option in Quicktime renders
• Support for 10b and 12b encoding options for DNxHR HQX and DNxHR 444
• Support for Rec.2100 metadata in QuickTime renders
• Support for decoding and encoding 32-bit float WAV files
• Support for QuickTime reference movies on Linux and Windows
• Added support for automatically searching the current folder when a QuickTime reference clip is not found
• Support for drop frame timecode when performing a 3:2 pull down during encode

General

• DaVinci Resolve Studio now also supports license key based activation
• Support for an improved Project Manager with an integrated Database manager
• Added ability to resize the Project Manager window
• Added support for manually updating thumbnails in the Project Manager
• Ability to copy and paste one or multiple projects between databases
• Ability to sort list of databases in Database manager
• Support for a new Bicubic resizing filter option
• User settings such as layout preferences are now saved locally on the machine
• Ability to drag a bin into another bin in the Media Pool right hand side view
• Support for a smaller page switcher on smaller screens
• Ability to type in Project Manager and browse dialogs to automatically navigate to and highlight matches
• Support for searching for shortcuts by command name or shortcut in Project Settings > Keyboard Mapping
• Support for displaying conflicts when assigning shortcuts in Project Settings > Keyboard Mapping
• Modifying default keyboard mapping presets are now automatically stored as Custom
• Tags now support non-text parameters such as Timecode, Dates, Numbers and Resolutions
• Data Burn-In is now a floating window available on the Edit, Color, Fairlight and Deliver page through the Workspace menu
• Support for undo/redo history available in the Edit menu
• Support for an option to stop playback when frames are dropped on the SDI output
• Support for remembering the last open page across multiple sessions
• Added JKL playback support when in Cinema mode
• Added a shortcut for Blackmagic Design’s Training resources in the Help menu


Return to posts index

Luke Sheldon
Re: Release of DaVinci Resolve 14
on Sep 7, 2017 at 3:18:46 pm

So I have 14 already (14.0.0b.037)

Do I need to update or reinstall?


Return to posts index

Jeff Sargeant
Re: Release of DaVinci Resolve 14
on Sep 7, 2017 at 6:30:53 pm
Last Edited By Jeff Sargeant on Sep 7, 2017 at 9:45:30 pm

I will be upgrading from DaVinci Resolve 12.5.4 (non Studio) version, what do I need to do to insure all of my hundreds of previous projects and media files are recognized and will open in the new version (14)?
Do I need to update to 12.5.6 first?

Jeff Sargeant
Videographer @
Flowmaster/Hurst/B&M
Hayden, ID


Return to posts index


Michael Gissing
Re: Release of DaVinci Resolve 14
on Sep 7, 2017 at 11:04:44 pm

It is recommended that you backup your database and individual projects. In the early 14betas there were issues of databases corrupting or not converting so it was reported on many forums that it was better to start with a new database and then import the various projects back in.

I waited until Beta 8 and going from 12.5.5 it converted the database without an issue. However you really should backup both database and project files before this as the new database, once converted cannot be used by earlier versions of Resolve. I can't tell you if there is a problem with the release version and your current 12.5 version but the forum at Blackmagic has a lot more specific details on such issues than this forum.

So if you are feeling game once you have everything backed up, if you strike problems you can always reinstall 12.5 and reimport your old database.


Return to posts index

Jeff Sargeant
Re: Release of DaVinci Resolve 14
on Sep 8, 2017 at 12:05:45 pm

Thanks, I did what you said and installed DR 14, so far all is working although I did notice that an audio plugIn I use a lot did not cary over in the projects once opened in the new 14 version. The plugIn was there and available, just no longer assigned to the audio tracks from the 12.5 version. I had to re-place the plugin back onto the audio tracks and then re-set the parameters of the plugIn for every project (103). No fun. Is this a bug?

Jeff Sargeant
Videographer @
Flowmaster/Hurst/B&M
Hayden, ID


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]