FORUMS: list search recent posts

Only 16fps playback using Decklink 4K extreme in Resolve

COW Forums : DaVinci Resolve

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeff Brown
Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 4:44:14 pm

Hi There

Does anyone know of a bottleneck that would cause 4K Decklink output (either HDSDI or HDMI UHD) to only get to 15/16fps?

Getting realtime in the GUI all the time but as soon as I turn the card on it maxes out at 16fps regardless of slot configuration.

This is playing a 4K DPX (3840 x 2160) sequence - no nodes / grades just straight playing from the RAID.

Configuration:
Mac 8 Core 2.26 w/ 24GB Ramm
10.8.4 / Latest full Resolve 9.1.4 / Latest desktop video 9.7.3
Blustor PCIE Extender with 20TB RAID giving 1.5gbps read/write.


Slot1 - GTX 680 for MAC (GUI only)
Slot 2 - Expander to RAID / Rocket / Nvidia Quadro 4000 (GPU)
Slot 3 - Decklink 4K Extreme
Slot 4 - HDMI breakout plate

I should add that I have tried this in pretty much every configuration (including more GPUs in the extender). Tried single GTX 680 as GUI/GPU and no GPU in extender as well as Quadro 4000 / Quadro 4800 as single GUI/GPU in slot 1 / Also tried 4K extreme in slot 1 for 16x bandwidth. Attempting to put the 4K extreme in an 8x slot in the expander results in kernel panic at boot.

I'm getting realtime 4K DPX playback in Scratch and in Resolve with no decklink but only ever get 16fps when trying to monitor 3840 x 2160p. I get realtime via the card when monitoring 1080p and then it chokes when going to 2160p.

Looking for a solution so any ideas welcomed!

Thanks

Jeff Brown
http://www.brownianmotion.co.uk


Return to posts index

Eric Hansen
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 5:42:23 pm

You mention a Rocket in your setup. if you're trying to playback 5k footage, you won't get realtime playback. Check optimized playback when using a single card. Although, I'm not sure if this has the same affect with 4k output as 1080.

Maybe there's not enough VRAM available for 4k. You definitely should have more GPU power than a Q4000 or 4800.

BMD 4k Decklink is only 4x. So leave it in slots 3 or 4 in the Mac Pro.

e

Eric Hansen
Production Workflow Designer / Consultant / Colorist / DIT
http://www.erichansen.tv


Return to posts index

Jeff Brown
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 5:58:34 pm

No not playing R3D although interstingly it's the same - realtime in the GUI with no decklink card and 16fps with the decklink. In fact pretty much all formats - tried a 4K Prores and got the same results.

My main content is 3840 x 2160 10 BIT DPX that have been finished and exported from multiple format sources. I would imagine the lack of compression would help the playback (And I know the storage can handle the bandwidth).


Return to posts index


Juan Salvo
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 5:53:16 pm

Q4000 is a very old and weak card. Particularly for 4K. You should check the config guide for advice on better options. I personally recommend the Titan.

Also be sure to enable "optimized for SDI" mode.

Colorist | Online Editor | Post Super | VFX Artist | BD Author

http://JuanSalvo.com


Return to posts index

Jeff Brown
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 6:01:57 pm

The Q4000 was just one I tried -along with the Q4800. I was initially using the new GTX680.

All of those cards as a single GUI/GPU give me realtime in the GUI regardless of cores(there is no difference using multiple GPUs).

All of them only give 16fps when the Decklink is turned on which is why I'm thinking it's a restriction not linked to the GPU performance.


Return to posts index

Juan Salvo
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 6:14:02 pm

[Jeff Brown] "The Q4000 was just one I tried -along with the Q4800. I was initially using the new GTX680.

All of those cards as a single GUI/GPU give me realtime in the GUI regardless of cores(there is no difference using multiple GPUs).

All of them only give 16fps when the Decklink is turned on which is why I'm thinking it's a restriction not linked to the GPU performance."


All of those quadros are either slow or painfully slow. The optimized for SDI setting will help, as the issue is two way nature of bandwidth use.

Also which MacPro are you running?

Colorist | Online Editor | Post Super | VFX Artist | BD Author

http://JuanSalvo.com


Return to posts index


Jeff Brown
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 6:34:02 pm

The odd thing is if I add up to three GPU cards nothing changes - it gets much snappier with no decklink as expected but still always the same 16fps with the card on.

If is was all just GPU based then I'd expect to see variation in the results as I add more cores.

I'll check what tower revision (not in the office now and I have 6 so not sure which one it is) and I'll look at the SDI optimised setting - thanks.


Return to posts index

Juan Salvo
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 12, 2013 at 6:44:18 pm

[Jeff Brown] "If is was all just GPU based then I'd expect to see variation in the results as I add more cores.

I'll check what tower revision (not in the office now and I have 6 so not sure which one it is) and I'll look at the SDI optimised setting - thanks."


The quadros are probably hurting more than helping as processing cards.

Enabling the Optimized for SDI option will improve most of your concerns. If you'd just try that out first.

Colorist | Online Editor | Post Super | VFX Artist | BD Author

http://JuanSalvo.com


Return to posts index

Ben Scott
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 13, 2013 at 12:46:45 pm

we had something similar last week on windows 7

fix was to right click desktop>personalise>change to windows 7 basic mode

basically it turns off all the fancy windows 7 transparency

as suggested for avid setup

it worked and the frame rate came back to normal in Resolve

I was convinced it wasnt the graphics cards as it was something conflicting with the blackmagic card being on as an output (i turned off the external out and it went full frame rate)

try that


Return to posts index


Jeff Brown
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 13, 2013 at 1:57:30 pm

Thanks guys. Spec is:


Model Name: Mac Pro
Model Identifier: MacPro4,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.26 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Core): 256 KB
L3 Cache (per Processor): 8 MB
Memory: 24 GB
Processor Interconnect Speed: 5.86 GT/s
Boot ROM Version: MP41.0081.B07
SMC Version (system): 1.39f5
SMC Version (processor tray): 1.39f5
Serial Number (system): CK94305A20H
Serial Number (processor tray): J593600721LUE
Hardware UUID: B0136638-2D6C-5888-A4AE-5F6B9312A7F0

I've now added another expander - one for the RAID and one for the GTX (GPU only) so as not to be hoggin that bandwidth on playback. It's 2 x JMR 8x expanders linked into a single bridge card on slot 2 16X.

I've selected the optimised playback option and now I seem to have realtime on the GPU in the Colour window indicator (that was always at 16fps).

My GUI playback now stutters in what looks like around 15-16fps - so I'm assuming it's assigning resources to the Decklink feed instead?

No 4K monitor in today to test - 80+ inch TV coming in tomorrow to test the UHD over single HDMI input.

If all works out fine I shall report back and let you know.

Thanks.


Return to posts index

Jeff Brown
Re: Only 16fps playback using Decklink 4K extreme in Resolve
on Jun 16, 2013 at 1:16:51 pm

For anyone that's interested - the above worked fine.

I suspect the "optimise for playback" setting had the most impact.

I effectively got 15-16fps stutter in the GUI and realtime via the decklink.

Thanks for all the input chaps.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]