FORUMS: list search recent posts

Lock&Load in Motion 4

COW Forums : CoreMelt Plug-ins

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Helge Frueh
Lock&Load in Motion 4
on Sep 1, 2010 at 9:58:20 pm

Hi,

I am busy evaluating Lock&Load v2 with Motion 4. I like it very much so far, but there is one thing...

One particular file is kind of crashing Lock&Load. After pushing the "Track" button it shows the "Motion Tracking" - progress bar forever. It's not that it just takes a while it seems to not even start. There is no duration info showing. Pushing the "cancel tracking"-button doesn't help either. It just does not respond. The progress bar never stops running. This is with a clip (20sec, ProRes Proxy, 1920x1080i) sent from Final Cut.

Interestingly every other file (same format, same length) works just fine. And I know that this one bad file worked at least once.

Is it possible, that there is a damaged tracking data file for this particular clip somewhere on my drive? If so, I really like to delete this file. Where can I find it?

Thanks,
Helge


Return to posts index

Roger Bolton
Re: Lock&Load in Motion 4
on Sep 1, 2010 at 10:58:23 pm

Hi, can you upload that clip so we can look at it?

You can upload it to our public folder on idisk as follows.  In the finder go to the "Go" menu then select "idisk", "other users public folder".  Type "coremelt" as the user name (no password required).

Then create a new folder with your name on it to upload the clip to.

Thanks
Roger
CoreMelt

-
CoreMelt V2 plugins


Return to posts index

Helge Frueh
Re: Lock&Load in Motion 4
on Sep 2, 2010 at 9:26:15 pm

Hi Roger,

I did some further investigation and I think CoreMelt is innocent ;) If I just create a new motion project and insert the clip Lock&Load X is fine. It seems that this is a problem with "FCP sending a clip to Motion". I analyzed the Motion project file and found something interesting...

Inside the

scene
footage name
clip name

elements is a 'creationDuration' element which is 0 (!). This seems to be the reason for all L&L problems. I diffed the motion project file which came from FCP with one I created from scratch. Apart from other minor differences the most obvious was the 'creationDuration' element which was set to (in this case) 720. After editing the FCP Motion project file to 720 L&L worked just fine.

So I come to the conclusion that the 'sending to Motion'-process seems somewhat broken. At least if you are using L&L inside Motion. I haven't noticed any other problems with 'sending to Motion', though.

Strange...


Return to posts index


Eberhard Ammelt
Re: Lock&Load in Motion 4
on Sep 2, 2010 at 8:54:47 am

Does this occur with Lock & Load Frames or L&L X?
Can you please send me a crash log to eberhard (at) coremelt.com?

Regards, Eberhard


Return to posts index

Helge Frueh
Re: Lock&Load in Motion 4
on Sep 2, 2010 at 9:33:15 pm

Hi Eberhard,

this all happens with L&L X. I guess there is no technical crash. The progress bar just moves forever. Though I can't cancel the tracking process I can remove the whole filter from the clip. Where could I find the crash log if there is one?

Thanks,
Helge


Return to posts index

Eberhard Ammelt
Re: Lock&Load in Motion 4
on Sep 3, 2010 at 3:06:10 pm

You would find a Motion crash log in your home folder in Library/Logs/CrashReporter/Motion_....
Regarding the hanging of Lock & Load X could you please check the log file for any error reports?
You find the log file when you open the Console app in the utility app folder. Then select "All Messages" from the left hand table. Now launch Motion, apply Lock & Load X, and try to track motion. Is there written any message to the log file then?
In the activity monitor app do you see any cpu load in a process named "Lock & Load Tracker" ?

Regards, Eberhard


Return to posts index


Helge Frueh
Re: Lock&Load in Motion 4
on Sep 4, 2010 at 12:55:33 pm

Eberhard, I rechecked the console and there are no Motion specific crash reports. CPU utilization for the "Lock & Load Tracker" process is 0,1% (4 threads) while the progress bar is spinning.

But I found another message in the console which says:
04.09.10 14:39:26 Lock & Load Tracker[3250] Too short tracking range

The Motion project contains just one group with the clip in it. The Load & Load X filter is applied to the clip. The filter is exactly the same duration as the clip. The clip itself is 596 frames long.

I guess this is really strange behavior which is caused by the FCP-to-Motion sending process. This somehow screws up the 'creationDuration' XML-tag in the Motion project file (see above post).


Return to posts index

Eberhard Ammelt
Re: Lock&Load in Motion 4
on Sep 5, 2010 at 9:18:14 am

Could you please press the Alt/Option key and click on "Track Motion". This will write some useful information to the log file. Can you please send this to me at eberhard (at) coremelt.com?

Regards, Eberhard


Return to posts index

Helge Frueh
Re: Lock&Load in Motion 4
on Sep 5, 2010 at 10:40:00 am

Just sent you a pm.


Return to posts index


Eberhard Ammelt
Re: Lock&Load in Motion 4
on Sep 6, 2010 at 8:56:01 am

Ok, thanks. The problem with Lock & Load X is related to the wrong clipDuration specified by FCP, I can reproduce this behavior with this condition.
Lock & Load X should handle this problem more user friendly but it can't work correctly with a wrong clipDuration anyway. I suggest to open the clip directly in Motion.

Regards, Eberhard


Return to posts index

Helge Frueh
Re: Lock&Load in Motion 4
on Sep 6, 2010 at 8:18:29 pm

Thanks for looking into it, Eberhard.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]